Jump to content
  • 0
sgame

Modulo pago TPVV CECA 0.5 BETA

Question

Buenas a todos:

Hemos estado creando un modulo para poder realizar pagos a traves del
TPV Virtual de la CECA. Aun no esta listo para produccion pero si alguien
esta planteandose crear el mismo modulo puede ponerse en contacto
con nosotros a traves de este foro y colaborar en busca de un fin comun.

Trabajamos sobre la version 4.1 del TPVV.

Al final de esta semana veremos cuantos somos y como organizarlo.

Muchas gracias.

Un saludo
sgame.-

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hola de nuevo a todos.

 

 

 

Esto suele deberse a que está mal la configuración dentro del panel de CECA.

 

Tiene que poner donde dice comunicacion online ok (o similar) la opción si y en la url online ok (o similar) la ruta al archivo validation.php que suele ser http://tudominio.com.../validation.php (si no recuerdo mal).

 

Este error se debe en el 97% de los casos a esta mala configuración.

 

Saludos.

 

Acabo de adquirir tu módulo y tengo exactamente el mismo problema. La configuración de la url está bien, comunicación online ok SI y el pago se realiza correctamente porque me aparece en el listado de operaciones, pero al volver no se vacía el carrito, no manda mail, no guarda el pedido... Todo lo realizo en el entorno de pruebas.

 

Alguna otra solución?

 

Gracias.

Share this post


Link to post
Share on other sites
  • 0

 

Acabo de adquirir tu módulo y tengo exactamente el mismo problema. La configuración de la url está bien, comunicación online ok SI y el pago se realiza correctamente porque me aparece en el listado de operaciones, pero al volver no se vacía el carrito, no manda mail, no guarda el pedido... Todo lo realizo en el entorno de pruebas.

 

Alguna otra solución?

 

Gracias.

 

Copia la url que hayas puesto como url online ok en el panel de CECA y pegala en la barra de direcciones del navegador y pulsa intro.

 

Si efectivamente está correctamente configurada debaría aparecerte un mensaje que dice algo asi como validación sin post.

 

Si no te aparece el mensaje es que no está bien configurada.

 

Si necesitas más ayuda, por favor dirigete a http://www.quixotehosting.com/billing registrate y habre un ticket de soporte.

 

Necesitaré tu version de prestashop y estaría bien que pudieses darme acceso a tu tienda y tu panel de ceca para que yo pueda mirar.

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

 

Copia la url que hayas puesto como url online ok en el panel de CECA y pegala en la barra de direcciones del navegador y pulsa intro.

 

Si efectivamente está correctamente configurada debaría aparecerte un mensaje que dice algo asi como validación sin post.

 

Si no te aparece el mensaje es que no está bien configurada.

 

Si necesitas más ayuda, por favor dirigete a http://www.quixotehosting.com/billing registrate y habre un ticket de soporte.

 

Necesitaré tu version de prestashop y estaría bien que pudieses darme acceso a tu tienda y tu panel de ceca para que yo pueda mirar.

 

Saludos.

 

Mis disculpas, tenías toda la razón. Me decía que no existía la URL y me acabo de dar cuenta de que en esta tienda tengo la carpeta "shop" que no puse en la ruta.

 

Mil gracias!

Ángela

Share this post


Link to post
Share on other sites
  • 0

 

Mis disculpas, tenías toda la razón. Me decía que no existía la URL y me acabo de dar cuenta de que en esta tienda tengo la carpeta "shop" que no puse en la ruta.

 

Mil gracias!

Ángela

 

No hay de que...

 

Este error es el más común de todos y como ves no tiene que ver nada con el módulo.

 

Encantado de haberte ayudado.

Share this post


Link to post
Share on other sites
  • 0

Buenos días, hemos tenido la necesidad de utilizar el módulo de la CECA para un nuevo proyecto sobre la versión 1.5. Viendo que éste módulo no estaba aún actualizado nos metimos en harina y tras unas pequeñas correcciones y modificaciones ya es completamente funcional.

 

Con las nuevas modificaciones, no es necesario modificar el código, la clave de encriptación se mete como el resto de variables de configuración desde el back de la tienda. Sólo tendreis que subir al servidor la carpeta 'cecatpv', instalarlo e introducir, en configuración, los datos que os proporciona CECA.

 

Recordaros que para el correcto funcionamiento del módulo en el panel de administración de CECA>configuración, debeis de modificar las directivas citadas a continuación como sigue:

No queremos acabar el post sin agradecer el trabajo de sgame, ecomesana y bernardo2201, puesto que el grueso del trabajo tanto en programación, como en documentación recae en ellos habiéndonos sido de gran ayuda.

 

Como creemos que no hay mejor presentación que una aportación, aquí os dejamos el módulo.

Un saludo

cecatpv.zip

Share this post


Link to post
Share on other sites
  • 0

Hola, tenemos una tienda con la version 1.5.2. Supongo que este modulo valdra para todas las cajas de CECA (nuestro caso Caja Burgos).

Esto es correcto?

Por otro lado que datos debo introducir?

- Clave de encriptación del TPV.

- Código comercio (MerchantID).

- Código entidad (AcquirerBIN)

 

Y el resto lo dejo como estan?

 

Hay entorno de pruebas?

 

Muchas gracias

Edited by cidsa

Share this post


Link to post
Share on other sites
  • 0

Buenos días, hemos tenido la necesidad de utilizar el módulo de la CECA para un nuevo proyecto sobre la versión 1.5. Viendo que éste módulo no estaba aún actualizado nos metimos en harina y tras unas pequeñas correcciones y modificaciones ya es completamente funcional.

 

Con las nuevas modificaciones, no es necesario modificar el código, la clave de encriptación se mete como el resto de variables de configuración desde el back de la tienda. Sólo tendreis que subir al servidor la carpeta 'cecatpv', instalarlo e introducir, en configuración, los datos que os proporciona CECA.

 

Recordaros que para el correcto funcionamiento del módulo en el panel de administración de CECA>configuración, debeis de modificar las directivas citadas a continuación como sigue:

No queremos acabar el post sin agradecer el trabajo de sgame, ecomesana y bernardo2201, puesto que el grueso del trabajo tanto en programación, como en documentación recae en ellos habiéndonos sido de gran ayuda.

 

Como creemos que no hay mejor presentación que una aportación, aquí os dejamos el módulo.

Un saludo

 

¿Alguien lo ha probado? ¿funciona en la 1.5.3.1?

Share this post


Link to post
Share on other sites
  • 0

Hola:

He instalado el módulo y los pagos se realizan correctamente, envia los mails pero el pedido no se refleja ni en la cuenta del cliente ni en el BO. No se si es del módulo CECA ó del carrito.

¿Alguna idea?

www.nupani.com

Share this post


Link to post
Share on other sites
  • 0

Hola:

Estoy intentando usar este modulo en 1.5.3, pero me falla en que no cambia el estado del pedido.

 

El pago se hace correctamente, vuelve a la tienda, pero el pedido aparece sin estado, por lo que no me envia mail ni nada conforme hay un pedido.

 

La configuración está tal cual indica en las instrucciones.

 

Alguna pista por dónde mirar???

muchas gracias

Edited by eugeniotgn

Share this post


Link to post
Share on other sites
  • 0

Lo he instalado en un prestashop 1,5,4,1 y despues de usar todas las versiones qeu por aqui se proponen , he puesto la ultima modificada por "envista cultura visual" , como digo he probado todas con igual resultado. Gracias a todos los creadores y desarrolladores

 

Todo parece funcionar ok en entorno de pruebas, funciona fenomenal no falla nada y el email de debug perfecto todo ok.

 

Aquí viene el problema al pasar a entrono real:

 

En entrono real después de cambiar lógicamente URL y clave encripatcion , al llegar al pago en ceca me sale :

 

Operacion no autorizada : Operación no realizable (resto de casos)

 

Este es el error desde la web de ceca:

Código Error: ERR-190

Descripción: Operación no realizable (resto de casos)

 

Alguien se le ocurre algo. como digo en entorno de pruebas todo ok

 

Gracias de antemano.

Share this post


Link to post
Share on other sites
  • 0

por si alguien está trabajando con la 1.4.x y el módulo 0.61 y no le aparece el módulo en "pago" o en "módulos>pago", hay que cambiar en el archivo cecatpv.php donde dice

$this->tab = 'Payment';

por

$this->tab = 'payments_gateways';

es una tontería pero en mi caso que trabajo con diferentes grupos de usuarios, no aparecía el módulo ceca para los usuarios que no perteneciesen al grupo "Predeterminado"

Share this post


Link to post
Share on other sites
  • 0

Hola

 

Estoy usando el módulo del post #202 realizado por envista.

Módulo de pago "cecatpv" por Envista Cultura Visual, version 0.62.

Mi versión es 1.5.5.0

 

En principio esta todo bien configurado, pero a la hora de hacer un pago me devuelve este error

Error - Las firmas NO COINCIDEN

¿alguien sabe como solucionar esto?

 

Si pruebo la dirección de validadción escrita sobre el navegador devuelve: Validacion SIN POST de pago desde TPV CECA

se agradecería cualquier ayuda al respecto.

 

Saludos cordiales

Share this post


Link to post
Share on other sites
  • 0

Hola.

A ver si puedo ayudar a alguno.

 

Prestashop 1.5.5.0

Módulo: El del post  #209 de envista cultura visual ( GRACIAS ¡¡)

 

Al configurar el módulo en Prestashop, debajo de Clave de encriptación del TPV, donde pone URL del TPV, poner,

 

https://pgw.ceca.es/cgi-bin/tpv

 

El la configuración del TPV Virtual de CECA ( Página que os dará el banco), debe estar en "Datos reales"

 

131130021146113434.jpg

 

Espero os sirva. Salud

Edited by JuanCarlosG

Share this post


Link to post
Share on other sites
  • 0

GRACIAS!!!

 

Ahora funciona el módulo!  estaba informando mal de la url del TPV, he puesto la que indicabas y realiza las operaciones perfectamente.

 

gracias de nuevo

 

Hola.

A ver si puedo ayudar a alguno.

 

Prestashop 1.5.5.0

Módulo: El del post  #209 de envista cultura visual ( GRACIAS ¡¡)

 

Al configurar el módulo en Prestashop, debajo de Clave de encriptación del TPV, donde pone URL del TPV, poner,

 

https://pgw.ceca.es/cgi-bin/tpv

 

El la configuración del TPV Virtual de CECA ( Página que os dará el banco), debe estar en "Datos reales"

 

131130021146113434.jpg

 

Espero os sirva. Salud

 

Share this post


Link to post
Share on other sites
  • 0

Una duda puedo usar este modulo para que me paguen con tarjeta y llegue a mi banco?

A mi banco le pregunte si tenian TPV y me dijeron que no trabajaban con ellos.

Entonces me lio un poco, que necesito para usar este modulo y me paguen con tarjeta?

Share this post


Link to post
Share on other sites
  • 0

Aunque soy novata, agradezco la ayudan que me van dando y quiero corresponder.

Tendrás que pedirle a tu banco un TPV virtual que tendrás que configurar con el TPV. Pero no todos los bancos tienen el mismo, en mi caso tuve que comprar unmódulo pata CECA, eso te lo dirán en el banco.

Share this post


Link to post
Share on other sites
  • 0

Hola, muchas gracias, pero como indicaba mi banco me dijo que no trabajaban con tpv entonces que debo hacer para que me paguen con tarjeta ? descartando paypal.

Edited by azahara

Share this post


Link to post
Share on other sites
  • 0

Hola, muchas gracias, pero como indicaba mi banco me dijo que no trabajaban con tpv entonces que debo hacer para que me paguen con tarjeta ? descartando paypal.

  Extraño que tu banco o caja no disponga de ninguna pasarela de pago aunque sea con costo. Si no quieres usar paypal ni ninguna similar(que hay muchas)... si no recuerdo mal algunos hosting ofrecían sus propias pasarelas. La única solución sera cambiar de banco...  También existe la formula de tpv telefónico, no te lo recomiendo dado su alto riesgo en fraudes. (Osea mediante un scrip tu recives los datos de tarjeta y los tecleas en un tpv físico... insisto nada recomendable)

Share this post


Link to post
Share on other sites
  • 0

Hola.

A ver si puedo ayudar a alguno.

 

Prestashop 1.5.5.0

Módulo: El del post  #209 de envista cultura visual ( GRACIAS ¡¡)

 

Al configurar el módulo en Prestashop, debajo de Clave de encriptación del TPV, donde pone URL del TPV, poner,

 

https://pgw.ceca.es/cgi-bin/tpv

 

El la configuración del TPV Virtual de CECA ( Página que os dará el banco), debe estar en "Datos reales"

 

131130021146113434.jpg

 

Espero os sirva. Salud

 

 

Buenos días. Lo primero agradecer a todos los que habéis hecho posible este módulo.

Al lio.

Estoy intentando hacer funcionar el módulo V0.62 del post #209, me he leido este y varios hilos en relacion con el tema del tpv Ceca, y este es mi problema.

Creo tener todos los datos correctos, tanto en el configurador de Ceca, como en la configuración del módulo en el prestashop (v. 1.5.6.1)

He hecho pruebas tanto en pruebas como en real (cambiando por supuesto url y clave de encriptación) siempre con el mismo resultado. Se hace el pago correctamente, e incluso sale en el listado de operaciones de la consola de Ceca, pero cuando el cliente le da a Aceptar para terminar el pago, este retorna a order-history y no se ha creado ningún pedido, lo que conlleva que no se crean los respectivos emails etc.

 

Más datos:

He pasado los datos por ftp en binario y probado con permisos 775 y 755.

He probado desactivando y activando en el módulo el modo de depuración.

Al poner la url http://www.....com/modules/cecatpv/validation.php me da Validacion SIN POST de pago desde TPV CECA.

 

Me he puesto en contacto con Ceca directamente, pero de momento no he optenido respuesta.

 

Sin más agradecería si alguien me pudiese ayudar.

Un saludo y gracias por anticipado.

Share this post


Link to post
Share on other sites
  • 0

Buenos días,

Estaba teniendo también problemas con este modulo, al igual que vosotros se realizaba el pago pero no se reflejaba en prestashop. Con unas pequeñas modificaciones que le he hecho parece que ya funciona, aunque me gustaría poder mejorar la validación.
Lo adjunto por si lo queréis probar y detectar fallos sobre los que poder seguir avanzando.
Obviamente ni soy el propietario del modulo (espero que no les importe que lo haya modificado sin más) ni asumo las consecuencias que pueda ocasionar, si lo usáis es bajo vuestra responsabilidad y con el fin de que entre todos tengamos algo que funcione correctamente.

 

Un saludo!

cecatpv.zip

Share this post


Link to post
Share on other sites
  • 0

Buenos días,

 

Estaba teniendo también problemas con este modulo, al igual que vosotros se realizaba el pago pero no se reflejaba en prestashop. Con unas pequeñas modificaciones que le he hecho parece que ya funciona, aunque me gustaría poder mejorar la validación.

Lo adjunto por si lo queréis probar y detectar fallos sobre los que poder seguir avanzando.

Obviamente ni soy el propietario del modulo (espero que no les importe que lo haya modificado sin más) ni asumo las consecuencias que pueda ocasionar, si lo usáis es bajo vuestra responsabilidad y con el fin de que entre todos tengamos algo que funcione correctamente.

 

Un saludo!

 

 

Hola a todos. Gracias por vuestras aportaciones.

 

Acabo de instalar el módulo CECA TPV, el último colgado por chupetite y parece que funciona más o menos bien.

 

He hecho algunas pruebas de compras con mi tarjeta y, aunque no puedo ver reflejado todavía los movimientos en mi cuenta de la tarjeta ni en la cuenta de la tienda, las operaciones aparecen autorizadas en la consola de gestión del TPV. Además, y esto es muy importante, se genera bien el pedido en la tienda Prestashop.

 

Tan sólo veo algunas cosas que creo se deberían mejorar, sobre todo al comparar el funcionamiento de este módulo con el de otros que he tenido (como el de Redsys para La Caixa). Me refiero a que se genera el pedido y este aparece con el estado "Awaiting Credit Card Validation", cuando creo que debería aparecer "Pago recibido". Además no aparece el pago en el apartado "Modo de pago" del pedido, y creo que debería aparecer por defecto el pago que se acaba de realizar a través del TPV CECA, con indicación de la fecha, hora, método de pago, ID de transacción, monto y factura. Toda esta información debería aparecer de forma automática, para no tener que meterla a mano. Y es importante que aparezca para que después la factura conste como pagada.

 

Creo que esas son las mejoras que habría que hacer a este módulo para que funcionara del todo bien. Pero yo no tengo ni idea de como modificarlo para conseguir eso... ¿alguien podría echar una mano?

 

Gracias y un saludo a todos.

Share this post


Link to post
Share on other sites
  • 0

Hola a todos. Gracias por vuestras aportaciones.

 

Acabo de instalar el módulo CECA TPV, el último colgado por chupetite y parece que funciona más o menos bien.

 

He hecho algunas pruebas de compras con mi tarjeta y, aunque no puedo ver reflejado todavía los movimientos en mi cuenta de la tarjeta ni en la cuenta de la tienda, las operaciones aparecen autorizadas en la consola de gestión del TPV. Además, y esto es muy importante, se genera bien el pedido en la tienda Prestashop.

 

Tan sólo veo algunas cosas que creo se deberían mejorar, sobre todo al comparar el funcionamiento de este módulo con el de otros que he tenido (como el de Redsys para La Caixa). Me refiero a que se genera el pedido y este aparece con el estado "Awaiting Credit Card Validation", cuando creo que debería aparecer "Pago recibido". Además no aparece el pago en el apartado "Modo de pago" del pedido, y creo que debería aparecer por defecto el pago que se acaba de realizar a través del TPV CECA, con indicación de la fecha, hora, método de pago, ID de transacción, monto y factura. Toda esta información debería aparecer de forma automática, para no tener que meterla a mano. Y es importante que aparezca para que después la factura conste como pagada.

 

Creo que esas son las mejoras que habría que hacer a este módulo para que funcionara del todo bien. Pero yo no tengo ni idea de como modificarlo para conseguir eso... ¿alguien podría echar una mano?

 

Gracias y un saludo a todos.

 

Hola arizaruiz,

 

casi todo lo que comentas está funcionando, perdonad pero quizás mi post ha sido un poco escaso, como bien se comentaba en unas publicaciones anteriores, además de instalar el modulo hay que crear un nuevo estado para los pedidos, en mi caso he creado uno que es "Pagado CECA" (con el id 14) y con eso se crea automáticamente como pago recibido y te aparece en modo de pago con los datos que indicas fecha, hora, método de pago, id de transacción (este no estoy del todo seguro), monto y factura.

 

Creo recordar que en la documentación del modulo que publicaron en > en este post < te explican como crear los estados de los pedidos correctamente.

 

Un saludo!

Share this post


Link to post
Share on other sites
  • 0

Gracias chupetite por las indicaciones.

 

En este caso he creado el nuevo estado, pero no ha funcionado. Creo que es un tema del OK que debe dar la pasarela de pago, y he estado cambiando la configuración de ésta con los siguientes resultados.

 

He marcado en los campos de configuración:

 

Comunicación on-line OK: Sí

URL online OK: http://midominio/modules/cecatpv/validation.php

Respuesta requerida OK: No

 

Con esta configuración ahora sí me pone el estado del pedido con Pago recibido, y en la ficha del pedido ya aparece la información  del pago, con Fecha y hora, método de pago y monto (no aparece el ID de transacción).

 

Hasta ahí todo bien, el problema es que con esta configuración al cliente, cuando termina de aceptar el pago, le aparece un mensaje de "La compra no se puede cargar o una orden ya se ha colocado en este carro"

 

He intentado distintas configuraciones y no se como hacer para que no aparezca este mensaje en la tienda. El pedido parece que está bien realizado, pero aparece este error.

 

¿alguien sabe la razón y cómo poder solucionarlo?

 

 

Gracias y saludos a todos.

Share this post


Link to post
Share on other sites
  • 0

Gracias chupetite por las indicaciones.

 

En este caso he creado el nuevo estado, pero no ha funcionado. Creo que es un tema del OK que debe dar la pasarela de pago, y he estado cambiando la configuración de ésta con los siguientes resultados.

 

He marcado en los campos de configuración:

 

Comunicación on-line OK: Sí

URL online OK: http://midominio/modules/cecatpv/validation.php

Respuesta requerida OK: No

 

Con esta configuración ahora sí me pone el estado del pedido con Pago recibido, y en la ficha del pedido ya aparece la información  del pago, con Fecha y hora, método de pago y monto (no aparece el ID de transacción).

 

Hasta ahí todo bien, el problema es que con esta configuración al cliente, cuando termina de aceptar el pago, le aparece un mensaje de "La compra no se puede cargar o una orden ya se ha colocado en este carro"

 

He intentado distintas configuraciones y no se como hacer para que no aparezca este mensaje en la tienda. El pedido parece que está bien realizado, pero aparece este error.

 

¿alguien sabe la razón y cómo poder solucionarlo?

 

 

Gracias y saludos a todos.

 

Comenta la linea 29 del archivo back.php, para no añadir dos veces el pedido:

 

//$cecatpv->validateOrder($id, $id_estado_esperando_banco, $cantidad, $cecatpv->displayName, 'Pago recibido.');

 

Al utilizar la "Comunicación on-line OK: Si",  la orden del pedido se añade desde el archivo validation.php, que se ejecuta cuando el pago se realiza correctamente y antes de salir de la pagina del TPV pulsando al boton de aceptar.

 

TPV Pago--> (si pago es correcto) ----> validation.php ---> ventana del TPV de pago correcto---->(si click aceptar) ---> URL_OK (back.php)

                                       

Share this post


Link to post
Share on other sites
  • 0

Hola buenas tardes:

He instalado el modulo en  prestashop 1.5.6.1 y funciona correctamente, solamente que cuanto termina toda la compra, no me lleva a la pagina orden-confirmacion.php o historialdepedidos ya que tengo url amigables.

se queda en http://www.midominio.com/modules/cecatpv/back.php?id=112&c=001&ok=1

alguna idea?

 

 

gracias

 

Me respondo

comentar la linea que se dice en el post de arriba

//$cecatpv->validateOrder($id, $id_estado_esperando_banco, $cantidad, $cecatpv->displayName, 'Pago recibido.');

Edited by angeles33

Share this post


Link to post
Share on other sites
  • 0

Muy buenas.

 

Primer agradecer que una persona haga un modulo gratis, como el que nos ocupa.

 

Resulta que todo el mundo tiene la version 1.5 de prestashop, pero yo utilizo la 1.6, he instalado el modulo, pero no me funciona correctamente y explico mi problema.

 

Cuando pulso el boton de confirmar en la pasarela de pago, me digire a www.midominio/back.php

 

una vez pulsado efectivamente esto en prestashop, pero como si no hubiera pagado nada, por lo que si intengo pagar de nuevo, me aparece el mismo numero de pedido.

 

Agradezco que alguien me pueda indicar que solucion tengo.

 

un saludo

Share this post


Link to post
Share on other sites
  • 0

Hola a todos, a ver quien puede echarme una mano.

He instalado el módulo de pago correctamente y me realiza los pagos sin problema.

Pero una vez realizado el pago el cliente vuelve a su historico de pedidos, y no le aparece reflejado, así como tampoco se borra el carrito.

He probado varias soluciones como por ejemplo escribir en el navegado la dirección URL OK Online:

Pero lo que me aparece es esto:

 

Fatal error: Call to undefined method Configuration::getValue() in /home/aceiteac/public_html/modules/cecatpv/cecatpv.php on line 235

 

Por favor necesito ayuda.

Gracias

Share this post


Link to post
Share on other sites
  • 0

Hola,

 

Yo también utilizo la versión 1.6 y no consigo que cuando un cliente hace una compra y la paga mediante el módulo CECA el pedido se confirme automáticamente (por lo que no envía el email, google analytics no trackea el pedido, etc.)  como lo hacía en anteriores versiones de prestashop.

 

Parece ser que hay que crear un nuevo estado? he intentado seguir los pasos para asignar un nuevo estado que se han mencionado en este post pero no lo consigo...

 

¿cómo lo habéis conseguido?

 

Millones de gracias de antemano!

Share this post


Link to post
Share on other sites
  • 0

Hola.

A ver si puedo ayudar a alguno.

 

Prestashop 1.5.5.0

Módulo: El del post  #209 de envista cultura visual ( GRACIAS ¡¡)

 

Al configurar el módulo en Prestashop, debajo de Clave de encriptación del TPV, donde pone URL del TPV, poner,

 

https://pgw.ceca.es/cgi-bin/tpv

 

El la configuración del TPV Virtual de CECA ( Página que os dará el banco), debe estar en "Datos reales"

 

131130021146113434.jpg

 

Espero os sirva. Salud

 

Muchas gracias por las aclaraciones.

 

Probado y funcionado en PS 1.6 con la configuración que tu indicas.

Share this post


Link to post
Share on other sites
  • 0

Hola a todos, 

 

Es la primera vez que escribo en un foro pero la ocasión lo merece. Un 10 para el módulo y un 11 para todas las aportaciones que se han hecho en el foro para facilitarnos la vida a los menos expertos.

 

Módulo CECA funcionando en Prestashop 1.6.

 

GRACIAS.

Share this post


Link to post
Share on other sites
  • 0

Hola a todos, 

 

Es la primera vez que escribo en un foro pero la ocasión lo merece. Un 10 para el módulo y un 11 para todas las aportaciones que se han hecho en el foro para facilitarnos la vida a los menos expertos.

 

Módulo CECA funcionando en Prestashop 1.6.

 

GRACIAS.

 

Hola, mira una consulta, a ver si me puedes ayudar, probé el módulo y bien en entorno pruebas, pero ¿cómo puedo pasarla a entorno real? Ya que ahora le coloco los datos que me han dado los del tpv para el entorno real, pero veo que las operaciones me siguen entrando por un entorno de pruebas. 

 

¿Se cambia algo en el prestashop?

 

Saludos y gracias de antemano

Share this post


Link to post
Share on other sites
  • 0

Buenos días, hemos tenido la necesidad de utilizar el módulo de la CECA para un nuevo proyecto sobre la versión 1.5. Viendo que éste módulo no estaba aún actualizado nos metimos en harina y tras unas pequeñas correcciones y modificaciones ya es completamente funcional.

 

Con las nuevas modificaciones, no es necesario modificar el código, la clave de encriptación se mete como el resto de variables de configuración desde el back de la tienda. Sólo tendreis que subir al servidor la carpeta 'cecatpv', instalarlo e introducir, en configuración, los datos que os proporciona CECA.

 

Recordaros que para el correcto funcionamiento del módulo en el panel de administración de CECA>configuración, debeis de modificar las directivas citadas a continuación como sigue:

No queremos acabar el post sin agradecer el trabajo de sgame, ecomesana y bernardo2201, puesto que el grueso del trabajo tanto en programación, como en documentación recae en ellos habiéndonos sido de gran ayuda.

 

Como creemos que no hay mejor presentación que una aportación, aquí os dejamos el módulo.

Un saludo

 

Hola!

he instalado el módulo en prestashop 1.6.1 y me está dando un error de que las firmas no coinciden. No sé qué es lo que estoy haciendo mal... ¿Alguien me puede ayudar?

 

Mil gracias!

Share this post


Link to post
Share on other sites
  • 0

Hola a todos,

 

Utilizo la versión 1.6.1.5 de PrestaShop.

 

He adquirido el módulo TPV CECA 1.3.0 supuestamente compatible con PrestaShop 1.6.x en la página http://www.quixotehosting.com/shop/es/modulos/27-ceca-tpv-modulo-prestashop-v-16.html, lo intento instalar como módulo (Añadir un nuevo módulo) y no se añade/instala, sale un mensaje en verde en la parte superiror que dice: "se ha descargado correctamente" pero no aparece por ningún lado.

 

Por favor, alguien me puede ayudar con este problema.

 

Saludos.

 

 

Share this post


Link to post
Share on other sites
  • 0

 

Hola a todos,

 

Utilizo la versión 1.6.1.5 de PrestaShop.

 

He adquirido el módulo TPV CECA 1.3.0 supuestamente compatible con PrestaShop 1.6.x en la página http://www.quixotehosting.com/shop/es/modulos/27-ceca-tpv-modulo-prestashop-v-16.html, lo intento instalar como módulo (Añadir un nuevo módulo) y no se añade/instala, sale un mensaje en verde en la parte superiror que dice: "se ha descargado correctamente" pero no aparece por ningún lado.

 

Por favor, alguien me puede ayudar con este problema.

 

Saludos.

 

 

 

Por cierto, en realidad, creo que el tema actual se supone que es para hablar del "modulo/aportes" gratuitos en referencia a ceca... xD

 

Referente al modulo que dices que has comprado, mira ver si aparece bien subido desde el ftp en el directorio modules (es decir "carpeta del modulo y dentro todo lo del modulo")

 

Saludos,

Share this post


Link to post
Share on other sites
  • 0

Hola,

 

Muchas gracias Sergio.

 

Lamento si no es el hilo correcto de conversación. Culpa mia por no fijarme. Si es necesario creo un tema nuevo con el problema y ya está.

 

He comprobado las carpetas de los módulo a través del FTP y resulta que no aparece, es como si no se instalara nada. Ahora bien, será que PrestaShop no está instalando el módulo...

 

Hice un pantallazo de la supuesta instalación: https://drive.google.com/open?id=0By6IzpX73MZSSU4yeUhWQnd3T0U

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola,

 

Muchas gracias Sergio.

 

Lamento si no es el hilo correcto de conversación. Culpa mia por no fijarme. Si es necesario creo un tema nuevo con el problema y ya está.

 

He comprobado las carpetas de los módulo a través del FTP y resulta que no aparece, es como si no se instalara nada. Ahora bien, será que PrestaShop no está instalando el módulo...

 

Hice un pantallazo de la supuesta instalación: https://drive.google.com/open?id=0By6IzpX73MZSSU4yeUhWQnd3T0U

 

Saludos.

Prueba subir "el directorio del modulo" (carpeta descomprimida) al directorio modules desde el ftp o administrador de archivos de tu hosting depende subir el zip desde la pestaña modulos -> modulos, y luego intenta buscar el modulo desde la pestaña modulos -> modulos, a ver si te aparece.

 

Saludos,

Share this post


Link to post
Share on other sites
  • 0

Hola de nuevo,

 

Gracias por su respuesta pero no ha funcionado. No aparece el módulo instalado en PrestaShop.

 

He escrito al servicio de soporte de Quixote y ni siquieras sé si me contestarán. No sé que hacer.

 

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola de nuevo,

 

Gracias por su respuesta pero no ha funcionado. No aparece el módulo instalado en PrestaShop.

 

He escrito al servicio de soporte de Quixote y ni siquieras sé si me contestarán. No sé que hacer.

 

 

Saludos.

Si quieres enviame datos de acceso por privado y veo al menos porque no se te esta "subiendo". (Para instalarlo, primero tiene que aparecer reflejado como subido)

 

Saludos,

Share this post


Link to post
Share on other sites
  • 0

Hola Nadie;

 

Gracias por su ayuda.

 

He intentado enviarte un mensaje privado pero sale un mensaje en rojo que dice; "El miembro nadie no puede recibir nuevos mensajes".

 

Como lo hacemos?

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola Nadie;

 

Gracias por su ayuda.

 

He intentado enviarte un mensaje privado pero sale un mensaje en rojo que dice; "El miembro nadie no puede recibir nuevos mensajes".

 

Como lo hacemos?

 

Saludos.

Te lo envie esta mañana. (Aunque ya hemos hablado por privado te comento xD)

 

Referente al modulo que me has enviado por privado para que lo revise, que veo que se llama en tu caso:

tpvceca_13_PS16X.zip

Y he visto que el modulo para poder instalarlo se tiene que llamar el directorio del modulo: (ya que la clase principal del modulo se llama asi)

tpvceca

Descomprimelo en tu ordenador, renombra el directorio del modulo de:

tpvceca_13_PS16X

a

tpvceca

Vuelve a comprimirlo en "zip", y intenta subirlo ahora desde la pestaña modulos -> modulos.

 

Iba a intentarlo yo, pero me has pasado la contraseña para entrar al panel de tu tienda, pero no el email para entrar.

 

Saludos,

Share this post


Link to post
Share on other sites
  • 0

Hola Nadie,

 

¡Solucionado! No entiendo porq venden algo así, dificultando de este modo su intalación.

 

Muchas gracias de nuevo.

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola Nadie,

 

¡Solucionado! No entiendo porq venden algo así, dificultando de este modo su intalación.

 

Muchas gracias de nuevo.

 

Saludos.

Hola buenos dias, te funciona correctamente en prestashop 1.6? yo he descargado la version que aportan en este foro pero no me termina de funcionar bien, Normalmente el pago suele fallar aun termina cobrandose, pero el pedido no se cierra, en Prestashop no aparece como que haya pedido pero al cliente si se le cobra el dinero. Alguien puede ayudarme?

Share this post


Link to post
Share on other sites
  • 0

Hola Chumaufo,

 

Nadie me ha solucionado lo de la instalación pero yo también tengo el problema de los pedidos que no se tramitan en PrestaShop.

 

Donde he adquirido el módulo me han timado y no me contestan y nadie me ha dado una solución para ese tema.

 

Al final he decidido cambiar de banco para así trabajar sin problema con Redsys.

 

Es lo que me ha tocado.

 

Te deseo suerte y paciencia.

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola Chumaufo,

 

Nadie me ha solucionado lo de la instalación pero yo también tengo el problema de los pedidos que no se tramitan en PrestaShop.

 

Donde he adquirido el módulo me han timado y no me contestan y nadie me ha dado una solución para ese tema.

 

Al final he decidido cambiar de banco para así trabajar sin problema con Redsys.

 

Es lo que me ha tocado.

 

Te deseo suerte y paciencia.

 

Saludos.

 

Hola, habria alguna posibilidad de que yo probase ese modulo?

Share this post


Link to post
Share on other sites
  • 0

Hola chumaufo;

 

Perdona, he estado muy liado.

 

Sí, quieres que te pase un link para que lo descargues? Pero te advierto, los pedido no se tramitan después de los pago, aún que los pagos se realizan correctamente.

 

Saludos.

Share this post


Link to post
Share on other sites
  • 0

Hola chumaufo;

 

Perdona, he estado muy liado.

 

Sí, quieres que te pase un link para que lo descargues? Pero te advierto, los pedido no se tramitan después de los pago, aún que los pagos se realizan correctamente.

 

Saludos.

 

Qiuza sea porque es para la version 1.5, creo q es lo que sucede con el modulo que descargue del foro. Voy a comprar otro que vi, ya os contaré que tal

Share this post


Link to post
Share on other sites
  • 0

gracias @chumaufo, en cuanto salga la version para 1.7 me lo compraré, que tengo la tienda en el horno ya.....solo me faltan detalles

 

Si alguno sabe donde comprar/compartir el modulo TPV para CECA que me avise por privado, saludos

Share this post


Link to post
Share on other sites
  • 0

gracias @chumaufo, en cuanto salga la version para 1.7 me lo compraré, que tengo la tienda en el horno ya.....solo me faltan detalles

 

Si alguno sabe donde comprar/compartir el modulo TPV para CECA que me avise por privado, saludos

Respecto a "comprar" en la tienda de módulos oficial (en addons) de Prestashop tiene alguno funcional para Prestashop 1.7, según estoy viendo.

Share this post


Link to post
Share on other sites
  • 0

Hola a todos,

Normalmente me dedico a leer, de hecho creo que es el primer mensaje que escribo en los años que llevo registrada.

Sólo quería decir que el fallo de que hace los cobros pero no tramita el pedido, no tengo ni idea de por qué ocurre, pero yo compré el módulo del TPV Ceca en la versión V2.6 en el addons de Prestashop, para mi tienda en ps 1.4.8.2 . Al principio y durante un tiempo funcionó perfectamente, un buen día empezó a dar este fallo de manera aleatoria, contacté con el soporte de Ceca y no me sirvió de mucho, aparentemente todo estaba bien. El fallo a día de hoy sigue ocurriendo, de forma impredecible, va por rachas. Rachas de 6 pedidos seguidos que falla. Luego semanas funcionando bien... Llevo varios años así.

Buscando este problema me encontré que también hay gente que le ocurre con el de Red Sys, gente que le ocurre con el de Ceca en diferentes versiones y con diferentes versiones de Prestashop, así que ni idea de la causa, pero es un fallo que lleva unos cuantos años pasando y nunca he encontrado a nadie que lo resuelva o le de explicación. Incluso gente que "aparentemente" lo resuelve, unos meses más tarde vuelve a escribir que le sigue pasando... Yo no soy ninguna experta, y ya he perdido la esperanza de encontrar solución, tampoco puedo cambiar de banco y aún así no sé si me pasaría también con el de Res Sys como otros que he leído.  Por suerte o por desgracia mi tienda tiene poco tráfico así que por ahora sigo resignada con mi ruleta rusa de TPV. 

No tengo más que aportar, sólo era compartir mi caso.

 

Saludos a todos.

Share this post


Link to post
Share on other sites
  • 0
En 6/6/2018 a las 3:17 PM, LittleSister dijo:

Hola a todos,

Normalmente me dedico a leer, de hecho creo que es el primer mensaje que escribo en los años que llevo registrada.

Sólo quería decir que el fallo de que hace los cobros pero no tramita el pedido, no tengo ni idea de por qué ocurre, pero yo compré el módulo del TPV Ceca en la versión V2.6 en el addons de Prestashop, para mi tienda en ps 1.4.8.2 . Al principio y durante un tiempo funcionó perfectamente, un buen día empezó a dar este fallo de manera aleatoria, contacté con el soporte de Ceca y no me sirvió de mucho, aparentemente todo estaba bien. El fallo a día de hoy sigue ocurriendo, de forma impredecible, va por rachas. Rachas de 6 pedidos seguidos que falla. Luego semanas funcionando bien... Llevo varios años así.

Buscando este problema me encontré que también hay gente que le ocurre con el de Red Sys, gente que le ocurre con el de Ceca en diferentes versiones y con diferentes versiones de Prestashop, así que ni idea de la causa, pero es un fallo que lleva unos cuantos años pasando y nunca he encontrado a nadie que lo resuelva o le de explicación. Incluso gente que "aparentemente" lo resuelve, unos meses más tarde vuelve a escribir que le sigue pasando... Yo no soy ninguna experta, y ya he perdido la esperanza de encontrar solución, tampoco puedo cambiar de banco y aún así no sé si me pasaría también con el de Res Sys como otros que he leído.  Por suerte o por desgracia mi tienda tiene poco tráfico así que por ahora sigo resignada con mi ruleta rusa de TPV. 

No tengo más que aportar, sólo era compartir mi caso.

 

Saludos a todos.

Hola!

yo tengo unos clientes a los que les pasa esto mismo, y según he observado el comportamiento lo achaco al servidor. Si el servidor se colapsa y tiene muchas peticiones a la base de datos la web contacta con el TPV, hace el cobro bien, pero cuando el TPV devuelve a la tienda "cobro OK", el servidor está colapsado y no le llega la respuesta a tiempo. Por lo que el banco hace el cobro pero tú no ves qué ha comprado el cliente.

Observa si esto te sucede en momentos en los que tengas muchas visitas, o habla con tu proveedor de host por si ellos ven que tengas picos de conexiones de usuarios.

Un saludo!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More