Jump to content

Upload foto non funziona anche con permessi giusti


Acyd
 Share

Recommended Posts

Ho scaricato ed installato la versione 1.1.0.5 italiana.

Creando un nuovo prodotto o modificando altre immagini tramite upload con form integrato non funziona, non carica nulla. Le directory hanno permessi esatti 777.

Grazie

Share this post


Link to post
Share on other sites

Ti ringrazio della risposta.

Il server è unix, è mio, con 777 ha permessi totali di scrittura ed esecuzione, forse anche troppo direi.

Ma proprio non va.

Directory img/ admin - c - co - l - m - os - p - s -scenes - su - t - tmp tutte a 777

Se non sbaglio i prodotti li mette in p ma proprio non funziona.

Qualche file da controllare? Qualche funzione?

Share this post


Link to post
Share on other sites

ma 755 è più restrittivo di 777, per cui con 777 deve funzionare per forza ... a meno che aruba non permetta il setting a 777 (che significa permesso di lettura/scrittura/esecuzione da parte di proprietario/gruppo/chiunque) per motivi di sicurezza ... per cui magari setti a 777 via ftp e in realtà questo non avviene ... alcuni provider non permettono il 777 perché troppo permissivo

Share this post


Link to post
Share on other sites

forse il problema è di altro tipo, io l'ho sto testando su ubuntu server e settando a 777 è tutto ok (anche se non mi piace molto questa cosa dei permessi al massimo) ... hai un msg di errore quando fai upload? lo dovresti avere se il problema è sui permessi

Share this post


Link to post
Share on other sites

Aggiungo per completezza che ho altri domini con wordpress che ha un upload di foto e funziona con 777 anzi anche con 755 o 666


infatti dovrebbe funzionare anche a 755, se davvero il codice di prestashop ha bisogno di cosi' tanti permessi significa che non è fatto troppo bene, e questo mi inquieta un pò ... è da indagare

Share this post


Link to post
Share on other sites

No, nessun errore, mi da "Aggiornamento eseguito con successo".

Ma non esegue nulla.


non sono sicuro al 100% ma ti dovrebbe dare un errore o almeno un warning di php, se il problema è quello dei permessi ... hai i warning attivi?
io se non setto a 777 ho addirittura dei warning quando tenta di caricare l'immagine associata al prodotto! che è un pò demenziale che abbia bisogno di TUTTI i permessi per solamente leggere un'immagine

Share this post


Link to post
Share on other sites

In effetti hai ragione, potrebbe anche essere un problema di spostamento del temporaneo da parte del server.
Gli altri domini hanno comunque una configurazione propria.

Ora controllo.

Comunque nell'installazione fa mettere a 777 anche altre directory come i modules ad esempio, ora l'ho riportata a 755, non è il massimo ma è comune a tutti i cms. Dovrebbe essere detto da qualche parte, ammesso che non ci sia un manuale che non conosco.
Lasciare directory a 777 con dentro moduli non mi sembra sicuro.

Ma parlo da admin, non conosco bene Prestashop, non vorrei criticare una cosa che non conosco bene.

Share this post


Link to post
Share on other sites

fammi sapere cosa scopri che mi interessa, dato che anche a me la cosa non piace a livello di sicurezza ... i manuali te li puoi scordare, praticamente non esistono, ma non si può chiedere troppo a un open source così giovane, che cmq ha un codice pulito e facile da modificare.

Share this post


Link to post
Share on other sites

In effetti hai ragione, potrebbe anche essere un problema di spostamento del temporaneo da parte del server.
Gli altri domini hanno comunque una configurazione propria.

Ora controllo.

Comunque nell'installazione fa mettere a 777 anche altre directory come i modules ad esempio, ora l'ho riportata a 755, non è il massimo ma è comune a tutti i cms. Dovrebbe essere detto da qualche parte, ammesso che non ci sia un manuale che non conosco.
Lasciare directory a 777 con dentro moduli non mi sembra sicuro.

Ma parlo da admin, non conosco bene Prestashop, non vorrei criticare una cosa che non conosco bene.


Secondo me rischiate di fare un pò di confusione (sopratutto sulla sicurezza). Io ho installato la versione 1.1 Italia su Linux di Aruba, i permessi sono tutti 755 e vi assicuro che non ho problemi ne di sicurezza tanto meno di operatività. L'unico problema che riscontro (credo che riscontrino anche gli altri visto che ci sono diversi post) è quello di far funzionare diversi moduli creati dagli utenti del forum. Per quanto mi riguarda il mio negozio gira bene, le transazioni avvengono regolarmente e la comunicabilità con i Clienti è abbastanza buona. Credo sia più opportuno controllare i propri hosting perima di criticare PS che tra l'altro è GRATIS.

Buon lavoro ragazzi

Share this post


Link to post
Share on other sites

In effetti hai ragione, potrebbe anche essere un problema di spostamento del temporaneo da parte del server.
Gli altri domini hanno comunque una configurazione propria.

Ora controllo.

Comunque nell'installazione fa mettere a 777 anche altre directory come i modules ad esempio, ora l'ho riportata a 755, non è il massimo ma è comune a tutti i cms. Dovrebbe essere detto da qualche parte, ammesso che non ci sia un manuale che non conosco.
Lasciare directory a 777 con dentro moduli non mi sembra sicuro.

Ma parlo da admin, non conosco bene Prestashop, non vorrei criticare una cosa che non conosco bene.


Secondo me rischiate di fare un pò di confusione (sopratutto sulla sicurezza). Io ho installato la versione 1.1 Italia su Linux di Aruba, i permessi sono tutti 755 e vi assicuro che non ho problemi ne di sicurezza tanto meno di operatività. L'unico problema che riscontro (credo che riscontrino anche gli altri visto che ci sono diversi post) è quello di far funzionare diversi moduli creati dagli utenti del forum. Per quanto mi riguarda il mio negozio gira bene, le transazioni avvengono regolarmente e la comunicabilità con i Clienti è abbastanza buona. Credo sia più opportuno controllare i propri hosting perima di criticare PS che tra l'altro è GRATIS.

Buon lavoro ragazzi


scusami, ma mi sento libero di criticare chi e cosa voglio (e cmq non era ancora una critica ma solo supposizioni) ... se tutto ti funziona a 755 meglio, significa che avrai meno problemi di sicurezza, il contrario se invece sei costretto a usare 777 ... ah, poi mi spieghi come fai a sapere che non hai problemi di sicurezza, il fatto che nessuno ti abbia ancora bucato il sito non significa che non avverrà mai ;-)

Share this post


Link to post
Share on other sites

In effetti hai ragione, potrebbe anche essere un problema di spostamento del temporaneo da parte del server.
Gli altri domini hanno comunque una configurazione propria.

Ora controllo.

Comunque nell'installazione fa mettere a 777 anche altre directory come i modules ad esempio, ora l'ho riportata a 755, non è il massimo ma è comune a tutti i cms. Dovrebbe essere detto da qualche parte, ammesso che non ci sia un manuale che non conosco.
Lasciare directory a 777 con dentro moduli non mi sembra sicuro.

Ma parlo da admin, non conosco bene Prestashop, non vorrei criticare una cosa che non conosco bene.


Secondo me rischiate di fare un pò di confusione (sopratutto sulla sicurezza). Io ho installato la versione 1.1 Italia su Linux di Aruba, i permessi sono tutti 755 e vi assicuro che non ho problemi ne di sicurezza tanto meno di operatività. L'unico problema che riscontro (credo che riscontrino anche gli altri visto che ci sono diversi post) è quello di far funzionare diversi moduli creati dagli utenti del forum. Per quanto mi riguarda il mio negozio gira bene, le transazioni avvengono regolarmente e la comunicabilità con i Clienti è abbastanza buona. Credo sia più opportuno controllare i propri hosting perima di criticare PS che tra l'altro è GRATIS.

Buon lavoro ragazzi


scusami, ma mi sento libero di criticare chi e cosa voglio (e cmq non era ancora una critica ma solo supposizioni) ... se tutto ti funziona a 755 meglio, significa che avrai meno problemi di sicurezza, il contrario se invece sei costretto a usare 777 ... ah, poi mi spieghi come fai a sapere che non hai problemi di sicurezza, il fatto che nessuno ti abbia ancora bucato il sito non significa che non avverrà mai ;-)


Non sò cosa ne ricava uno a bucarmi il sito. E cmq evidentemente ha tanto tempo libero e magari non è di lunedì per poter guadare GF e farsi i c... degli altri. :lol:

Share this post


Link to post
Share on other sites



Secondo me rischiate di fare un pò di confusione (sopratutto sulla sicurezza). Io ho installato la versione 1.1 Italia su Linux di Aruba, i permessi sono tutti 755 e vi assicuro che non ho problemi ne di sicurezza tanto meno di operatività. L'unico problema che riscontro (credo che riscontrino anche gli altri visto che ci sono diversi post) è quello di far funzionare diversi moduli creati dagli utenti del forum. Per quanto mi riguarda il mio negozio gira bene, le transazioni avvengono regolarmente e la comunicabilità con i Clienti è abbastanza buona. Credo sia più opportuno controllare i propri hosting perima di criticare PS che tra l'altro è GRATIS.

Buon lavoro ragazzi


Sulla sicurezza non credo proprio, è il mio lavoro da anni.

Ho detto che controllerò i server, e ho detto che non critico senza controllare. Dopotutto la critica, e la ricerca di soluzioni, se fondata, è il sale dell'Open Source. Linux docet.

Share this post


Link to post
Share on other sites

Come promesso preciso. Il difetto era nel server, o meglio, nella necessità di togliere il safemode per caricare l'immagine. Il file può essere inserito solo con 777 e rimane comunque una cosa che si può migliorare.

Risolto comunque.

Share this post


Link to post
Share on other sites

Come promesso preciso. Il difetto era nel server, o meglio, nella necessità di togliere il safemode per caricare l'immagine. Il file può essere inserito solo con 777 e rimane comunque una cosa che si può migliorare.

Risolto comunque.


grazie per la segnalazione, anche io su ubuntu sono costretto ad aprire a 777.

Share this post


Link to post
Share on other sites

Scusa di che? figurati :)

Si Benway, purtroppo senza 777 non va. Ma questo forse è il meno, andrebbero, a mio parere, inseriti dei warning e delle indicazioni per chi non è molto esperto di cambiare alcuni permessi a directory o file che sono stati messi a 777 per l'install.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More