Jump to content

[Risolto] errore navigazione a strati e ordinamento per filtri non funzionante


darkinlight
 Share

Recommended Posts

salve a tutti !

 

credo che il problema che ho riscontrato sia dipendente dal modulo blocklayerednavigation

 

in pratica quando questo e' attivo nelle pagine delle varie categorie e' impossibile visualizzare pagine successive alle prime

 

mi spiego meglio, se ho 24 prodotti in una categoria tramite visualizzazione a 10 articoli per pagina vengono conteggiate esattamente 3 pagine, tuttavia cliccando su "successivo" o sul numero di pagina seguente la pagina caricata rimane vuota, senza articoli.

 

l'unica soluzione che ho trovato, spulciando per bene i forum in lignua ita e eng e' la disattivazione del modulo stesso e in effetti il problema e' risolto le pagine successive alla prima vengono visualizzate correttamente

 

ho riscontrato allora un altro errore nel sorting per prezzo / attributi / ecc. delle varie categorie, tale funzione e' infatti non funzionante, selezionando un quasiasi filtro dalla tendina non succede niente

 

ho allora applicato il fix di cui

http://forge.prestas...anel#issue-tabs

 

e riattivato il modulo della navigazione a strati

 

risultato:

"pagine successive" non funzionanti e filtro degli articoli non funzionante

tornando a disattivare il modulo si torna ad avere solo il filtraggio non funzionante

 

spero sinceramente qualcuno possa aiutarmi, grazie in anticipo =)

 

tema utilizzato : versione modificata del free_black

versione prestashop : 1.4.3

 

-ema

Share this post


Link to post
Share on other sites

aggiornamento:

ho risolto tutto =)

 

1) disabilitato la cache

2) pulito /tools/smarty/compile e /tools/smarty/cache

3) ripristinato versione originale (1.4.3) del modulo blocklayered

4) riabilitato la cache (in modalità sistema di file)

5) dalla configurazione del modulo ho reinizializzato il database della navigazione a strati

 

e funziona tutto, lascio scritto così se qualcuno si ritrova nella mia stessa situazione può provare in questo modo =)

 

grazie comunque a tutti

 

-ema

Share this post


Link to post
Share on other sites

il modulo e' pieno di bug e crea parecchi casini tra cui il casino piu' noto e' quello di non riuscire poi a navigare tra le varie pagine quando il filtro e' attivato. e' comunque risaputo e anche scritto nel backoffice che non e' una versione utilizzabile....

Share this post


Link to post
Share on other sites

  • 7 years later...
On 10/24/2011 at 1:23 PM, darkinlight said:

aggiornamento:

ho risolto tutto =)

 

1) disabilitato la cache

2) pulito /tools/smarty/compile e /tools/smarty/cache

3) ripristinato versione originale (1.4.3) del modulo blocklayered

4) riabilitato la cache (in modalità sistema di file)

5) dalla configurazione del modulo ho reinizializzato il database della navigazione a strati

 

e funziona tutto, lascio scritto così se qualcuno si ritrova nella mia stessa situazione può provare in questo modo =)

 

grazie comunque a tutti

 

-ema

Ciao, abbiamo lo stesso problema con questo modulo...

Potresti spiegarci come ripristinare il modulo originale (al tuo 3°passaggio).

Ti ringrazio in anticipo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More