Jump to content
Sign in to follow this  
oli004

Temps d'accès beaucoup trop long avec prestashop+60gp, parfois même erreur 500

Recommended Posts

Bonjour à toutes et tous,

Voilà plusieurs semaine que je n'arrive pas à résoudre un probleme d'erreur 500 aléatoire, avec des temps d'affichage affolant sur certaines pages sur une boutique en ligne utilisant prestashop sur un 60gp.

Les erreurs ne sont pas systématique, mais le temps de navigation lent rend la viste plutôt désagréable et non fluide.

J'ai lu ça et là que le problème "pourrait" être du au nombre de fichier appelé important à la génération de la page, mais bon sang, il y a bien des boutiques prestashop qui tournent sur des mutus chez ovh et où le temps d'affichage n'est pas aussi long.

Le design est relativement épuré, mais ce n'est pas ce qui ralenti, voir essais avec Pingdom : http://tools.pingdom.com/fpt/default.asp?url=http://www.jm-distribution.com/&id=757745

Et bien sur, YSlow + Firebug me donnent quasiment les mêmes graphes.

Comment remédier à ce problème ?

Je précise que j'ai également ouvert un sujet sur le forum ovh pour avoir deux pistes à suivre

Une idée, voir une solution serait la bienvenue.

Share this post


Link to post
Share on other sites

Oui ils parlents de ce problème sur les forum OVH, ça date pas d'hier :
http://forum.ovh.com/showthread.php?t=42965

Je pense malheureusement que le problème vient de chez eux, tu n'es pas le seul a avoir ce souci sur les mutualisés!

Par contre ça serai pas mal que tu mette le lien de ton post vers le forum OVH au cas ou quelqu'un ayant le même problème passe par la ;)

Share this post


Link to post
Share on other sites

Il y a je pense une part de hasard, car dans mes différents hébergements perso j'ai un 90plan et un kimsufi et les temps de réponse sont très bons pour les 2.

Share this post


Link to post
Share on other sites

la boutique n'est pas sur un plan ni même un dédié, mais sur un gp.
Hors avant de basculer sur un hebergement plus important j'aimerai avoir des précisions sur la source exacte du problème. J'ai ouvert un ticket auprès de l'assitance technique, je vous tiens informé de l'avancement du problème.

PS : sur le forum ovh, tjs pas de réponse pour le moment.

Share this post


Link to post
Share on other sites

En même temps je pense que les DNS sont gérés au même endroit pour tous les hébergements OVH (sauf ceux qui se gèrent eux-même).
Enfin attendons la réponse tout de même.

Share this post


Link to post
Share on other sites

Enfin une réponse ... (de normand)


Bonjour,


Au bout de 10 secondes d'exécution et si le script consomme plus de 30% de CPU , okiller mets une sorte de verrou sur le script pour le limiter à 30% de CPU, afin de permettre aux autres utilisateurs d'avoir suffisamment de ressource pour exécuter leurs scripts .Votre site a peut-être atteint une taille critique sur un point particulier. La majorité des CMS fonctionnent parfaitement bien jusqu'à ce que certaines limites soient atteintes, et à partir de là il faut souvent faire quelques modifs au niveau du code ou faire un peu le ménage dans les bases de données ou les fichiers pour rétablir un fonctionnement normal.

Tout est ok de notre coté.

Cordialement, Mohamed

Share this post


Link to post
Share on other sites

Alors, je me permets de remonter le sujet que j'avais ouvert il y a quelques semaines car après avoir basculé la boutique du mutu 60gp sur lequel elle était implantée vers un dédié kimsufi, c'st maintenant le jour et la nuit.
Temps d'accès et de navigation beaucoup plus rapide.
Je n'ai fait que transferer intégralement le site + la bdd. Et même après avoir allourdi le template de quelques images, la navigation est fluide et agréable.

Share this post


Link to post
Share on other sites

Bonjour et merci d'avoir actualisé le sujet.

En effet, il apparait rapidement nécessaire au delà d'un certain besoin de bande passante d'avoir recours à un serveur dédié. Ce que OVH "oublie " de préciser lorsqu'il annonce une bande passante, c'est que celle ci est une moyenne sur le mois. En cas de forte affluence ou de passage de robots gourmands ( bien penser à virer les parasites ! ), on est sanctionné par une forte baisse de bande passante ou carrément une pénalité de suspension de site, comme j'ai pu en faire les frais à mes dépends ! )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More