Jump to content
Sign in to follow this  
fatididy

probleme avec cms

Recommended Posts

bonsoir tous le monde

j'ai un problème trés urgent ,les cms ne s'affiche plus méme (qu'on je clik sur un des lien de block information j'ai une page vide )

je trouve dans une forum que c'est à cause du théme mais rien n'a était changé pour moi ,méme si je prend le méme fichier cms.tpl du théme prestashop standard et le remplacé dans le mien .

que dois je faire ????

Share this post


Link to post
Share on other sites

Ca peut venir aussi de la fonction rewrite si tu l'as activée. je suis en plein dans ce problème!

Share this post


Link to post
Share on other sites

bonjour et merci beaucoup pour vos réponses

alicepinasse :je fais ce que tu m'a dis et le résultat :une page blanche (sans menu ni modules ni rien d'autre)

Stéphane chonez :méme si j'utilise un lien de menu et je l'attribuer un fichier cms cela me donne le méme resultat

typac :non j'ai pas activé URL simplifiée

 

merci de me donner d'autre suggestions ^_^

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Merci d'afficher les erreurs en activant le mode débug.

 

Il suffit d'aller dans le fichier /config/config.inc.php et de mettre "on" à la place de "off" et "true" à la place de "false" sur les deux premières lignes de code.

 

Une page totalement blanche signifie bien souvent un arrêt à cause d'une erreur PHP.

Share this post


Link to post
Share on other sites

bonjour et merci beaucoup pour vos réponses

voici l'erreur

htmlentities() expects parameter 1 to be string, array given in C:\wamp\www\tools\smarty\plugins\modifier.escape.php on line 30

 

 

et voici le ligne 30

case 'htmlall':

return htmlentities($string, ENT_QUOTES, $char_set);

Share this post


Link to post
Share on other sites

Bonjour,

 

L'erreur dit "htmlentities demande comme paramètre une chaine de caractères, or un tableau est envoyé".

 

Votre variable $string doit être un array, ce qui ne convient pas à htmlentities.

 

Je vous conseille donc d'utiliser la fonction de Prestashop : Tools::HtmlEntities (quelque chose qui s'en rapprche, CTRL + F vous aidera à trouver), qui permet d'appliquer htmlentities sur une chaine ou un tableau grâce à la fonction array_map.

Share this post


Link to post
Share on other sites

merci bq Sbizz

j'ai trouvé la solution ,y a un module qui empéche l'affichage de mes pages cms ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More