Jump to content
Mecosof

Prestashop 1.4.4.1 - Enviar Newsletters desde el Panel de Administración (Back Office)

Recommended Posts

Después de mucho buscar, encontré un sistema para enviar Newsletters desde el Back Office de Prestashop 1.4.4.1.

Éste fue realizado por Eolia de olalla.com, pero no estaba en Español (Solo francés e inglés).

Yo he traducido todos los archivos, pero probablemente haya quedado algo que se me escapó, si alguno lo usa y encuentra faltantes, por favor avisen y trataré de arreglar todo.

También hice un tutorial en pdf explicando lo mejor posible como se hace la instalación.

Yo todavía no tengo una tienda en funcionamiento, estoy en la fase de pruebas y configuración.

Hasta ahora de las pruebas que hice, anda todo, excepto el mail que recibe el suscriptor cuando se borra, que en el texto, en lugar de insertar la dirección del email borrado, pone el código de llamado {email}, que si bien no es tan importante, si alguien que entienda de programación lo puede solucionar, bienvenido sea para todos.

Les dejo el archivo adjunto.

 

Editado 29 de Octubre dde 2011: Como verán más abajo, el usuario JimKa tuvo inconvenientes. Luego a mí también me ocurrió, y descubrí un error en el archivo "AdminNewsletter.php". Lo he corregio y resubido el zip completo.

NewsLetter_PS_1.4.4.1.zip

  • Like 4

Share this post


Link to post
Share on other sites

Eres grande Mecosof . . . Tenía tiempo buscando algo así.

 

Muchas gracias :D

 

 

Saludos!

  • Like 1

Share this post


Link to post
Share on other sites

Hola a todos:

 

Muchas gracias por facilitarnos la traducción. Lo he instalado en la 1.4.3 y me sale la imagen que dejo adjunta. He usado este módulo desde hace bastante y antes me aparecía algo así como "Clientes que se han suscrito al boletín" pero aquí no aparece.

 

¿Cómo se podría solucionar?

 

Un saludo y gracias

 

Bueno ya lo he solucionado. No admite en el Panel de Admnistrador ni tildes ni "nº".

 

Muchas gracias de nuevo.

post-68947-0-33502900-1319632549_thumb.jpg

Share this post


Link to post
Share on other sites

Hola a todos:

 

Muchas gracias por facilitarnos la traducción. Lo he instalado en la 1.4.3 y me sale la imagen que dejo adjunta. He usado este módulo desde hace bastante y antes me aparecía algo así como "Clientes que se han suscrito al boletín" pero aquí no aparece.

 

¿Cómo se podría solucionar?

 

Un saludo y gracias

 

Bueno ya lo he solucionado. No admite en el Panel de Admnistrador ni tildes ni "nº".

 

Muchas gracias de nuevo.

 

 

Hola JimKa:

 

Comencé otra prueba de instalación, y en ésta me ha ocurrido lo mismo que a vos. Por favor, me puedes decir ¿qué archivos corregiste y su ubicación? y si es posible qué fue lo que editaste.

Gracias...

 

Saludos

Share this post


Link to post
Share on other sites

Bueno...

 

Me respondo yo mismo:

 

Como verán más arriba, el usuario JimKa tuvo inconvenientes. Luego a mí también me ocurrió, y descubrí un error en el archivo "AdminNewsletter.php". Lo he corregido y resubido el zip completo.

Por favor, si alguien tiene algún inconveniente y luego lo soluciona, les pido que lo comenten en este post, indicando detalladamente cómo lo solucionaron. Esto puede ser de mucha ayuda para otros.

Gracias..

 

Saludos!!!!

Share this post


Link to post
Share on other sites

Hola a todo, perdonad que no haya contestado antes.

 

Lo único que hice fue que en las traducciones del módulo eliminé todo símbolo "extraño", como nª, nº, tildes como á, é... etc.

Solo eso.

Share this post


Link to post
Share on other sites

En fin, perdonad mi ignorancia.

Lo primero es que estoy encantada de haber descubierto este módulo, michas gracias Micosof, me parece imprescindible, pero, y una vez subido a la tienda ¿cómo se hace?

Reitero estoy empezando a aprender y pido perdón

Share this post


Link to post
Share on other sites

Hago tal como dices pero me da este error al empleados-pestañas-añadir.. :

Se ha producido un error mientras se creaba el objeto tab ()

 

he dado permisos a carpetas y ficheros del modulo.. y nada no lo consigo

Prestashop 1.4.5.1

Share this post


Link to post
Share on other sites

En fin, perdonad mi ignorancia.

Lo primero es que estoy encantada de haber descubierto este módulo.....

 

Holaaaa Picarrasca:

Por favor lee atentamente todas las instrucciones en el archivo pdf. Si sigues los pasos indicados, no tendrás problemas.

Aclaro que esto lo he probado en la versión 1.4.4.1, desconozco si funciona en otras versiones.

Saludos...

Share this post


Link to post
Share on other sites

Hago tal como dices pero me da este error al empleados-pestañas-añadir.. :

Se ha producido un error mientras se creaba el objeto tab ()

 

he dado permisos a carpetas y ficheros del modulo.. y nada no lo consigo

Prestashop 1.4.5.1

 

Hola enesri:

 

Aclaro que esto lo he probado en la versión 1.4.4.1, desconozco si funciona en otras versiones.

Por favor, si logras que ande en la v1.4.5.1, sería de utilidad para muchos que lo comentes aquí y qué hiciste para lograrlo.

Saludos....

Share this post


Link to post
Share on other sites

Uffff compadre, no sabes cuanto tiempo llevo buscando algo como esto.... ojala todo funcionebien, muchas gracias....

Share this post


Link to post
Share on other sites

plopp me sucedio lo mismo que a enesriadjunto un print pantalla para que puedan ver el error, espero alguien nos ayude....

 

print.jpg

Share this post


Link to post
Share on other sites
timestamp[/size]='1322507906' post='692503']

plopp me sucedio lo mismo que a enesriadjunto un print....

www.beststore.cl/img/print.jpg

 

Hola zerock:

 

¿Qué versión de PS estás usando?

Fíjate que enesri tuvo problemas con la v1.4.5.1 y yo avisé que anda en la 1.4.4.1

Igualmente ahora estoy haciendo unas pruebas de instalación desde cero, y veré si también me da problemas. Lo extraño es que cuando hice este post, fue porque el día anterior lo instalé sin problemas.

Por favor zerock es importante que nos aclares qué versión de PS estás usando. Gracias.

Saludos.

Share this post


Link to post
Share on other sites

utiliza tinymce pero adiciona un tinymce extra, luego adiciona la configuracion al mismo cuando presta ya trae su configuracion en el archivo js/tinymce.inc.js , cabe destacar que la configuracion en prestashop de tinymce esta algo elaborada y ha sido una ardua tarea del equipo de desarrollo integrarlo, para dar seguridad al sistema.

por otra parte a la ligera trabaja por sessiones si bien son seguras se debe utilizar filtros para evitar sorpresas...

la images son enviadas pero dudo que cuentas pop3 o hotmail, yahoo reciban las imagenes...

 

Por ultimo no posee limites envios, deben saber que este tipo de sistema deben limitar el envio a 400 o 500 email por dia ya que si superan este limite cuentas como gmails pueden

ser bloquedas por spam, tambien deben saber cual es limite diario de email en sus respectivos hosting para que estos no suspendan sus cuentas.

 

saludos

Share this post


Link to post
Share on other sites

hola , ya funciona en la PS 1.4.5.1 ?? me he quedado colgado desde que actualize sin poder enviar newsletter..

Share this post


Link to post
Share on other sites

hola , ya funciona en la PS 1.4.5.1 ?? me he quedado colgado desde que actualize sin poder enviar newsletter..

Yo lo pobre en dicha versión y funciona perfectamente.

Share this post


Link to post
Share on other sites
Guest

y que tal en la versión 1.4.7?, no me atrevo a fastidar la web ahora que va mas o menos bien.

Share this post


Link to post
Share on other sites

La acabo de instalar en mi web y funciona perfecto! Por fin un modulo para poder hacer servir el Newsletter de Prestashop.

Utilizo la versión 1.4.7

Share this post


Link to post
Share on other sites

Ante todo agradecer a Mecosoft su trabajo!

 

Quiero puntualizar un detalle, creo que es importante, al menos a mí me ha costado un rato hasta que lo he visto.

Cuando leáis el documento PDF adjunto, con las instrucciones de montaje del módulo, tened en cuenta que en la página 2, en el apartado en el que dice:

 

A la carpeta “admin” / ”js”: subir el directorio “tinymce” con todos los subdirectorios. (Van a ver que en el servidor hay otro directorio “tiny_mce”, no toquen ni copien nada en ese). O sea que dentro de “admin” / ”js” van a tener ahora esos dos directorios.

 

Editado:

No se refiere a la carpeta "js" de la parte de gestión, sino a la carpeta "js" del directorio raiz de la tienda.

 

Suerte a todos!

 

ZzzZzzZ

Edited by lasiesta (see edit history)

Share this post


Link to post
Share on other sites

Hola chavals!

La instalación es normal, tal cual se explica, solo tienes que tener en cuenta el detalle que comené en el post #23

 

A ver si te sirve, ya nos contarás!

Share this post


Link to post
Share on other sites

Agradecido Mecosoft por tu aporte, funciona perfectamente en la versión 1.4.8.2 y es de gran utilidad. Por los momentos no ha surgido ninguna falla.

 

Un cordial saludo!

Share this post


Link to post
Share on other sites

 

Resuelto

 

¿Cómo lo has resuelto? Yo tengo prestashop 1.4.7 y no me sale el editor de textos mejorado...

Share this post


Link to post
Share on other sites

A m'i me aparece todo bien, pero a la hora de enviar me sale un mesaje de Error!, sin m'as, uso la 1.4.8.2, seguramente sea por eso. Alguien sabe un m'odulo que funcione en esta versi'on?

 

(Siento las faltas, se ha desconfigurado el teclado)

Share this post


Link to post
Share on other sites

Hola a todos, primero agradecer a mecosoft por su aporte, lo instale en la version 1.4.9 y funciona perfectamente el unico detalle es que toca areglar las rutas hacia el js en la clase el resto muy bien, muchas gracias.

Share this post


Link to post
Share on other sites

Hola que tal, primero que todo gracias :D. Me pasa algo super extraño ya que instalo en un servidor (de pruebas) y funciona a la perfección, pero cuando instalo en el de producción, al momento de presionar la pestaña no me aparece nada, ni un error nada, solo un block pequeño en blanco. Le ha sucedido esto a alguien más? o quizás alguien tiene alguna idea de que podría ser?, agradecería cualquier ayuda.

 

Muchas gracias de antemano. Saludos

Share this post


Link to post
Share on other sites

Hola que tal, primero que todo gracias :D. Me pasa algo super extraño ya que instalo en un servidor (de pruebas) y funciona a la perfección, pero cuando instalo en el de producción, al momento de presionar la pestaña no me aparece nada, ni un error nada, solo un block pequeño en blanco. Le ha sucedido esto a alguien más? o quizás alguien tiene alguna idea de que podría ser?, agradecería cualquier ayuda.

 

Muchas gracias de antemano. Saludos

Habilita el debug de errores.

Share this post


Link to post
Share on other sites

Muchas gracias con esto pude identificar el error de sintaxis, muchas gracias :D

Share this post


Link to post
Share on other sites

Hola a todos:

 

Tengo el módulo bien, me enví los correos, etc. Pero tengo un problema en los correos. si escribo sin tablas los espacios entre la franja de color por defecto inicial (donde se pone el nombre de la Newsletter que uno eliga o el nombre de la web) y el texto es normal. Pero en cuánto se usa una tabla la separación es enorme, con lo que desde la franja por defecto hasta el inicio del correo es de bastantes renglones. ¿Alguien sabe a qué puede ser debido?. Gracias.

Share this post


Link to post
Share on other sites

Hola, gracias por el modulo, y los aportes.

Lo he instalado en PS 1.4.7.0 siguiendo las intrucciones, pero al pulsar en la pestaña del BO "NewsLetter" me sale un rotulo que dice "El archivo de la pestaña no puede encontrarse" he repasado la instalación y no encuentro donde esta el error, a alguien más la ha pasado podeis indicarme que hago mal, muchas gracias y un saludo.

Share this post


Link to post
Share on other sites

Bueno pues yo solito he encotrado la solución, si le pasa a alguien más en el tutorial de intalación donde dice:

 

"Cabe aquí hacer una aclaración, para que no les pase lo que me ocurrió a mí, en cuanto a los archivos a subir:

A la carpeta “admin” / ”tabs”: subir el archivo “AdminNewsletter.php”

 

En mi caso hay que subir el archivo a la carpeta "iadmin/tabs" y a funcionar.

 

Un saludo

Edited by betetero (see edit history)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More