Jump to content
ubergirl

Module postes canada - ça marche pour vous?

Recommended Posts

Salut

Y a-t-il des gens qui utilisent le nouveau module pour postes canada dans prestashop 1.4.4.1 ?

 

J'avais acheté le module équivalent fait par Presto-Changeo, qui fonctionne très bien d'ailleurs. C'est celui qui est présentement utilisé en prod.

 

J'ai un site de test en local sur mon pc. J'ai désinstallé le module de Presto-Changeo à partir de l'onglet Modules dans le back-end. Puis j'ai fait supprimer. J'ai vérifié qu'il n'y avait plus rien dans le dossier module.

 

Ensuite j'ai copié/collé le dossier Canadapost par PrestaShop dans le dossier module. je l'ai activé dans le back-end. Et quand je tente de le configurer, ça ne fonctionne pas. Je ne peux pas passer la première étape; ça écrit:

 

forbbiden.gif Prestashop could not connect to Canada Post webservices :

Canada Post Webservice seems to be down, please wait a few minutes and try again.

 

(le site n'est pas down)

 

J'aimerais vraiment pouvoir utiliser ce module, car j'aimerais pouvoir importer les adresses des commandes dans le logiciel d’expédition de Postes Canada (on m'a dit que ça se faisait)

 

Mon serveur de dev est sous Wampserver 2. Ça serais-tu possible que ce soit ma configuration locale qui ne fonctionne pas?

Share this post


Link to post
Share on other sites

Bonjour,

 

As tu demandé une ouverture de compte chez poste canada pour ce service (utilisateur et mot de passe)

 

Chez moi ca marche pas tout testé mais ca marche

 

Cordialement

 

Didier

  • Like 1

Share this post


Link to post
Share on other sites

Moi je l'utilise et il fonctionne tres bien. je n'ai pas tester l'importation des liste d'adresse encore

Share this post


Link to post
Share on other sites

Le Module natif Postes Canada ne fonctionne pas du tout. Dans le Back-Office tous les types de services sont "Down" inactives.

 

Par contre, celui de Presto-Changeo marche très bien!

Share this post


Link to post
Share on other sites

y a-t-il un guide pour utiliser le module canada poste, parce que je l'ai activé , bien configuré. Mes produits ont tous bien été configurés également : poid, taille. Mais le calcul ne se fait absoluement pas. Ca reste à zéro, et au panier ca fait l'erreur "Il n'y a pas de transporteur disponible qui délivre à cette adresse." svp aidez moi

Share this post


Link to post
Share on other sites

As tu bien configuré avec les codes d'accès à l'API ? As tu choisi tes modes de livraison ? As tu configuré tes zones de livraison ?

Share this post


Link to post
Share on other sites

y a t-il un model d emploie pour ce module? j y songe mais si c est trop compliqué.....

Share this post


Link to post
Share on other sites

J'ai un compte avec Poste Canada. Quand je viens pour configurer le module Poste Canada dans Prestashop, il y a toujours le message:

PrestaShop ne peut pas se connecter aux webservices Canada Post :

Erreur -2001 : Merchant CPC Id not found on server

 

Pourquoi, qu'est-ce que je n'ai pas bien rempli ou qu'il manque ailleurs? Dans la case Votre compte Poste Canada, j'ai mis mon no de membre et ça ne fonctionne pas et si je mets le no de la convention, ça ne fonctionne pas plus. Y a-t-il un autre no à entrer?

Share this post


Link to post
Share on other sites

Merci pour l'information, j'ai obtenu mon code CPC de Poste Canada et configurer mon compte avec eux ainsi que le module Poste Canada sur Prestashop. Maintenant, je ne sais plus où je dois configurer les transports pour que ce soit fonctionnel sur mon site. Quand je teste un achat sur le site, il n'apparait que Colis standard pour une livraison au Canada alors que j'ai configuré 3 services de poste pour le Canada dans mon profil de Poste Canada sur leur site et dans le module Poste Canada de Prestashop, j'ai configuré ces mêmes 3 services: colis standard, Xpresspost et colis accéléré. Dois-je aussi configurer les transporteurs dans le menu transport? Ou s'il y a un lien entre Prestashop et Poste Canada? Comment bien configurer l'ensemble?

Share this post


Link to post
Share on other sites

Si les 3 services offrent le même délai de livraison, le module ne proposera que le prix le plus bas. Donc si tu testes avec une adresse proche du lieu d'expédition il est probable que cela n'affichera qu'un prix.

 

Il faut aussi aller dans le site sell online de Postes Canada pour configurer ton compte et surtout creer la taille de tes boites.

Share this post


Link to post
Share on other sites

Oui, j'ai configuré mon compte Poste Canada pour les boîtes et les services offerts. Tout va de ce côté, je crois. J' ai activé les différents services de Poste Canada dans le menu transporteurs aussi et laissé tous les transporteurs disponibles dans produit. Maintenant quand je fait un test de prix pour des colis sur le site de Poste Canada directement, le site me donne un prix d'envoi pour les différents services offerts. Quand je fais le même envoi à partir de mon site, même article donc même poids et volume et même adresse de livraison, mon site me donne les services offerts avec un prix qui est pratiquement le double du prix dans Poste Canada. J'ai enlevé tous les frais de manutention dans mon compte Poste Canada et dans Prestashop. Je me demande qu'est ce qui cause un prix aussi différent? 7,80$ sur Poste Canada et 14,88$ sur mon site?

Edited by Mme Chic (see edit history)

Share this post


Link to post
Share on other sites

Oui, tout est bien configuré sur sellonline. J'ai même vérifié avec quelqu'un de Poste Canada et il me dit que tout fonctionne bien de leur côté. Il a essayé un achat sur mon site et il voit que leur programme donne le bon prix. C'est du côté de Prestashop et ma configuration que ça ne fonctionne pas bien. J'ai enlevé tout montant de manutation ou prix d'emballage, même l'emballage cadeau non disponible et c'est toujours le même prix trop élevé!

 

J'ai changé les Frais supplémentaires sur le module Poste Canada dans Prestashop et ça ne change rien au prix de livraison affiché. Par contre quand je met 1 item par colis, j'obtiens un prix de livraison et si je mets calculer plusieurs items par colis, il n'y a plus de transporteur disponible. Où peut-être l'erreur de configuration?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More