Jump to content
Sign in to follow this  
xakru

[Résolu] Frais de port différents pour des pays différents, comprend vraiment pas !!!

Recommended Posts

Bonjour,

Je suis entrain de configurer mon Prestashop,et j'ai un tout petit soucis.

Je vais vendre aussi bien en Belgique (mon pays d'origine) qu'en France.

J'ai donc configurer les frais d'envoi pour une Zone 1 Belgique via taxipost : xxx€
Une deuxième zone pour la france, transporteur Taxipost international : zzz€

En testant je me crée un compte belge et un français, quand je commande pour les deux j'ai les même frais de port. Je ne vois pas ou j'ai foiré... quelqu'un peut-il m'aider ?

D'avance merci

Share this post


Link to post
Share on other sites

Dans le B.O / onglet TRANSPORT / TRANSPORTEUR / tu édites le transporteur concerné et tu coches la zone a laquelle le prix s applique

Share this post


Link to post
Share on other sites

Bon ben ca fait 2h que j'essaye...

J'ai créé 2 zone :
- Belgique
- France

Dans la catégorie Pays :
- Belgique est dans la zone belgique
- France dans la zone france

Dans mes transporteurs :
- taxipost --> belgique
- taxipost international --> france

Et lorsque je crée mon compte avec une adresse france, j'ajoute qqchose dans mon panier, les frais de port sont ceux de la catégorie taxipost Belgique...


Je suis perdu !!!!!!!! :-S

Share this post


Link to post
Share on other sites

Personne ???

J'ai encore regarder ce soir et je ne vois vraiment pas ou j'ai oublié quelque chose...

Share this post


Link to post
Share on other sites

Donc en fait il applique les frais de port du transporteur par défaut (disons le belge) même pour la France...

Et quand tu dis que c'est les mêmes frais de port tu constates ça juste après avoir ajouté un article au panier (avec le client français) ou bien même en allant tout au bout du processus de commande ?

Share this post


Link to post
Share on other sites

Je n'avais pas été jusqu'ua bout de la validation de la commande...

Quand je l'ajoute au panier, il met les frais de port par défaut, Belgique

Quand je valide la commande et arrive au choix du transporteur, une seule possibilité se présente et c'est la bonne...

Donc ca marche même si au départ j'induis le client en erreur... car mon envoi belge coute 11€... et l'envoi français revient à 30€...

Y a-t-il moyen de remédier à cela ?

Share this post


Link to post
Share on other sites

Le seul moyen que je verrais, ce serait d'ajouter un transporteur "Retrait au magasin" pour 0€ et le mettre par défaut... Mais bon, si tu ne comptes pas offrir cette possibilité c'est bof bof...

Share this post


Link to post
Share on other sites

Ben non il n'y a pas cette possibilité...

C'est dommage ça, c'est vraiment la seule chose que je peux reprocher à Prestashop...

Merci tout de même pour ton aide

Share this post


Link to post
Share on other sites
Ben non il n'y a pas cette possibilité...


Tu veux dire que toi tu ne veux pas offrir cette possibilité (retrait au magasin) ou que tu ne la trouve pas dans PS ?

Pourquoi tu as mis le topic en Résolu ? C'est pas le cas... Si ?

Share this post


Link to post
Share on other sites

Non je ne laisse pas la possibilité de retiré en magasin...

Je pensais que ce n'était pas possible de faire cela c'est pour cela que j'ai :smirk: mis résolu... je remet HELP alors

Share this post


Link to post
Share on other sites

est-ce que tu vides le cache de l'ordi avant de faire la manip' de changement de compte de français à belge ou inverse ?

Share this post


Link to post
Share on other sites

je viens de comprendre !

J'ai eu le même souci au début, pour que les frais de port apparaisse par défaut dans le panier il faut absolument que ton transporteur par défaut soit le même pour tous les pays donc tu dois créer le même transporteur pour la France et la Belgique (l'idée de Zendik allait dans ce sens en créant retrait en magasin pour les deux pays).

Ensuite sous l'onglet Transport tu vas en bas et tu mets tes tarifs en fonction des pays.

De tout façon Prestashop ne peut pas savoir d'où vient le client tant qu'il n'est pas enregistré avec un Pays d'expédition.

Share this post


Link to post
Share on other sites

Ce n'est malheureusement pas possible

Belgique : Taxipost
France : Taxipost international --> pas les mêmes frais

Share this post


Link to post
Share on other sites

justement on met des tarifs différents sous l'onglet transport en bas de la page

pour mon site j'ai colissimo pour tous les pays du monde par défaut (un seul et unique transporteur indiqué ) et je rentre les tarifs en fonction des zones

Share this post


Link to post
Share on other sites

Ce que veut dire CMMC, si je comprends bien, c'est qu'au lieu d'avoir :
Belgique => Taxipost
France => Taxipost international

tu auras :
Taxipost
=> zone France : X euros
=> zone Belgique : Y euros

Donc un seul transporteur auquel sont affectées les 2 zones France et Belgique.

Par contre dans ce cas, tant que l'utilisateur n'est pas identifié, je ne sais pas lequel des deux prix sera affiché...

Share this post


Link to post
Share on other sites

Je viens de tenter ce que tu dis, la configuration est juste.

Met lorsque j'ajoute qqchose au panier, j'ai tout de même les frais de port belge qui apparaisse dans la ligne expédition, lorsque je valde ma commande par contre je n'ai le choix que des frais de port internationaux, avec la particularité que les frais apparaissent Hors TVA...

:coolgrin:

Share this post


Link to post
Share on other sites

pour les taxes il faut aller dans l'onglet Paiement et ensuite Taxes et choisir les pays pour la taxe à 21 %

pour le transporteur tu auras toujours un prix de transport par défaut qui correspond à ton pays et en validant avec un client se sera uniquement les frais de port vers les pays client qui s'affichera

Share this post


Link to post
Share on other sites

Merci pour ces réponses, c'est juste j'avais oublié de coché la taxe pour la France...

C'est dommage que sur les pages du shop, prestashop ne prenne pas déjà en compte le pays d'origine du client enregistré mais le pays par défaut. Et qu'il ne change que cela au moment de la validation de la commande.

Je peux dire que mon problème est résolu alors même si la solution n'y est pas vraiement ...

Share this post


Link to post
Share on other sites
Je peux dire que mon problème est résolu alors même si la solution n'y est pas vraiement ...


Dans ce cas, maintenant tu peux mettre [Résolu]. ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More