Jump to content

Problème ajout produit avec attribut si JS désactivé


Recommended Posts

Bonjour,

Je suis en train de tester Presta en ayant le Javascript désactivé (parce qu'il y a aussi des gens qui désactive tout le JS, de moins en moins, mais quand même!) et je suis confronté a ce qu'il me semble être un bug

Si vous avez un produit avec des attributs, par exemple un T-shirt, avec comme attributs la taille (S, M, L, XL) :
Avec le JS activé, tout va bien... Mais avec le JS désactivé, le produit est ajouté au panier avec la valeur d'attribut par défaut, quoique vous choisissiez dans le Select

Alors grande question : Je suis le seul a avoir testé? ou d'autres ont le problème?

Apparemment le script derrière récupère la valeur du champ :

<input type="hidden" value="" id="idCombination" name="id_product_attribute"/>



Avec le JS activé il est bien mis a jour, mais sans... forcément, il ne l'est pas!

Si vous passez par là et que vous avez 2min pour tester, je suis preneur ;)

Pour info :
Presta 1.1 avec le template de base
Testé aussi sur la demo du site

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More