Jump to content
jaxchris

How to increase Maximum execution time

Recommended Posts

Good Day All:

 

I am attempting to export my catalog to google shopping and when I select Export Products with combination/attributes (Export Several Products: One Product per attribute combination), I receive the following error.

 

(My shop has 2400 products with almost 40k different products with variations.) I can export 2400 products fine with no errors.

 

Fatal error: Maximum execution time of 120 seconds exceeded in /home2/saddler3/public_html/classes/SpecificPrice.php on line 124

 

I have configured the php.ini file with the settings as:

max_execution_time = 600 ; Maximum execution time of each script, in seconds

max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

memory_limit = 1024M ; Maximum amount of memory a script may consume (1024MB)

 

 

I have configured the config.inc.php file with the settings as:

@ini_set('memory_limit ', '1024M');

@ini_set('max_execution_time ', 600);

 

 

Is there another place to adjust the execution time other than the places I have already configured? Is there a step that I am missing? I am using Google Merchant Center.

Share this post


Link to post
Share on other sites

Maybe the php.ini that is read is not the one you are modifying. Add a file to the root of your installation with

<?php
phpinfo();
?>

 

and note the location the php.ini is read from. Is it the same file you are modifying?

  • Like 1

Share this post


Link to post
Share on other sites

Take a look into the file : /controllers/admin/AdminImportController.php

Try to set settings there for importing files:

 

 
@ini_set('memory_limit', '3024M');
@ini_set('session.gc_maxlifetime', 5000);
@ini_set('max_execution_time', 5000);
@ini_set('max_input_time', 5000);
@ini_set('max_input_vars', 20000);
@ini_set('expect.timeout', '2000');
@ini_set('default_socket_timeout', '2000');
Edited by satkauskas (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More