Jump to content
Sign in to follow this  
ArnoParis

Problème lenteur 1ere connexion

Recommended Posts

Bonjour,

J'ai un problème avec prestashop. Je suis hébergé chez OVH et lors de la première connexion sur mon site prestashop (en cours de dev), j'ai un temps de latence d'environ 4/5 sec avant que la page d'accueil ne s'affiche. Je n'ai pas ce problème en test. Par contre une fois le site affiché, je n'ai plus de problème de lenteur dans la navigation sur le site. il s'agit uniquement de la première connexion.
Avez vous une idée d'om ça vient ? de chez OVH ? de prestashop ?

Merci de votre retour,

Arnaud

Share this post


Link to post
Share on other sites
Guest

[Edit blablabla pub par Damien]

Je t'ai proposé une solution mais ça ne plait pas à tout le monde, alors tu peux me joindre ICI, si tu as encore besoin d'aide.

Share this post


Link to post
Share on other sites

Perso suis chez ovh 240plan et constate pas mal de lenteur comme arnoParis, on a décidé de changer de serveur, ca vient des requètes mysql, on va prendre plus gros, maintenant désactiver certains modules statistiques peuvent améliorer les performances.

Share this post


Link to post
Share on other sites

Pour ma part il s'agit seulement de la 1ere connexion, la navigation par la suite est fluide ... comme le retour sur la page d'accueil ...

J'arrive pas à comprendre si ça vient de prestashop ou de OVH ...

Share this post


Link to post
Share on other sites

Vu sur le forum OVH

Je cite :


On regarde ça de notre côté, et la piste qu'on a est lié au nombre de fichiers appelés pour la génération d'une page, sachant que les données en mutu sont hébergées en NFS.

Les CMS touchés semblent être batis autour de très nombreux fichiers séparés et la moindre page fait plus de 200 appels d'ouverture de fichiers, ce qui multiplie l'impact d'un temps de réponse un peu plus lent en réseau.

Exemple: mettons que l'appel à un fichier soit ralenti de 10ms. Un site ordinaire fait moins de 10 appels pour afficher une page, il subit donc un ralntissement <100ms, imperceptible. Un site wordpress/joomla qui fait 200appels subira par contre un ralentissement de 2 secondes

Ce ralentissement est plus sensible sur la première page, car ensuite les fichiers restent en cache mémoire sur le serveur web, et donc le nombre d'appel à des nouveaux fichiers redevient moins important.

On cherche comment restreindre au maximum ce phénomêne. On est actuellement en train de faire des déploiements pour limiter la variation du temps de réponse des filers.
Exemple : http://smokeping.ovh.net/ovh-server-...0plan.homez-34

On cherche également d'autres pistes.
A noter aussi que l'impact est moins sensible pour un site très fréquenté, dont les fichiers seront maintenus en cache par les nombreuses visites successives.



Le reste de la discutions :
http://forum.ovh.com/showthread.php?t=42965

V++

Atch

Share this post


Link to post
Share on other sites
Guest

Ce sont les aléas des mutualisées.

Share this post


Link to post
Share on other sites

Pas chez tous les hébergeurs ;-)

Sans faire de pub pour le mien, je peux dire en tout cas que si je bosse avec OVH pour tout ce qui est domaines / certifs SSL, pour l'hébergement ils ne sont pas près de me voir. Entre les soucis de perfs et le pseudo cloacking qui a pénalisé des dizaines de sites sur Google, merci bien : OVH a vraiment des problèmes !...

Plus généralement, la première connexion "lente" peut venir simplement du poids de votre page. Une fois le premier passage fait, un certain nombre d'éléments (fichiers CSS, Javascript, mais aussi images CSS et dans une moindre mesure images tout court) sont mis dans le cache du navigateur. On peut passer de 300 ko à 15/20 ko réellement téléchargés pour une page Prestashop (le reste étant donc mis dans le cache du navigateur).


Un outil indispensable : Firebug avec son add-on YSlow, sous Firefox 3.x.

Exemple de ce que l'on obtient sur une boutique Prestashop relativement lourde au niveau graphique (à gauche, avant la mise en cache, à droite, après la mise en cache).

5185_XWKcJZfN3jBsUROyJLJA_t

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More