Jump to content

Problème de déclinaison depuis la mise à jour


Recommended Posts

Bonjour tout le monde,

 

voilà avant tout fonctionnait correctement, mais depuis ma migration vers la dernière version de prestashop je rencontre quelque problème avec certain article qui ont des déclinaisons en effet j'ai ce message

 

Ce produit n'existe pas dans cette déclinaison. Vous pouvez néanmoins en sélectionner une autre.

 

hors il y a bien du stock pour cette déclinaison. C'est bien pour celà que je ne comprends pas pourquoi ça ne fonctionne pas.

 

Si quelqu'un peut me venir en aide?

 

Merci.

Share this post


Link to post
Share on other sites

Je viens de m'apercevoir d'un truc la gestion des déclinaisons a changé depuis la version 1.3.5 en effet je pouvais mettre plusieurs attribut dans un groupe, maintenant je ne peux plus, il me dit que je peux ajouter qu'un seul type par groupe, hors le problème c'est que 85% de mon catalogue fonctionnait avec l'ancien système, je voudrais savoir si il existe une solution, sans que j'ai a tout refaire je vais perdre un temps fou et c'est pas du tout envisageable.

Share this post


Link to post
Share on other sites

Je vais donner un exemple précis afin que vous comprenez bien mon problème qui est bien plus que gênant!

 

Prenons l'exemple de vente de batterie moto donc j'avais créé

 

Le groupe "Type yamaha" pour les motos de la marque .

Dans ce groupe se trouve les attributs de cette forme:

 

-R1 06/08

-R1 09/11

-R6 06/08

-R6 09/11

 

la batterie peut être compatible avec plusieurs type de modèle de la marque.

Par exemple une batterie ayant la référence batterie1 est compatible avec le R1 06/09 et le R6 06/09

 

Donc avant quand je voulais créer ma déclinaison j' ajouter plusieurs attribut d'un même pour une déclinaison

Maintenant je ne peux plus je suis vraiment bien embêter car les anciennes déclinaisons sont toujours présente mais le site indique au client que cette article n'existe pas dans cette déclinaison, hors c'est faut.

 

Et si je crée une déclinaison pour chaque modèle de moto pris dans mon exemple la gestion des stock n'est plus bonne .....

 

 

Et je me suis aperçu de sa car j'ai remarqué une baisse de certain produit phare qui se vendent plus depuis la mise à jour, maintenant je comprends mieux le client ne peux pas commander cet article en question.

 

Je cherche une solution rapide car mes ventes sont entrain de chuter.

 

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

 

N'obtenant pas de réponse a mon problème j'ai fais remonter l'information à la forge ou pour le moment j'ai pas eut de réponse donc wait and see de ce coté là.

 

Mais comme c'est un problème plus que merdique et je pèse mes mots a force, j'ai contacter le support par téléphone, tout ce qu'on ma dit c'est que sous la 1.3 c'était un bug et que maintenant ça restera toujours comme ça , alors j'ai demandé si ils avaient une solution et là on ma répondu que j'avais a tout recommencer.

 

Super !! non ?.

 

Sérieusement je pige pas là "un bug" , il était surtout bien utile celui-ci et je ne vois pas en quoi il dérangeait dans le fonctionnement de prestashop.

 

Car je trouve pas sa logique de ne pas pouvoir ajouter plusieurs attributs d'un même groupe lors de la création d'une déclinaison.

 

Je dois pas être le seul a rencontrer ce problème tout de même .

Share this post


Link to post
Share on other sites

Bonjour Tchupa,

 

Je reviens vers toi avec une solution du support :

 

- Ouvre le fichier AdminProduct.php dans le dossier Tabs du dossier Admin

- A la ligne 507 remplacer

 

if ($product->productAttributeExists($_POST['attribute_combinaison_list'], $id_product_attribute)) 

 

par

 

if (1!=1)//$product->productAttributeExists($_POST['attribute_combinaison_list'], $id_product_attribute))

- A la ligne 544 remplacer

if ($product->productAttributeExists($_POST['attribute_combinaison_list'])) 

par

if (1!=1)//$product->productAttributeExists($_POST['attribute_combinaison_list']))

 

Tu peux me confirmer que cela marche pour toi ?

Share this post


Link to post
Share on other sites

Oui je viens de le refaire à l'instant ça ne change rien, j'ai même essayer de faire une nouvelle fiche produit mais impossible d'ajouter plusieurs attribut d'un même groupe dans une déclinaison j'ai toujours le message d'erreur.

post-125302-0-63077400-1316512849_thumb.jpg

Share this post


Link to post
Share on other sites

Nous voilà revenu au point de départ, et si je contourne le problème ma gestion des stock n'est plus bonne et là ça devient ingérable, il faut absolument trouver une solution, et je suis sure qu'il y en a une puisque sous la 1.3 ça fonctionnait.

Share this post


Link to post
Share on other sites

Bonjour Tchupa,

 

J'ai pu avoir plus d'informations du support sur ce "fonctionnement" de la 1.3.

 

C'est un bug présent dans cette version qui permettait d'ajouter plusieurs attributs à une déclinaison.

 

Ce problème étant corrigé dans la 1.4 c'est pour cela que tu ne retrouves pas le même fonctionnement.

 

Pour le code, le support l'a testé. Le plus simple est de les contacter si ça ne change rien pour toi.

Share this post


Link to post
Share on other sites

Bonjour Carl,

 

oui on m'avait bien dit que c'était un bug sur l'ancienne version lors de mon appel au support mais on m'avait pas donné du tout de solution.

 

Tu as quand même fait avancer le soucis depuis, je t'en remercie.

 

Par contre tu me confirme que le support a testé les modifications du code, tu me confirme que cette modification recrée ce fameux bug?

 

Parce que si c'est pas le cas , je fais quoi moi ? je suis vraiment dans la ****** car la situation que j'expose ici est pourtant logique dans certain domaine de la vente en ligne.

 

 

Ps: c'était quand même un bug rudement efficace, je sais pas si on peut vraiment appeler ça un bug <_<

Share this post


Link to post
Share on other sites

  • 7 months later...

Je viens de mettre à jour une version 1.2.5 vers 1.4.7, et pareil, les déclinaisons telles que formatées dans l'ancienne version empêche que les achats soient effectués... y a-t-il un patch ou autre pour ce problème ? une requête SQL magique ? mon client a un peu mal aux reins rien que de penser au temps qu'il va passer à tout convertir...

 

Comment se fait-il que cela n'est pas géré lors de la mise à jour ? Comment se fait-il que les anciennes déclinaisons soient maintenues dans le système ?

 

Concernant le fait que cela serait un bug, je trouve ça très louche, car tout fonctionnait très bien. Messieurs les développeurs de Prestashop, en gage de bonne foi, vous pourriez nous fournir un patch, non ?

 

CAR AU FINAL, nous passons pour des rigolos aux yeux de nos clients, et ça, à VOTRE PLACE.

 

En vous remerciant de votre compréhension, j'espère que vous pourrez y apporter une solution rapide et efficace.

 

D'avance merci.

 

Eric

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More