Jump to content
Sign in to follow this  
amyal

Problème de base de données pendant la mise à jour de PS

Recommended Posts

Bonjour à tous. Avec mon pote qui m'aide à gérer la partie technique de notre site prestashop, nous avons recontré quelques problèmes de bdd qui me semblent un peu bizarre pendant la mise à jour de prestashop 1 vers la version 1.1 :

Table ps_access : dans la nouvelle version, le champ id_access n'existe plus.(Unknown column 'id_access' in 'field list')

Table ps_connexions : ici deux noms de champs ont changé (id_customer semble être remplacé par id_guest et date par date_add)
ancien : id_connections, id_customer, ip_address, date
nouveau : id_connections, id_guest, id_page, ip_adress, date_add, http_referer

table ps_country :
nouveau champ deleted
Unknown column 'deleted' in 'field list'

#1146 - Table 'ps_newsletter' doesn't exist

table `ps_product_lang`
#1054 - Unknown column 'availability' in 'field list'

Après suppression des 5 tables ci-dessus qui posaient problème, l'installation démarre, mais il manque des menus et la page d'accueil annonce "Tentative de piratage".

Quelqu'un a -t-il rencontré les même problèmes. La façon dont nous avons procédé pour les corriger est-elle bien catholique. J'avoue être déjà un peu circonspect car qu'est ce que ce sera le jour où il faudra passer à une V1.2 ?

Merci de vos opinions.

Share this post


Link to post
Share on other sites

J'ai les mêmes soucis...
J'ai les erreurs suivantes lors de la mise à jour de la base:
INSERT INTO ps_block_cms (`id_block`, `id_cms`) VALUES ((SELECT id_module FROM ps_module m WHERE m.name = 'blockinfos' LIMIT 1), 1)
(1048) Column 'id_block' cannot be null

INSERT INTO ps_block_cms (`id_block`, `id_cms`) VALUES ((SELECT id_module FROM ps_module m WHERE m.name = 'blockinfos' LIMIT 1), 2)
(1048) Column 'id_block' cannot be null

INSERT INTO ps_block_cms (`id_block`, `id_cms`) VALUES ((SELECT id_module FROM ps_module m WHERE m.name = 'blockinfos' LIMIT 1), 3)
(1048) Column 'id_block' cannot be null

INSERT INTO ps_block_cms (`id_block`, `id_cms`) VALUES ((SELECT id_module FROM ps_module m WHERE m.name = 'blockinfos' LIMIT 1), 4)
(1048) Column 'id_block' cannot be null

Si je passe outre (mais je n'ai pas osé toucher aux tables par contre), la page d'accueil est ok, mais je n'ai plus aucune page visible de mes articles. (erreur du type : The requested URL /miel/10-miel-de-fleur.html was not found on this server)
Est-ce quelqu'un a une solution ? (je retourne en 1.0.0.8 en attendant...)
Merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More