Jump to content
Sign in to follow this  
Alexa

RESOLU Problème installation sur ovh

Recommended Posts

Bonjour,
Voila j'essaye de mettre en ligne mon prestashop sur ovh mais je n'y arrive pas. J'ai un plan 90 et j'utilise Filezilla, j'ai corrigé mon dossier settings, mais lorsque je vais sur ma page d'accueil j'ai une page blanche avec un dossier prestashop et lorsque je clique dessus j'ai tous les liens sans aucune mise en page, quelqu'un peu m'aider ?
Merci d'avance !!!

Share this post


Link to post
Share on other sites
Guest

Utilise la fonction recherche... Il y a plein de post à propos des blèmes chez OVH...

Share this post


Link to post
Share on other sites

la fonction recherche ? si cela veut dire de demander l'affichage des erreur php je l'ai fais mais ça n'a rien donné de plus...

Share this post


Link to post
Share on other sites

oui j'ai ddéjà cherché des posts sur le sujet avant d'en créer un mais mon problème n'est pas le même que ceux trouvés...

Share this post


Link to post
Share on other sites

Si tu vois tous les liens sans mise en forme c'est que la CSS n'est pas trouvée.

Si ta boutique est dans un dossier www/prestashop/, alors ton fichier /config/settings.inc.php doit contenir la ligne :
define('__PS_BASE_URI__', '/prestashop/');

Share this post


Link to post
Share on other sites

Merci ! merci merci !
après plusieurs jours de galère mon problème est résolu !!!!

Share this post


Link to post
Share on other sites
Si tu vois tous les liens sans mise en forme c'est que la CSS n'est pas trouvée.

Si ta boutique est dans un dossier www/prestashop/, alors ton fichier /config/settings.inc.php doit contenir la ligne :
define('__PS_BASE_URI__', '/prestashop/');



Bonjour,
je suis un nouvel utilisateur, et moi aussi, j'ai une page blanche en tapant mon URL ou se trouve mon dossier prestashop !
Donc impossible d'installer ma boutique à ma base de donnée.
Je viens d'essayer d'ajouter la ligne que vous avez indiqué : define(’PS_BASE_URI‘, ‘/prestashop/’);
Mais maintenant ça m'indique :
Warning: Division by zero in /homez.29/tungsten/www/prestashop/config/config.inc.php on line 4

Voir extrait de la config :

<?php


define(’PS_BASE_URI‘, ‘/prestashop/’);

/* Improve PHP configuration to prevent issues */
@ini_set('display_errors', 'off');
@ini_set('upload_max_filesize', '100M');
@ini_set('default_charset', 'utf-8');




Pour info je suis aussi chez OVH, mais je ne vois pas où est le problème !?

Merci pour votre aide, mes début avec prestashop commence mal...

Share this post


Link to post
Share on other sites

C'est un extrait de quel fichier ça ?

L'instruction que j'ai donnée plus haut doit être ajoutée au fichier :
config/config.inc.php
et non pas :
config/settings.inc.php

Inversement, la ligne :
define(’PS_BASE_URI‘, ‘/prestashop/’);
n'a rien a faire dans :
config/config.inc.php
mais doit être dans :
config/settings.inc.php
Cette ligne doit être adaptée en fonction du répertoire d'installation de PS. Dans le cas présent dans un dossier prestashop.

Share this post


Link to post
Share on other sites

Bonjour,

non il s'agit bien d'un extrait du fichier config/config.inc.php !

mon url de site est : www.tungsten-prod.com/prestashop

Share this post


Link to post
Share on other sites
Bonjour,

non il s'agit bien d'un extrait du fichier config/config.inc.php !

mon url de site est : www.tungsten-prod.com/prestashop


Et qu'est-ce qu'elle fait la ligne :
define(’PS_BASE_URI‘, ‘/prestashop/’);
dans ce fichier ?

Share this post


Link to post
Share on other sites

j'avais cru comprendre la mettre là mais par contre je n'ai pas de fichier config/settings.inc.php ??
Faut-il le créer ?

Share this post


Link to post
Share on other sites

Il me semble qu'il se crée pendant l'install.

Si j'ai bien compris, tu ne l'as pas encore faite. Donc commence par réessayer de la lancer...

Share this post


Link to post
Share on other sites

Bon alors j'ai renlevé cette fameuse ligne !
J'ai donc à nouveau une page blanche, voir : www.tungsten-prod.com/prestashop
Je ne peux donc pas créer de setting si j'ai impossibilité d'installer ?

Share this post


Link to post
Share on other sites

Laisse le fichier settings.inc.php tranquille, il se créera tout seul...

Bon, vu comme c'est parti, je te conseille de supprimer tous les fichiers de PS, de les réuploader (avec un vrai client FTP comme FileZilla) et de relancer l'install.

Share this post


Link to post
Share on other sites

Ce serait pas une histoire d'accès au serveur ?
Le dossier prestashop est en 705.
Sinon je vais recommencer l'install complète, je la fais habituellement avec FETCH.

Share this post


Link to post
Share on other sites

Autant pour moi,
j'ai épluché de près les droits d'accès et tout a changé !
De plus j'ai ajouté un htaccess pour OVH.
Mais si je n'avais pas reçu ton lien, je ne l'avais pas remarqué tout seul dans l'accueil du site ou le process de l'install.
Encore merci...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More