Jump to content
shacker

[MODULO] Logo format v1.5- cambia el formato del logo de la tienda

Recommended Posts

Prestashop sólo permite logos jpg para su tienda, por lo que necesita cambiar el código en el header.tpl del tema y subir el logotipo en la carpeta de imágenes. Format logo es un módulo que le permite cargar el logotipo de png, jpg, gif o modificar su plantilla y para mostrar su logo sin conocimientos.

Simplemente cargando su logotipo con el módulo, seleccione el formato y listo!!

http://catalogo-onli...go-formato.html

v1.2 - permite cambiar la posicion del logo mediante el hookTop en modulos, posiciones
v1.3 - añadimos posicion absoluta o relativa
v1.4-multistore,
v1.5 - usa el logo por defecto en tiendas sin multistore


logo-format.jpg
Version adjunta: 1.0

logoformat.zip

  • Like 3

Share this post


Link to post
Share on other sites

Hola:

 

He probado el modulo pero a mi no me funciona , me refiero a que mi imagen esta en formato .png y me sigue sin mostrar las transparencias ... alguna idea sobre lo puede estar pasando , por cierto gracias por el modulo me parece increíble que nadie te ha haya dado las gracias.

 

Un saludo

Share this post


Link to post
Share on other sites

suele pasar jeje.

El logo lo debes subir desde el modulo, y tambien el archivo header.tpl debe tener permisos de escritura para que modifique el formato.

sino funciona, edita el header;tpl de tu theme, cambia a logo.png y tu logo deberia estar en al carpeta img de prestashop. recuerda que desde el admin no puedes subir png por que los convierte a jpg

Share this post


Link to post
Share on other sites

v1.2 - permite cambiar la posicion del logo y no es necesario modificar el header.tpl

Share this post


Link to post
Share on other sites

Lo he instalado he subido un logo, lo he puesto que se muestre al centro del header y no funciona. Estoy subiendo una imagen .jpg normal sin mucho lio. Me podrías ayudar a resolver ese problema ?

Saludos

Share this post


Link to post
Share on other sites

Ya lo veo, es que se me fue hacia abajo xd.. listo funciona de maravillas.. gracias por el aporte.. Saludos

Share this post


Link to post
Share on other sites

de nada. Recuerda que puedes poner el ancho al 100% para que no quede nada al lado

Share this post


Link to post
Share on other sites

Saludos Shacker, estoy utilizando el modulo en el Tema Perfum tuyo, pero configurando el ancho de mil maneras, y la posición "left" no logro que el logo quede a la izquierda, como es usual

Share this post


Link to post
Share on other sites

Gracias Shacker, en HEADER y en TOP lo tengo en número 1, el tema es que le logo me sale casi al centro, aunque varíe el porcentaje de ancho hasta 0.

Share this post


Link to post
Share on other sites

Muchas gracias!, me viene de maravilla... mañana lo instalo a ver que tal...

Share this post


Link to post
Share on other sites

Ya he instalado el módulo pero no sé como encontrarlo, es decir, voy a la pestaña módulos y busco el mismo por "logoformat" y no me aparece nada.

Share this post


Link to post
Share on other sites

Lo mismo me pasa, pero me pasa con la versión que bajo desde la página del autor (versión 1.3), el modulo de esta página (versión 1) no me dio problema alguna. Saludos.

Share this post


Link to post
Share on other sites

Yo tengo la 1.5.2

 

Crees que si me bajo la versión 1 de este módulo me dará errores para prestashop 1.5.2 me dará errores?

Share this post


Link to post
Share on other sites

Prueba descargarlo de nuestro sitio de nuevo, Ya lo subimos de nuevo y deberias poder instalarlo desde añadir modulos. apareceria en la pestaña front office features o tools, dependiendo la version de presta

Share this post


Link to post
Share on other sites

Ok... ya está instalado, ahora tengo otro problema, una vez que subo el logo me aparece descuadrado, mirar la captura:

 

%204716e4e361d4e66735a3def1804c09f9.jpg"]http:// 4716e4e361d4e66735a3def1804c09f9.jpg[/url]

Share this post


Link to post
Share on other sites

El logo de arriba es el que ya estaba, subido desde Preferencias - Temas - Logo

 

El otro de abajo está subido con "Logoformat"

Share this post


Link to post
Share on other sites

el de abajo lo posicionas desde modulos -> posiciones, y en top lo acomodas con donde quieras

 

el de arriba no se que clase tenga asignada. QUe clase es la del logo?

Share this post


Link to post
Share on other sites

???... a qué clase? ya me he perdido. El otro lo subí desde la pestaña Preferencias - Temas - Logo de encabezamiento, una imagen JPG.

Share this post


Link to post
Share on other sites

Mi intención es quitar el logo que está arriba y colocar el nuevo (el subido en PNG)

 

Vale, vale... ya casi lo tengo:

 

66d9d3f5ba264ed04ddc3b92c29520f3.jpg

Edited by JoseMRT

Share this post


Link to post
Share on other sites

Hola a todos, después de estar trasteando con el módulo "logoformat 1.3" descargado desde: http://www.catalogo-onlinersi.com.ar/ para mi versión de Prestashop 1.5.2 y de unos cuanto privados con shacker, he solucionado mi problema que era:

 

1 - Después de posicionar el módulo en el sitio correcto me surgió otro problema, no sabía eliminar el logo antiguo el cual solucioné editando el archivo css de mi plantilla de la siguiente manera:

 

a#header_logo {

position: absolute;

top: 58px;

text-align: center;

margin: 0px;

width: 100%;

font: normal 80px "ModernNo.20Regular";

line-height: 88px;

color: #3C3C3C;

display: none;

}

 

2 - Luego me surgió otro, y era que el logo sólo me aparecía en la pantalla de inicio, otra vez más shacker me lo solucionó editando el archivo category.css del theme y quitando la siguiente linea:

 

h1 {

  • display: none;

 

}

 

En un principio parecía que no funcionaba pero bastó con reiniciar el pc para que todo fuera como la seda. Por ahora todo OK

 

Gracias Shacker!

Share this post


Link to post
Share on other sites

lo he instalado pero no me aparece en la lista de modulos, con que nombre aparece?

Share this post


Link to post
Share on other sites

Log oformat o formato de logo, lo instalaste desde modulos, añadir modulo y lo bajaste desde nuestro sitio? es la ultima version

Share this post


Link to post
Share on other sites

Si bajado de vosotros, el caso es que lo busco con el filezilla y está ahí, pero luego desde el admin en modulos no aparece por ningun lado.

Share this post


Link to post
Share on other sites

debes instalarlo desde modulos. en modules, debe estar la carpeta, y sin subcarpeta que se llame igual, sino esta mal subido

Share this post


Link to post
Share on other sites

Hola..

 

Lo he bajado y al tratar de instalarlo en mi version 1.5.3.1 me dice "The module logoformat you uploaded is not a module"

 

Saludos

Share this post


Link to post
Share on other sites

raro, por que es un modulo. Lo bajaste de nuestro sitio?

 

Muchas Gracias por las respuestas.

Baje la version que esta en el primer Post de este tema y no funciono, ahora lo baje directamente de su tienda, y todo muy bien, se instalo bien y funciona, solo que la imagen me aparece debajo del menu horizontal. Me imagino que esto debe de corregirse por configuracion.

Excelente aporte, solo espero seguir aprendiendo y en algun momento poder ayudar a otros usuarios de la comunidad.

 

Saludos y garcias de nuevo

Share this post


Link to post
Share on other sites

v1.5 - usa el logo por defecto en tiendas sin multistore

Share this post


Link to post
Share on other sites

Buenas,

He probado el modulo en la versión 1.5.4.1 y me funciona perfectamente, salvo por lo que han comentado anteriormente, el logo se queda debajo del menú horizontal, he tratado de desplazar el modulo y no lo consigo, la verdad es que no controlo mucho, así que agradecería que explicases como se hace, he entrado en el menú "módulos" "posiciones" trasladar modulo y ahí me quedo, jeje

Gracias de antemano y por el aporte

un saludo,

Joaquin

Share this post


Link to post
Share on other sites

Ya lo he conseguido, ahora solo queda que el bloque pequeño del carrito y de usuario se coloquen sobre el logo.

Share this post


Link to post
Share on other sites

Me refiero a que no se si esta bien hecho, pero funciona. Lo que me queda es poner el carrito y el login sobre el logo, eso ya no tengo ni idea de como hacerlo

Share this post


Link to post
Share on other sites

Hola que tal, bueno ya instale este modulo de logo, solo que no logro ponerlo en la parte de la cabecera me sale abajo de la barra horizontal, como he modificado el homeslider haciendolo mas grande en anchura, el logo me aparece abajo de este modulo homeslider, alguna suigerencia ? anexo captura de pantalla 

 

 

https://www.dropbox.com/s/5d9ba9drxulpphe/Captura%20de%20pantalla%202013-10-28%2011.42.03.png

 

Captura%20de%20pantalla%202013-10-28%201

Edited by QUALITYLAP

Share this post


Link to post
Share on other sites

fuiste a modulos, posisiones, y en la seccion top lo moviste hacia arriba de los demas modulos?

Share this post


Link to post
Share on other sites

Listo amigo gracias ya encontré la sección para mover, agradezco tu ayuda  y para insertar mas contenido o centrar el logo ? me puedes ayudar 

Edited by QUALITYLAP

Share this post


Link to post
Share on other sites

el log oconfiguras el modulo y lo pones al 100% de ancho. lo otro  abre otro post

Share this post


Link to post
Share on other sites

Hola, muchísimas gracias por el aporte, me parece un módulo muy útil. ¿Es compatible con  PrestaShop™ 1.5.6.2?

Share this post


Link to post
Share on other sites

hola, he instalado el modulo pero el logo no se pone bien y no tengo ni idea de como corregirlo para que ponga en su sitio, podrias ayudarme.

Lo que ocurre es que sd me queda demasiado abajo tendria que estar mas arriba y no se como hacer para subirlo, os pongo la pagina haber si alguien puede ayudarme. Www.esenciasdevida.com

Gracias

Edited by hilber

Share this post


Link to post
Share on other sites

Hola estimados, ojala me puedan ayudar, sucede que instale el modulo, subi el logo, pero me queda en el centro y necesito que quede al costado izquierdo, adjunto un print pantalla para que lo puedan ver, necesito que el logo quede en la cruz roja, me pueden ayudar?

 

 

 

Print.jpg

Share this post


Link to post
Share on other sites

dsde modulos, posiciones, en la seccion top mueve el modulo arriba de todos

Share this post


Link to post
Share on other sites

Buenas tardes, lo he instalado pero no consigo que el logo de la tienda en formato gift funcione se queda estático como si fuera un png y me sale muy abajo, ¿cómo lo soluciono?, gracias. Tengo prestashop 1.5.6.2

post-560493-0-15379900-1448641537_thumb.jpg

Edited by cocolisto

Share this post


Link to post
Share on other sites

ve a m odulos, posiciones, y en la seccion top muevelo arriba de todo

Share this post


Link to post
Share on other sites

Hola, tengo un problema, lo he descargado 3 veces, me dice que el modulo se ha descargado correctamente, pero no aparece por ningun lado. ¿que puede pasar?

Muchisimas gracias

Share this post


Link to post
Share on other sites

lo has instalado desde el back office?

 

Yo lo he instalado desde el back office y no me hace nada. Uso la version 1.6 y nose si sera compatible. el caso esque subo imágenes no me hace nada. Intento en insertar un hook y no tiene asignado ninguno.

 

Sabes que podría ser?

Saludos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More