Jump to content
  • 0
shacker

[MODULO] Logo format v1.5- cambia el formato del logo de la tienda

Question

Prestashop sólo permite logos jpg para su tienda, por lo que necesita cambiar el código en el header.tpl del tema y subir el logotipo en la carpeta de imágenes. Format logo es un módulo que le permite cargar el logotipo de png, jpg, gif o modificar su plantilla y para mostrar su logo sin conocimientos.

Simplemente cargando su logotipo con el módulo, seleccione el formato y listo!!

http://catalogo-onli...go-formato.html

v1.2 - permite cambiar la posicion del logo mediante el hookTop en modulos, posiciones
v1.3 - añadimos posicion absoluta o relativa
v1.4-multistore,
v1.5 - usa el logo por defecto en tiendas sin multistore


logo-format.jpg
Version adjunta: 1.0

logoformat.zip

Share this post


Link to post
Share on other sites

70 answers to this question

Recommended Posts

  • 0

Hola:

 

He probado el modulo pero a mi no me funciona , me refiero a que mi imagen esta en formato .png y me sigue sin mostrar las transparencias ... alguna idea sobre lo puede estar pasando , por cierto gracias por el modulo me parece increíble que nadie te ha haya dado las gracias.

 

Un saludo

Share this post


Link to post
Share on other sites
  • 0

suele pasar jeje.

El logo lo debes subir desde el modulo, y tambien el archivo header.tpl debe tener permisos de escritura para que modifique el formato.

sino funciona, edita el header;tpl de tu theme, cambia a logo.png y tu logo deberia estar en al carpeta img de prestashop. recuerda que desde el admin no puedes subir png por que los convierte a jpg

Share this post


Link to post
Share on other sites
  • 0

Lo he instalado he subido un logo, lo he puesto que se muestre al centro del header y no funciona. Estoy subiendo una imagen .jpg normal sin mucho lio. Me podrías ayudar a resolver ese problema ?

Saludos

Share this post


Link to post
Share on other sites
  • 0

Saludos Shacker, estoy utilizando el modulo en el Tema Perfum tuyo, pero configurando el ancho de mil maneras, y la posición "left" no logro que el logo quede a la izquierda, como es usual

Share this post


Link to post
Share on other sites
  • 0

Ya he instalado el módulo pero no sé como encontrarlo, es decir, voy a la pestaña módulos y busco el mismo por "logoformat" y no me aparece nada.

Share this post


Link to post
Share on other sites
  • 0

Lo mismo me pasa, pero me pasa con la versión que bajo desde la página del autor (versión 1.3), el modulo de esta página (versión 1) no me dio problema alguna. Saludos.

Share this post


Link to post
Share on other sites
  • 0

Yo tengo la 1.5.2

 

Crees que si me bajo la versión 1 de este módulo me dará errores para prestashop 1.5.2 me dará errores?

Share this post


Link to post
Share on other sites
  • 0

Prueba descargarlo de nuestro sitio de nuevo, Ya lo subimos de nuevo y deberias poder instalarlo desde añadir modulos. apareceria en la pestaña front office features o tools, dependiendo la version de presta

Share this post


Link to post
Share on other sites
  • 0

El logo de arriba es el que ya estaba, subido desde Preferencias - Temas - Logo

 

El otro de abajo está subido con "Logoformat"

Share this post


Link to post
Share on other sites
  • 0

???... a qué clase? ya me he perdido. El otro lo subí desde la pestaña Preferencias - Temas - Logo de encabezamiento, una imagen JPG.

Share this post


Link to post
Share on other sites
  • 0

Mi intención es quitar el logo que está arriba y colocar el nuevo (el subido en PNG)

 

Vale, vale... ya casi lo tengo:

 

66d9d3f5ba264ed04ddc3b92c29520f3.jpg

Edited by JoseMRT

Share this post


Link to post
Share on other sites
  • 0

Hola a todos, después de estar trasteando con el módulo "logoformat 1.3" descargado desde: http://www.catalogo-onlinersi.com.ar/ para mi versión de Prestashop 1.5.2 y de unos cuanto privados con shacker, he solucionado mi problema que era:

 

1 - Después de posicionar el módulo en el sitio correcto me surgió otro problema, no sabía eliminar el logo antiguo el cual solucioné editando el archivo css de mi plantilla de la siguiente manera:

 

a#header_logo {

position: absolute;

top: 58px;

text-align: center;

margin: 0px;

width: 100%;

font: normal 80px "ModernNo.20Regular";

line-height: 88px;

color: #3C3C3C;

display: none;

}

 

2 - Luego me surgió otro, y era que el logo sólo me aparecía en la pantalla de inicio, otra vez más shacker me lo solucionó editando el archivo category.css del theme y quitando la siguiente linea:

 

h1 {

  • display: none;

 

}

 

En un principio parecía que no funcionaba pero bastó con reiniciar el pc para que todo fuera como la seda. Por ahora todo OK

 

Gracias Shacker!

Share this post


Link to post
Share on other sites
  • 0

Log oformat o formato de logo, lo instalaste desde modulos, añadir modulo y lo bajaste desde nuestro sitio? es la ultima version

Share this post


Link to post
Share on other sites
  • 0

Si bajado de vosotros, el caso es que lo busco con el filezilla y está ahí, pero luego desde el admin en modulos no aparece por ningun lado.

Share this post


Link to post
Share on other sites
  • 0

raro, por que es un modulo. Lo bajaste de nuestro sitio?

 

Muchas Gracias por las respuestas.

Baje la version que esta en el primer Post de este tema y no funciono, ahora lo baje directamente de su tienda, y todo muy bien, se instalo bien y funciona, solo que la imagen me aparece debajo del menu horizontal. Me imagino que esto debe de corregirse por configuracion.

Excelente aporte, solo espero seguir aprendiendo y en algun momento poder ayudar a otros usuarios de la comunidad.

 

Saludos y garcias de nuevo

Share this post


Link to post
Share on other sites
  • 0

Buenas,

He probado el modulo en la versión 1.5.4.1 y me funciona perfectamente, salvo por lo que han comentado anteriormente, el logo se queda debajo del menú horizontal, he tratado de desplazar el modulo y no lo consigo, la verdad es que no controlo mucho, así que agradecería que explicases como se hace, he entrado en el menú "módulos" "posiciones" trasladar modulo y ahí me quedo, jeje

Gracias de antemano y por el aporte

un saludo,

Joaquin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×