Jump to content

[MODULO] Logo format v1.5- cambia el formato del logo de la tienda


Recommended Posts

Prestashop sólo permite logos jpg para su tienda, por lo que necesita cambiar el código en el header.tpl del tema y subir el logotipo en la carpeta de imágenes. Format logo es un módulo que le permite cargar el logotipo de png, jpg, gif o modificar su plantilla y para mostrar su logo sin conocimientos.

Simplemente cargando su logotipo con el módulo, seleccione el formato y listo!!

http://catalogo-onli...go-formato.html

v1.2 - permite cambiar la posicion del logo mediante el hookTop en modulos, posiciones
v1.3 - añadimos posicion absoluta o relativa
v1.4-multistore,
v1.5 - usa el logo por defecto en tiendas sin multistore


logo-format.jpg
Version adjunta: 1.0

logoformat.zip

  • Like 3

Share this post


Link to post
Share on other sites
  • 6 months later...

Hola:

 

He probado el modulo pero a mi no me funciona , me refiero a que mi imagen esta en formato .png y me sigue sin mostrar las transparencias ... alguna idea sobre lo puede estar pasando , por cierto gracias por el modulo me parece increíble que nadie te ha haya dado las gracias.

 

Un saludo

Share this post


Link to post
Share on other sites

suele pasar jeje.

El logo lo debes subir desde el modulo, y tambien el archivo header.tpl debe tener permisos de escritura para que modifique el formato.

sino funciona, edita el header;tpl de tu theme, cambia a logo.png y tu logo deberia estar en al carpeta img de prestashop. recuerda que desde el admin no puedes subir png por que los convierte a jpg

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 months later...

Lo he instalado he subido un logo, lo he puesto que se muestre al centro del header y no funciona. Estoy subiendo una imagen .jpg normal sin mucho lio. Me podrías ayudar a resolver ese problema ?

Saludos

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 2 months later...

Lo mismo me pasa, pero me pasa con la versión que bajo desde la página del autor (versión 1.3), el modulo de esta página (versión 1) no me dio problema alguna. Saludos.

Share this post


Link to post
Share on other sites

Prueba descargarlo de nuestro sitio de nuevo, Ya lo subimos de nuevo y deberias poder instalarlo desde añadir modulos. apareceria en la pestaña front office features o tools, dependiendo la version de presta

Share this post


Link to post
Share on other sites

el de abajo lo posicionas desde modulos -> posiciones, y en top lo acomodas con donde quieras

 

el de arriba no se que clase tenga asignada. QUe clase es la del logo?

Share this post


Link to post
Share on other sites

Hola a todos, después de estar trasteando con el módulo "logoformat 1.3" descargado desde: http://www.catalogo-onlinersi.com.ar/ para mi versión de Prestashop 1.5.2 y de unos cuanto privados con shacker, he solucionado mi problema que era:

 

1 - Después de posicionar el módulo en el sitio correcto me surgió otro problema, no sabía eliminar el logo antiguo el cual solucioné editando el archivo css de mi plantilla de la siguiente manera:

 

a#header_logo {

position: absolute;

top: 58px;

text-align: center;

margin: 0px;

width: 100%;

font: normal 80px "ModernNo.20Regular";

line-height: 88px;

color: #3C3C3C;

display: none;

}

 

2 - Luego me surgió otro, y era que el logo sólo me aparecía en la pantalla de inicio, otra vez más shacker me lo solucionó editando el archivo category.css del theme y quitando la siguiente linea:

 

h1 {

  • display: none;

 

}

 

En un principio parecía que no funcionaba pero bastó con reiniciar el pc para que todo fuera como la seda. Por ahora todo OK

 

Gracias Shacker!

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...
  • 3 weeks later...

raro, por que es un modulo. Lo bajaste de nuestro sitio?

 

Muchas Gracias por las respuestas.

Baje la version que esta en el primer Post de este tema y no funciono, ahora lo baje directamente de su tienda, y todo muy bien, se instalo bien y funciona, solo que la imagen me aparece debajo del menu horizontal. Me imagino que esto debe de corregirse por configuracion.

Excelente aporte, solo espero seguir aprendiendo y en algun momento poder ayudar a otros usuarios de la comunidad.

 

Saludos y garcias de nuevo

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 2 weeks later...
  • 3 months later...

Buenas,

He probado el modulo en la versión 1.5.4.1 y me funciona perfectamente, salvo por lo que han comentado anteriormente, el logo se queda debajo del menú horizontal, he tratado de desplazar el modulo y no lo consigo, la verdad es que no controlo mucho, así que agradecería que explicases como se hace, he entrado en el menú "módulos" "posiciones" trasladar modulo y ahí me quedo, jeje

Gracias de antemano y por el aporte

un saludo,

Joaquin

Share this post


Link to post
Share on other sites
  • 2 months later...

Hola que tal, bueno ya instale este modulo de logo, solo que no logro ponerlo en la parte de la cabecera me sale abajo de la barra horizontal, como he modificado el homeslider haciendolo mas grande en anchura, el logo me aparece abajo de este modulo homeslider, alguna suigerencia ? anexo captura de pantalla 

 

 

https://www.dropbox.com/s/5d9ba9drxulpphe/Captura%20de%20pantalla%202013-10-28%2011.42.03.png

 

Captura%20de%20pantalla%202013-10-28%201

Edited by QUALITYLAP (see edit history)

Share this post


Link to post
Share on other sites
  • 3 months later...
  • 3 months later...

hola, he instalado el modulo pero el logo no se pone bien y no tengo ni idea de como corregirlo para que ponga en su sitio, podrias ayudarme.

Lo que ocurre es que sd me queda demasiado abajo tendria que estar mas arriba y no se como hacer para subirlo, os pongo la pagina haber si alguien puede ayudarme. Www.esenciasdevida.com

Gracias

Edited by hilber (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hola estimados, ojala me puedan ayudar, sucede que instale el modulo, subi el logo, pero me queda en el centro y necesito que quede al costado izquierdo, adjunto un print pantalla para que lo puedan ver, necesito que el logo quede en la cruz roja, me pueden ayudar?

 

 

 

Print.jpg

Share this post


Link to post
Share on other sites
  • 9 months later...
  • 8 months later...
  • 5 months later...

Hola, tengo un problema, lo he descargado 3 veces, me dice que el modulo se ha descargado correctamente, pero no aparece por ningun lado. ¿que puede pasar?

Muchisimas gracias

Share this post


Link to post
Share on other sites
  • 2 months later...

lo has instalado desde el back office?

 

Yo lo he instalado desde el back office y no me hace nada. Uso la version 1.6 y nose si sera compatible. el caso esque subo imágenes no me hace nada. Intento en insertar un hook y no tiene asignado ninguno.

 

Sabes que podría ser?

Saludos

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More