Jump to content

[Solved] Module not found


Recommended Posts

I have a module in localhost (localhost / sitename / admin) that works very well ..


But when I put the module online, and I try to configure it, I have an error: Module not found.

When I click on delete, this appears: Cannot load module object.


However the module is well present.


I have also noticed that the logo of the module does not appear, but for other modules it appears.

In localhost, all is good. The logo appears and I can configure, install, remove the module correctly.


The problem is just online. I tried to delete the module and put it back several times .. but nothing works.


Help me please ..

Link to comment
Share on other sites

  • 2 weeks later...

What actually happened is that in mymodule.php class,


public function __construct()
$this->name = 'MyModule';



This line : $this->name = 'MyModule'; created the error.


It should have been : $this->name = 'mymodule';


On my computer,im using windows, and the problem didnt occur.

But when i uploaded my module on my server,using linux,the uppercase thing caused the error..


I found ps_module and corrected the thing.

  • Like 4
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...