Jump to content
  • 0
akboselk

[Solved] installation stucked on Step 3 - installation type

Question

Hi

 

PS 1.4.4 installation error as below. I am on cpanel server

 

Initial steps (1 & 2 ) OK with ALL recommendation settings accepted. Folder permision also Correct

 

On STEP 3 >> DB connection Fine. also mail delivery OK

 

Now here the issue,

===================

 

On STEP 3 >> Installation type >> Simple Mode , giving below error

 

----------------

Error while inserting data in the database:

'SET NAMES \\\'utf8\\\''

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'\\\'utf8\\\'\' at line 1(Error: : 1064)

----------------

 

On STEP 3 >> Installation type >> Full mode , giving below error

 

----------------

Error while inserting data in the database:

'SET NAMES \\\'utf8\\\''

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'\\\'utf8\\\'\' at line 1(Error: : 1064)

----------------

 

 

So How we goto Next step and complete the installation ? How to Fix this installation problem on STABLE 1.4.4 ?

 

 

thanks

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

DB user has all privileges? U create new DB with UTF8 encoding?

 

I think here some thing wrong with mysql

Share this post


Link to post
Share on other sites
  • 0

Hi Kerm

 

DB user has all privileges? YES, DB Connection is OK

 

U create new DB with UTF8 encoding? >> There is no place to select on cPanel >> MySQL when it create. But phpMyAdmin I can see utf8_general_ci

 

--------- MySQL settings as below ---------------------

 

MySQL connection collation : utf8_general_ci

 

 

MYSQL

Server: Localhost via UNIX socket

Server version: 5.0.92-community-log

Protocol version: 10

User: multilan@localhost

MySQL charset: UTF-8 Unicode (utf8)

 

Web SERVER

cpsrvd 11.30.2.1

MySQL client version: 4.1.22

PHP extension: mysql Documentation

 

 

phpMyAdmin

Version information: 3.4.3.2

Documentation

Wiki

Official Homepage

Contribute

Get support

List of changes

 

------------------------------------------

My settings as above and please check it and let me now how to solve it ?

 

 

Note : I have another PS installation (Ver 1.4.0.17 ) working on same hosting account)

Share this post


Link to post
Share on other sites
  • 0

Hi Kerm

 

Thank you so much for the help , now it is working fine.

 

And one more thing, will there be any BO or FO functioning problem due to this Magic Quotes OFF ?

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

Hello guys. This is the way I managed to solve this problem:

 

Symptoms:

 

1. installation stuck on step 3 (DB connection – OK; Installation progress animation; but no success to move to step 4);

2. my mysql database engine is set to MyISAM;

3. default PS installation engine is selected as InnoDB;

 

Solution:

 

in step 3 choosing MyISAM DB engine helped me successfully move to step 4 :)

 

Hope my experience will help you.

Share this post


Link to post
Share on other sites
  • 0

Solve in my last post...change to MyISAM help u mb, but if u turn off magic quotes...u can use InnoDB and it's more better then MyISAM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×