Jump to content

Site Error caused by Slow queries executed towards my application's database.


ninki
 Share

Recommended Posts

Hi,

 

Can anyone help PLEASE? Our website is constantly down for the past 2 days. I've contacted the Host for our website (www.onedeko.co.uk) and following was their reply.

There seem to be issues with the database and possibly some module too? Is there anyone who knows how to resolve this?

 

'Here are some of the database queries that are slow and consume a lot of server resources:

 

Executed 1 min ago for 8 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 1 min ago for 7 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 1 min ago for 7 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 1 min ago for 14 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 0 min ago for 8 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 0 min ago for 10 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 0 min ago for 8 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

Executed 0 min ago for 12 sec on Database --> onedeko_prod.

DELETE FROM `ps_connections_page` WHERE id_connections IN ( SELECT `id_connections` FROM `ps_connections` WHERE date_add < LAST_DAY(DATE_SUB(NOW(), INTERVAL 1 WEEK

 

=====> Databases owned by onedeko.

Databases found:

onedeko_prod 545Mb.

onedeko_prodv2 128Mb.

onedeko_sampledemo 0Mb.

onedeko_sandboxonedeko 3Mb.

 

From the queries above we can conclude that your issue is caused by not well written scripts. In order to have the limitations removed, you should optimize your script so that it consumes less server resources.

 

Having not well written scripts is a quite complex problem. It may be caused by an additionally installed extension/module that is not working properly, or it may be in the application itself.

 

If the reason is in an extension/module, the easiest solution would be to disable/remove it. This can usually be done from the application's admin area.

 

Please disable the script that is using the queries above to resolve the issue.'

 

Thank you.

Share this post


Link to post
Share on other sites

Hi ninki,

 

You could try to disable all the modules and add them one by one to see which one is slowing down your website.

 

Also in Preferences>Performance, is Force compilation set to "no" ?

 

Have you also tried to activate CCC options ? (still in Preferences>Performance)

Share this post


Link to post
Share on other sites

Thank you for your reply Carl,

 

 

how would I be able to tell which one of the modules is slowing down the website?

My webhost agreed on taking away the limitations on the account for 24 hours, but this needs to be resolved.

Also, I've looked in Preferences, but don't have Performance there as an option.

we're still using Version 1.3.2.3 - 0.042s.

 

Is this something you could help with further please?

 

 

 

Hi ninki,

 

You could try to disable all the modules and add them one by one to see which one is slowing down your website.

 

Also in Preferences>Performance, is Force compilation set to "no" ?

 

Have you also tried to activate CCC options ? (still in Preferences>Performance)

Share this post


Link to post
Share on other sites

Hi again,

 

Onedeko, the company i work for, would be very happy to pay someone to resolve this issue.

Please could you get back to me with a quote?

We also in the future would like to upgrade to the latest version, this would be another job we want to outsource to a prestshop developer.

 

Thank you, Claudia

 

 

Thank you for your reply Carl,

 

 

how would I be able to tell which one of the modules is slowing down the website?

My webhost agreed on taking away the limitations on the account for 24 hours, but this needs to be resolved.

Also, I've looked in Preferences, but don't have Performance there as an option.

we're still using Version 1.3.2.3 - 0.042s.

 

Is this something you could help with further please?

 

 

 

Hi ninki,

 

You could try to disable all the modules and add them one by one to see which one is slowing down your website.

 

Also in Preferences>Performance, is Force compilation set to "no" ?

 

Have you also tried to activate CCC options ? (still in Preferences>Performance)

Share this post


Link to post
Share on other sites

Hello, try to desactivate the module "statsvisit", this should correct your problem. However, your visitors connections won't be logged anymore ;)

 

Edit : hmm my bad, it seems this will change nothing, well just desactivate all stats modules to see if it's ok after that

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More