Jump to content
bemcapaz

[MODULE][FREE] Facebook Like a Lot Prestashop 1.4+ [update 28/10 - With Facebook Open Graph tags]

Recommended Posts

The Facebook Like a Lot module, it appends bellow the product image a Like or Send button. The current version also turns your product page in a full open graph object for facebook, that means your product page can be discovered through facebook search like if it is a Facebook Fan Page :D

 

It's important that you create a Facebook App before using the module, it will need the information. If you need help creating the App you can follow this tutorial that explain step by step How to Create a Facebook App

 

Module Overview

Prestashop Version 1.4+

Module Version 1.3

Module Page Facebook Like a Lot Prestashop Module

Changelog

1.0 => 1.1 : added Open Graph compatibility to the module

1.1 .=> 1.2 : some tweaks on the code, added 2 new extra Open Graph tags the og:site_name and fb:app_id

1.1 => 1.2.1 : code review and tested on Prestashop 1.4.4.1

1.2.1 => 1.3: fixes for the changes on Facebook API

 

Download Link

 

Description and Features:

In the Admin page will be able to:

- Choose the language of your country (default to English, en_US)

- Input your own Facebook APP ID or use the default one provided with the module

- Select to show users pictures or not

- Show/Hide the new send button togheter with the Like Button

- Choose the text of the like button beetween LIKE or RECOMMEND

- Transform your page in a Open Graph Object by adding the following OG properties to your products page

og:title : get the name of the title of the product

og:type : setted to 'product', so facebook knows that your page is a product

og:image : also make the Send button always render the proper product image

og:description : get the short description of your product

og:url : your current product page url

og:site_name : automatically get your shop name new

fb:app_id : automatically get the app id of your site new

That means that your products now can be found on facebook like if they were Fan Pages, the picture appended show how it works.

 

Working Example:

You can find an example of the module running here http://develop.ilet....hp?id_product=1

 

Possible Integration Issues

1.My Like button isn´t being loaded right at the bottom of the image, what I have to do?

Make sure to uninstall any module that loads at the same place that the Like a Lot module, any module that is rendered after the Products image. After that, install Like a Lot module first and then reinstall the other modules, that will make Prestashop renders the LIke a Lot module right after the images.

 

2.When I click 'Like' it automatically gets unliked without any action, whats going on? new

This is a known Facebook issue. The easiest way to fix this up is by running the Facebook Lint application on the product link this bug is happening. Just go to http://developers.fa....com/tools/lint and type the address of the page where the bug is happening. It will clear the page cache for facebook and everything should work fine again.

Im available for any other doubts or problems regarding use and integration of the module.

 

Other Modules

I finished the Clean iLet jQuery Carousel Module that can be found in that link or in this forum in the post [MODULE][FREE] iLet Clean jQuery Carousel for Prestashop 1.4+

48335_2LI6ZIZMfR39FTfqXYUX_t

likealotmodule.zip

  • Like 3

Share this post


Link to post
Share on other sites

Great module. Everything working just fine. But i have one simple problem. Attached the picture with it. If is not hard for you bemcapaz, can you explain it to me ? Or someone else

47794_3rtDWSqNCJ1et6Eg6wE1_t

Share this post


Link to post
Share on other sites

Those options that are above the Like button, they are default of prestashop or are options added from other modules? I can´t say if it is a default option because of the language, hehe

Anyway, if they were added through a module thats because those other module are probably using the same hook that the Facebook one, the extraLeft. If thats the case I believe you can change their position in

Admin > Modules > Positions

That helped?

Share this post


Link to post
Share on other sites

I would like to embed it in another part of my template, theres any way I can do it?

Share this post


Link to post
Share on other sites

Great module. I'm wondering if I could change the image that the module chooses to make the link to facebook. It's choosing a sand clock and I need to get the product image. Any ideas?

  • Like 1

Share this post


Link to post
Share on other sites
Great module. Everything working just fine. But i have one simple problem. Attached the picture with it. If is not hard for you bemcapaz, can you explain it to me ? Or someone else


How to solve this problem?

Thanks...

Share this post


Link to post
Share on other sites

Hi, thanks for the feedback guys :)

jaro61, can you give me the link of where the error is ocurring?

I have to take a look to know for sure what can be hapenning, i couldn´t do much with the picture that CosTed posted because i can´t understand the language, so im kinda lost if that bug hapenned in the default configuration of prestashop or not.

Share this post


Link to post
Share on other sites

Ah just spoted the problem, its an easy fix

The problem is that you had installed two modules (Send to a friend AND The price one) before the Like a Lot module, so they are being ranked higher (rendered first) in prestashop when the page loads.

The way to fix it is by just uninstalling those modules and the facebook like a lot, then reinstalling then all, but make sure to install Facebook Like a Lot module first.

That way the prestashop will render like a lot module first than the others and it will appears right at the bottom of the image ;)

Tell me if that worked out for u

  • Like 1

Share this post


Link to post
Share on other sites
Hello, I'm looking for how to put the button francais.Merci


Hello

In the Admin options of the Like a Lot module there is a option called FACEBOOK APP LANGUAGE. It has a default value to en_US, all you have to do is change it to the code for french.

I just dont know wich one it is, i know that the brazilian portuguese is pt_BR, so its something with that pattern language_COUNTRY, maybe fr_FR ?

Share this post


Link to post
Share on other sites

When I click on the Like button, it shares it on facebook but with the wrong picture. How can I change it? As far as I can see, the picture depends on where is the button placed. Can you help me please?

You can test it here:
http://tresperfumes.com/es/perfumes -> If you click, you'll share it with the sand clock picture.
http://tresperfumes.com/es/5-hombre -> If you click here, you'll share it with the mail button picture.

Thank you, I appreciate your work :)

Share this post


Link to post
Share on other sites

@JuC - I just tested it and the same thing is happening to me, totally wrong picture is displayed!

Anyone some insights on this please?

Share this post


Link to post
Share on other sites
@JuC - I just tested it and the same thing is happening to me, totally wrong picture is displayed!

Anyone some insights on this please?


Looks like its posting a random image every time instead of the actual product image ..... i think it might have something to do with the meta og (open graph) tags thats missing in this module (taking a wild quess)

BUT I MUST SAY......

This is by far the best facebook like module i have come acrossed and if someone or the developer can maybe fix the image bug then i will very much recommend this module!

Maybe look at this modules attributes since everything works 100% (just lagging the well presented configure options in the BO as in likealotmodule has - http://www.prestashop.com/forums/viewthread/101086/

Share this post


Link to post
Share on other sites

So you guys are saying that when you share a product that is in the LIST of the products category, the like button is getting the wrong image to display on the facebook? That its showing the image from another product?

Share this post


Link to post
Share on other sites
So you guys are saying that when you share a product that is in the LIST of the products category, the like button is getting the wrong image to display on the facebook? That its showing the image from another product?


Yip, thats spot on, any product that one "likes" or "recommend" will be displayed on the persons facebook wall but with a random selected image of another product instead of the actual liked image..... the rest shows up 100%!

Share this post


Link to post
Share on other sites

Hi, juanv you´re correct, the bug can be easily solved by adding the og:image tag to the head section. However this fix will work only for the produc own page since any page can have a single og:image tag. Anyway im already working on it now and realease a updated version of the module today.

Thanks for the letting me know of the issue guys

  • Like 1

Share this post


Link to post
Share on other sites
Hi, juanv you´re correct, the bug can be easily solved by adding the og:image tag to the head section. However this fix will work only for the produc own page since any page can have a single og:image tag. Anyway im already working on it now and realease a updated version of the module today.

Thanks for the letting me know of the issue guys


Your most welcome and THANK YOU for the effort on this, really appreciate it!

Looking forward to the updated version, whoop whoop!

:)

Share this post


Link to post
Share on other sites
Hi, juanv you´re correct, the bug can be easily solved by adding the og:image tag to the head section. However this fix will work only for the produc own page since any page can have a single og:image tag. Anyway im already working on it now and realease a updated version of the module today.

Thanks for the letting me know of the issue guys


Yayyy! Great! Thank you bemcapaz. I've tried to add the og tags to fix the image issue with no proper result. I hope you'll be able to fix it. As juanv said, this is the best facebook like button module i've came across with.

I'm waiting patiently for the new version :D

Share this post


Link to post
Share on other sites

Just to let you guys know, I already updateded the module and its available on the first post, i changed the old one for the new one.

Let me know if it show any other problem ;)

Share this post


Link to post
Share on other sites

Hi bemcapaz and thank you for your contribution to this community; I am trying to test the carousel slide module and could not transplant it to the header, it is showed as hooked but not displaying at all; no error message either, am I missing something ?
I am working on localhost if that means anything.

Share this post


Link to post
Share on other sites
Just to let you guys know, I already updateded the module and its available on the first post, i changed the old one for the new one.

Let me know if it show any other problem ;)


Hi, Thank you for the updated version!

I have tested your new updated version and it works most of the time but i get an error next to the "Be the first of your friends to recommend this." If i click on the "error" a blanck window pops up with this address ->

http://www.facebook.com/connect/connect_to_node_error.php?title[func]=fbt_raw_array_unwrapped&title;[func_args][0]&title;[func_args][1][0]=No+administrators+were+specified.&title;[munge]=1&title;[need_force_raw]=0&title;[locale]=en_US&hash=AQDPGiTBUgfMSd9I

Most of the time the product gets posted on facebook with the right image and description even with this error and sometimes it will give no error and nothing will be posted on facebook?

Any ideas!

Many Thanx

Share this post


Link to post
Share on other sites
Just to let you guys know, I already updateded the module and its available on the first post, i changed the old one for the new one.

Let me know if it show any other problem ;)


Hi, Thank you for the updated version!

I have tested your new updated version and it works most of the time but i get an error next to the "Be the first of your friends to recommend this." If i click on the "error" a blanck window pops up with this address ->

http://www.facebook.com/connect/connect_to_node_error.php?title[func]=fbt_raw_array_unwrapped&title;[func_args][0]&title;[func_args][1][0]=No+administrators+were+specified.&title;[munge]=1&title;[need_force_raw]=0&title;[locale]=en_US&hash=AQDPGiTBUgfMSd9I

Most of the time the product gets posted on facebook with the right image and description even with this error and sometimes it will give no error and nothing will be posted on facebook?

Any ideas!

Many Thanx


After testing a few more products ..... once i click on the "recommend" link it will change to "confirm" and the when i click on "confirm" a window pops up and asks again to "like" the product! (see image)

is there a way to cut out this feature to make the process as fast and simple as possible?

:)

48398_2jSdBDVEcuQ886WSMfxQ_t

Share this post


Link to post
Share on other sites

Hey juanv, I looked intou the possible causes of the first problem mentioned and looks like that might be some Like Button bug. They are always updating the features of their apps so it isnt somthing really uncommon to happen, and those things tend to be corrected by itself (once their servers are ok or they fix the issue)

Also the proccess you mentioned can´t be changed since it is all sended from Facebook, even the proccess of how to render the Like button is coordinate from Facebook, all we can do is send in some parameters to configure how that should be rendered but its their servers that ultimately decide how it will be.

Thats why implemeting the Open Graphs tags are helpfull, facebook always read then before rendering the tools, so having a og:image will make Facebook use the link in there for the image and so on. All we can do is basicly configure the feature the best way possible to make sure any bugs wont happen.

For instance, are you using your own APP ID key or the facebook default APP ID that comes with the module? I found out that using a self created APP ID can be much better than using facebook shared one.

Share this post


Link to post
Share on other sites
Hey juanv, I looked intou the possible causes of the first problem mentioned and looks like that might be some Like Button bug. They are always updating the features of their apps so it isnt somthing really uncommon to happen, and those things tend to be corrected by itself (once their servers are ok or they fix the issue)

Also the proccess you mentioned can´t be changed since it is all sended from Facebook, even the proccess of how to render the Like button is coordinate from Facebook, all we can do is send in some parameters to configure how that should be rendered but its their servers that ultimately decide how it will be.

Thats why implemeting the Open Graphs tags are helpfull, facebook always read then before rendering the tools, so having a og:image will make Facebook use the link in there for the image and so on. All we can do is basicly configure the feature the best way possible to make sure any bugs wont happen.

For instance, are you using your own APP ID key or the facebook default APP ID that comes with the module? I found out that using a self created APP ID can be much better than using facebook shared one.


Hey

Thank you for replying so fast and for explaining these things to a noob like myself! It makes much more sense now!

Iam using my own created APP ID so thank you for that idea! I will leave this now for a couple of days and test it again but iam sure it will then be fixed!

Keep up the great work!

* GREAT MODULE AND THANK YOU*

Share this post


Link to post
Share on other sites
Hey juanv, I looked intou the possible causes of the first problem mentioned and looks like that might be some Like Button bug. They are always updating the features of their apps so it isnt somthing really uncommon to happen, and those things tend to be corrected by itself (once their servers are ok or they fix the issue)

Also the proccess you mentioned can´t be changed since it is all sended from Facebook, even the proccess of how to render the Like button is coordinate from Facebook, all we can do is send in some parameters to configure how that should be rendered but its their servers that ultimately decide how it will be.

Thats why implemeting the Open Graphs tags are helpfull, facebook always read then before rendering the tools, so having a og:image will make Facebook use the link in there for the image and so on. All we can do is basicly configure the feature the best way possible to make sure any bugs wont happen.

For instance, are you using your own APP ID key or the facebook default APP ID that comes with the module? I found out that using a self created APP ID can be much better than using facebook shared one.


Hey

Thank you for replying so fast and for explaining these things to a noob like myself! It makes much more sense now!

Iam using my own created APP ID so thank you for that idea! I will leave this now for a couple of days and test it again but iam sure it will then be fixed!

Keep up the great work!

*GREAT MODULE AND THANK YOU*

Share this post


Link to post
Share on other sites

No problem, actually I also must be thankfull for the feedback you gave to me, you helped me a lot on the improvment of the module ;)

Share this post


Link to post
Share on other sites
Hi bemcapaz and thank you for your contribution to this community; I am trying to test the carousel slide module and could not transplant it to the header, it is showed as hooked but not displaying at all; no error message either, am I missing something ?
I am working on localhost if that means anything.


Hey Rhobur, do you have any other module installed on header that is showing?

Share this post


Link to post
Share on other sites

Can you explain which file I need to edit to do this???? what folder/path etc..?


- Transform your page in a Open Graph Object by adding the following OG properties to your products page
og:title-> get the name of the title of the product
og:type -> setted to 'product', so facebook knows that your page is a product
og:image -> also make the Send button always render the proper product image
og:description -> get the short description of your product
og:url -> your current product page url
[/b]


I have this issue below and tried your solution.. no luck.. www.turbosupplycenter.com
.. I uninstalled everything except this little line that says "PRINT" in firebug it says it is #primary_block" that it is coming from but I don't see a primary block module this is a new site using version: 1.4.1.0

1.My Like button isn´t being loaded right at the bottom of the image, what I have to do?
Make sure to uninstall any module that loads at the same place that the Like a Lot module, any module that is rendered after the Products image. After that, install Like a Lot module first and then reinstall the other modules, that will make Prestashop renders the LIke a Lot module right after the images.


LOVE THE CAROSEL MODULE. USE IT OFTEN! Thanks for your giving nature and providing these great modules.

Share this post


Link to post
Share on other sites

J'ai un problème avec ce module lorsque je click sur j'aime un produit, l'image n'est pas la bonne? je suis sur la 1.4.10.Merci

Share this post


Link to post
Share on other sites

hi :)

i've installed this module yesterday but got some trouble with it :s
the module is availiable under my products

but when i clik on it, it seems it works because i can see one sec "I like that" but after my button disapear and got a confirm link instead :s and when i click on it, tells me that an error has occured :/

i use prestashop 1.4.2.5

oh and as you can see, the sen button is not visible (and i've configured it to be shown in my BO)

(and when i go to your site here the download for the module is not availiable :s)

(pictures are in the good order ;) )

49292_lCsyBHg2qmp6Z0sFkGbW_t

49293_tEZwDy7pGDpxY8pcdu8T_t

49294_KpktOdZKIIFv9onQjqAC_t

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys, just let you know im taking a look at this bug now and will release a fix asap

Share this post


Link to post
Share on other sites

Hey guys, just found out about what could possible be happening.

Those problems are all Facebook related, one easy way to fix it is running Facebook Link app on the link where the bug happens. For instance just go to http://developers.facebook.com/tools/lint and in the ADDRESS URL type the address where the Like Button is supossed to appear.

This tool analyses the page and give you some info about how well integrated it is with facebook and the open graph tags, but this tool also clear all facebook cache on the page, meaning that Facebook will be refreshed and any bugs wiped out.

I also made some code tweaks and added two new Open Graph tags in the version 1.2 I just released, it can be found on the first post of the topic.

Any other issues just let me know

Thanks for the feedbacks!

Share this post


Link to post
Share on other sites

i obtain this error:
Excepción No lograste dar una lista válida de administradores. Debes proveer los administradores usando una meta etiqueta fb:app_id o una meta etiqueta fb:admins para especificar una lista con comas de usuarios de Facebook.

Share this post


Link to post
Share on other sites
i obtain this error:
Excepción No lograste dar una lista válida de administradores. Debes proveer los administradores usando una meta etiqueta fb:app_id o una meta etiqueta fb:admins para especificar una lista con comas de usuarios de Facebook.


Hey, when this error occur, is in the new version I just released? Also, you are using the default APP ID that comes with the module or you created an APP for yourself in Facebook?

Share this post


Link to post
Share on other sites

im using the default app. my prestashop version is 1.4.3
Facebook Like a Lot v1.1

Share this post


Link to post
Share on other sites

Very nice module!

But I have a layout problem as you can see in the picture.
I tried to adjust the tpl files, but no good.
Would like to have it in-line with the other 'buttons'.
And the I like a lot buttons are a bit to big!
Who can help me with this?

49356_bC3gIcIlJQ6jbq1K2NBP_t

Share this post


Link to post
Share on other sites

hi :)

thanks for your new release. it fix my display bug for the send button. now i can see it et i can send some product to my friend on facebook.

But my like buton still doesn't work :s
when i click on it, i can see (only an half second) that i like that but just a second after it disappear and i've to click again but it never appear on my Facebook account or on the website.

When i use your link to debug (http://developers.facebook.com/tools/lint) i got an error on it (see on the picture ;))
Despite i switch the default APP_Id by mine ;) still have an error :s

and if you want to see the compete website go -> http://www.ivroom.fr
(it's our test environnement, same parameters than our production environnement but because our production website still not finished to develop i give you our test environnement)
Both environnement have the same configuration :
- Prestashop 1.4.2.5
- url_rewriting activated
(in our test environnement we don't modify anithing after installing ;))

do you have an idea to fix it ?

Kind regards,

Mokette

49360_s4xN0PaMQLjYHeKf9Vur_t

49388_dT2dna5qTeAEOKzCezjG_t

Share this post


Link to post
Share on other sites

I think I have a similar problem with facebook I Like button. When I click it, the I Like button changes to button CONFIRM. And it shows nothing on my fb page.

Share this post


Link to post
Share on other sites

hi,

i've got the same problem as you mcofko and the release 1.2 fix this bug of the confirm link but still have nothing on my FB page and got an error in the debug page :s

hope bemcapaz gonna come soon to answer us if he can =)

Mokette,

Share this post


Link to post
Share on other sites

Hi again :)

Problem solved for me :)
Really thanks you for your release 1.2 Bemcapaz it work well :)

To solve my problem i just replace the appId by mine and if it doesn't work the last day it was because of my server's cache ;) (and now have no error in the debug webpage of fb ^^)
I've re-installed it today and it works perfectly :D

mcofko if you come here, got a solution for you problem ;)

really thank you

Kind regards,

Mokette

Share this post


Link to post
Share on other sites
Very nice module!

But I have a layout problem as you can see in the picture.
I tried to adjust the tpl files, but no good.
Would like to have it in-line with the other 'buttons'.
And the I like a lot buttons are a bit to big!
Who can help me with this?


Does anyone can help me fix this?

Share this post


Link to post
Share on other sites

hi :)

have you try to modify the likealot.tpl file ?

in this file you'll find the "width" and "height" parameters ;)
you can modify this parameters to change the way how the buton look :)

if it's doesn't work gonna keep looking for another way to change this ;)

Mokette,

Share this post


Link to post
Share on other sites
hi :)

have you try to modify the likealot.tpl file ?

in this file you'll find the "width" and "height" parameters ;)
you can modify this parameters to change the way how the buton look :)

if it's doesn't work gonna keep looking for another way to change this ;)

Mokette,


thanks for your reply.

tried that already and no luck.. :s

Share this post


Link to post
Share on other sites

Hey Mokette, could you say me where can I find my facebook appID. Did I get it out of my URL link, when i'm on my fb profile page?

Share this post


Link to post
Share on other sites

hi :)

to get your app_ID go here -> https://developers.facebook.com/apps

create a new app.
When your app is created go to the web link in the left menu to edit your domain (www.yoursite.com), your website url (http://www.yoursite.com)

When it's done your app_ID is visible on the top (App ID/API Key) but before using this you have to click on the link in the access token section to grant's your app to use facebook ;)

And then you replace the app_ID by yours and it's ok ;)


@randysantino : gonna keep looking for another solution for you


Mokette

(i'm going in week-end in 30mins so my next answer will probably come monday (maybe soon if i got an internet acces this week-end ;) )

Share this post


Link to post
Share on other sites
hi :)

have you try to modify the likealot.tpl file ?

in this file you'll find the "width" and "height" parameters ;)
you can modify this parameters to change the way how the buton look :)

if it's doesn't work gonna keep looking for another way to change this ;)

Mokette,


thanks for your reply.

tried that already and no luck.. :s


i've looking in all the files in the likealot folder and the likealot.tpl file is the only file where the width and height of the module are initialized.

and it doesn't work when you edit this file ? and don't forget to clear your server and browser cache before refresh your page ;)

Mokette

Share this post


Link to post
Share on other sites

Hi,

i have installed likealotmodulev1_1.zip and not modify parameters in module.

 

when i click on ' i like ' this work in facebook, as message, but return Error in color RED.

 

Error:

The page failed to provide a valid list of administrators. It needs to specify the administrators using either a "fb:app_id" meta tag, or using a "fb:admins" meta tag to specify a comma-delimited list of Facebook users.

 

What do i do ?

 

 

sorry my english.

 

Thanks

Share this post


Link to post
Share on other sites

hi all,

 

i wait response....

 

it is normal that I always read the list of modules version 1.1?

 

I installed version 1.2

 

tnx

bye

Share this post


Link to post
Share on other sites

Can your module give a one-time discount (promo code) to a customer when he likes your shop on Facebook?

Share this post


Link to post
Share on other sites

great module!

it works on my site :)

http://xiawadressroom.com

 

Just wondering how to specify a particular thumbnail while like at the landing url? It don't have any product picture and just display some random photos instead of the logo.

Share this post


Link to post
Share on other sites

Hi,

i have installed likealotmodulev1_1.zip and not modify parameters in module.

 

when i click on ' i like ' this work in facebook, as message, but return Error in color RED.

Similar for me, BUT also: after i test liked a product the like link etc disapeared.

 

My error message: "Den specificerade applikations-IDn inom metataggen "fb:app_id" är ej tillåten inom denna domän. Du behöver skapa kontaktbasdomänen för att din app ska kunna fungera som ett http://mohsart.se/sv/go/848-timer-digital-dgt2010.html-prefix."

Rough translation: "The specified application ID within the meta tag "fb:app_id" is not permitted within this domain. You need to create the contact base domain so that your app will work as a http://mohsart.se/sv/go/848-timer-digital-dgt2010.html-prefix."

(ver 1.2, 1.1 just gave a similar error and didn't end up at my FB profile)

 

Edit: After a hard refresh the link etc reapeared, but didn't work (nothing posted on FB)

 

/Mats

Share this post


Link to post
Share on other sites

Hi,

i have installed likealotmodulev1_1.zip and not modify parameters in module.

 

when i click on ' i like ' this work in facebook, as message, but return Error in color RED.

Similar for me, BUT also: after i test liked a product the like link etc disapeared.

 

My error message: "Den specificerade applikations-IDn inom metataggen "fb:app_id" är ej tillåten inom denna domän. Du behöver skapa kontaktbasdomänen för att din app ska kunna fungera som ett http://mohsart.se/sv/go/848-timer-digital-dgt2010.html-prefix."

Rough translation: "The specified application ID within the meta tag "fb:app_id" is not permitted within this domain. You need to create the contact base domain so that your app will work as a http://mohsart.se/sv/go/848-timer-digital-dgt2010.html-prefix."

(ver 1.2, 1.1 just gave a similar error and didn't end up at my FB profile)

 

Edit: After a hard refresh the link etc reapeared, but didn't work (nothing posted on FB)

 

/Mats

 

Get your facebook app id here: https://developers.facebook.com/setup/ - then enter the id in the module configure. Then everything will work perfectly.

Share this post


Link to post
Share on other sites

Thanks, now only the send feature remasins to be fixed.

 

/Mats

Share this post


Link to post
Share on other sites

Seems it doesn'f fail on all products with short descriptions.

Makes it almost more irritating...

 

/Mats

Share this post


Link to post
Share on other sites

Hello,

 

I do not understand what to do here:

 

Transform Open your page in a Graph Object by Adding the Following OG properties to your products page

og: title: get the name of the title of the product

og: type: setted to 'product', so That knows your facebook page is a product

og: image: also make the Send button always render the proper product image

og: description: get the short description of your product

og: url: your current product page url

og: site_name: Automatically get your new name shop

fb: app_id: Automatically get the app id of your new site

 

 

I installed the module and gives me error:

 

The application ID specified in the tag "fb: app_id" is not allowed for this domain. You must configure the Domain Database Connect to your application as a prefix http://www.xxxxxxx.com/product.php?id_product=52

 

thanks

Share this post


Link to post
Share on other sites

Hello,

 

I do not understand what to do here:

 

Transform Open your page in a Graph Object by Adding the Following OG properties to your products page

og: title: get the name of the title of the product

og: type: setted to 'product', so That knows your facebook page is a product

og: image: also make the Send button always render the proper product image

og: description: get the short description of your product

og: url: your current product page url

og: site_name: Automatically get your new name shop

fb: app_id: Automatically get the app id of your new site

 

 

I installed the module and gives me error:

 

The application ID specified in the tag "fb: app_id" is not allowed for this domain. You must configure the Domain Database Connect to your application as a prefix http://www.xxxxxxx.com/product.php?id_product=52

 

thanks

 

 

nobody can answer me?

 

you can see the error in www.ayudastecnicasorbion.com

 

thank you very much

Share this post


Link to post
Share on other sites

It seems that everyone is able to get this done successfully. But why am i not seeing anything although it shows install successfully.

By default i can see it hooked at Top of pages, Footer and Header of Pages. But neither of these position shows me the facebook button. I would like to display it under the product image.

 

I have tried hook at all others position but it said "This module can't be transplanted to this hook."

 

Can you advice? i used the likealotmodule1_2.zip

Share this post


Link to post
Share on other sites

Hi i have no idea which module should i uninstall first then only install this likealot module.

My link here. Can anyone help? When i view the browser page source code, i can see the meta.. are showing there.. but it is not hooked somewhere.. I tried to uninstall some module and install this but i always get "This module can't be transplanted to this hook."

 

Please ignore the current facebook like button under the image. Those are generated through code in my product.tpl page. I am going to remove that once this module is successfully configured. I would like the Likealot module to display at the same place as what the facebook like button is displaying now.

 

Could anyone advice? thanks so much

Share this post


Link to post
Share on other sites

temporarily uninstall send to a friend and the google plus modules if you have them installed, then install this one, then install those back.. wa la :) your done.

Share this post


Link to post
Share on other sites

Thanks for much for the reply. But i do not have any of them installed. You may refer to the link i posted. there is no such module appear. Currently only the thumbnails picture appear under the product image.

Share this post


Link to post
Share on other sites

Hi Guys, sorry by my absence, I have been really busy lately.

 

I will be updating the Prestashop to the latest version (1.4.4.1) and check how the module behave on it, will be uploading the new version really soon here.

Share this post


Link to post
Share on other sites

Thanks for much for the reply. But i do not have any of them installed. You may refer to the link i posted. there is no such module appear. Currently only the thumbnails picture appear under the product image.

 

Hi bedum, just saw your message. I just checked the page you told me to and looks like the module is working just fine, you still have any problems with it?

Share this post


Link to post
Share on other sites

I use this module in my website. I like facebook search but when like a product, the image not the product image, it use random image on the page.

 

How to fix this?

 

Thanks!

Share this post


Link to post
Share on other sites

I use this module in my website. I like facebook search but when like a product, the image not the product image, it use random image on the page.

 

How to fix this?

 

Thanks!

 

Hi Alpha, you are using another Facebook module or its the Like a Lot only? The reason is the like button depends on the OG Tags (Open Graph) to correctly get the product image (og:image in this case), the module is suposed to do that automatically by grabbing the product main image and passing that as the Like image.

 

Giveme a link of a product so i can take a look at it.

Share this post


Link to post
Share on other sites

Thanks for this module, looks great!

 

One additional thing that you may wish to include in the options for the module is a way to toggle through the below:

 

data-layout="box_count", "button_count", "standard"

 

I've manually inserted this line to have in "box_count" - but I'm sure others would find great use in the automation of it.

 

Cheers again for the module, I like!

Share this post


Link to post
Share on other sites

 

Hi bedum, just saw your message. I just checked the page you told me to and looks like the module is working just fine, you still have any problems with it?

 

Hi Bemcapaz, yes i am still having problem with the installation. The one you saw successfully was the module i used from FacebookLike. I have uninstalled that now. Can you tell me how to hook your module in? I have viewed the source and i am able to see your code appear. But it just don show the buttons.

Share this post


Link to post
Share on other sites

 

Hi Alpha, you are using another Facebook module or its the Like a Lot only? The reason is the like button depends on the OG Tags (Open Graph) to correctly get the product image (og:image in this case), the module is suposed to do that automatically by grabbing the product main image and passing that as the Like image.

 

Giveme a link of a product so i can take a look at it.

I use one other Facebook Fan page module. Now I remove it and check some page again then it show correct product image.

I will check more later. Thanks!

Share this post


Link to post
Share on other sites

Thanks for this module, looks great!

 

One additional thing that you may wish to include in the options for the module is a way to toggle through the below:

 

data-layout="box_count", "button_count", "standard"

 

I've manually inserted this line to have in "box_count" - but I'm sure others would find great use in the automation of it.

 

Cheers again for the module, I like!

 

Hi leelee,

 

Since im looking to make the module as customizable as possible through the admin panel you gave me a great idea. Thanks!

I will implement this feature and release an updated version

Share this post


Link to post
Share on other sites