Jump to content
Sign in to follow this  
Troppau

[Solved] přesun produkční verze na localhost

Recommended Posts

Zdravím,
vím, že je tady spousta návodů, ale všechny pracují pouze se setings.inc.php

o co mi jde?

Chystám zdvojení jednoho obchodu, kdy potom ten nový bude mít jiný design, jiné řazení výrobků atd...
Chci to vyzkoušet na localhostu, ale ne a ne to rozchodit.
Co jsem udělal:

1) na localhostu jsem nainstaloval čistou instalaci prestashopu
2) zálohoval jsme DB přes prostředí produkční presty
3) přes PHPAdmin jsem smazal obsah localhost DB a naimportoval zálohu z produkční verze
V tuto chvíli presta ještě běží a to i s novým zbožím (pouze bez obrázků). Nelze se však přihlásit do administrace
4) stáhnul jsem přes FTP celý server produkční verze
5) všechny stažené soubory (kromě adresáře config) jsem nahrál místo původní čisté localhost instalace
V tuto chvíli již presta na localhostu neběží
6) nakopíroval jsem složku config do localhostu (krom setings.inc.php)
stále neběží

co jsem udělal špatně? jak správně nastavit které soubory?

co jsou tyto tři položky v setings.inc.php?

define('_COOKIE_KEY_', 'XvEBo20UMIOUoYdmrnwngdu6e2iMnn3JbvaFOgLohC3EUN1MGkQ7UEPT');
define('_COOKIE_IV_', 'Kp7Tknw6');
define('_PS_CREATION_DATE_', '2011-05-18');



CREATION_DATE předpokládám není důležité
co jsou COOKIE_KEY? jak mají být nastavené?

díky moc...

EDIT:

ještě error log:

[sun Jun 19 11:02:02 2011] [alert] [client 127.0.0.1] C:/wamp/www/Forseti_to_freya/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[sun Jun 19 11:02:02 2011] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico

Share this post


Link to post
Share on other sites

Tak vyřešeno.
problém je pouze v tom, že wampserver nemá povolen rewriting po smazání .htaccess (vymazání) funguje vše OK.

Jen tedy potřebuji zjistit jak na wampserveru povolit rewriting...

Share this post


Link to post
Share on other sites

Ja riešim problém ako presunúť DB z jedného servera (testovacieho) kde som vytvoril nový shop 1.4.2.5 na hlavný server.

Toto som ešte nerobil tak potrebujem radu.

Po presunutí súborov obchodu na server a naimportovaní databázy mi v rýchlej objednávke nezobrazuje polia na adresu.
Kde môže byť chyba, už fakt neviem kam mám pozrieť.

Pripájam PrtScr
Ďík

47845_o8BXXjTTyiHcVoEpOSyD_t

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More