Jump to content
Sign in to follow this  
morrissfr

[Résolu] Installer Prestashop sur une clé USB

Recommended Posts

Bonjour,
j'ai installé Easy PHP (qui est portable) sur une clé USB et ça fonctionne, j'ai dézippé prestashop sur la clé puis lancé l'install. (http://127.0.0.1/prestashop/install/)
Une première fenêtre s'ouvre disant qu'il faut javascript,
puis je passe à la deuxième fenêtre qui vérifie le système, ça fonctionne, tout est OK
puis fenêtre pour la BDD (configuration du système) , il la trouve (je l'ai créée au préalable sur la clé)
puis je clique sur suivant pour passer à "configuration de la boutique", et là plus rien .... le bouton suivant s’éteint 2 à 3 seconde puis se rallume, impossible de passer à la page suivante et ma BDD reste vide.
Que se passe-t-il voilà des heures que j'essaie toutes les solutions possibles....
merci de votre aide car je peux pas travailler....
Laurent

Share this post


Link to post
Share on other sites

Salut
Je l'ai déjà sur DD mais c'est pour pouvoir travailler sur d'autres ordi quand je me déplace et c'est fréquent malgré mon grand âge (70)
Par dépit j'ai installé WAMP sur la clé et j'ai le même problème et au même endroit, je commence à fatiguer! Prestshop étant "autonome" je vois pas pourquoi il fonctionnerait pas sur une clé USB
Si qqun a une solution....un grand merci!
Laurent

Share this post


Link to post
Share on other sites

Oui....mais ça fait quelques années que je programme en amateur et tranquillement!
Bon après avoir essayé tous las a, b c....amp qui ont tous calé au même endroit: vive la France car c'est un logiciel fr qui a fonctionné! à savoir Uwamp.
J'ai quand même un petit pb, j'ai migré mon prog en cours et sa base de donnée mais celle-ci n'est plus à la même place alors quand je veux ouvrir le panneau j'ai ce message: Link to database cannot be established. Quelqu'un peut me dire où je dois changer l'url de la bdd? Je vois pas où ça peut être enregistré.
merci de vos dons pour les vieux!
Laurent

Share this post


Link to post
Share on other sites

Oui, je l'ai exportée : prestashop.sql puis je l'ai importée dans le "data" de UwAmp. Du coup le chemin de la base n'est apparemment plus le même que sur easyphp. de localhost/home/mysql/index.php il devient localhost/mysql/index Enfin, bref, prestashop ne trouve plus sa BDD.
(J'ai bien mis les dossiers de prestashop dans le rep www de UwAmp)

Share this post


Link to post
Share on other sites

Ce fichier doit etre importé. Dans phpmyadmin>onglet import. Tout simplement. Bon courage.

Share this post


Link to post
Share on other sites

c'est bien comme ça que j'ai fait: phpmayadmin de UwAmp => céer base prestashop => importer.
j'ai bien la base avec ses 163 tables... et voilà ça fonctionne pas qaund je lance le programme.... je crois que je vais abandonner!

Share this post


Link to post
Share on other sites

Et tu as vérifié dans ton Back Office les paramètres de la base de données ?
Panneau d'administration > Préférences > Base de données

Share this post


Link to post
Share on other sites

Tu peux aussi vérifier ces infos dans le fichier :
/config/settings.inc.php

Share this post


Link to post
Share on other sites

Voilà! C'est ce que je cherchais dans mon troisième message!
Si je règle rien avec ça... j'arrête cette migration sur Clé!
Par contre une installation nouvelle sur la clé fonctionne à merveille (sauf grande lenteur...)
Merci à tous. Je considère "résolu"
Laurent

Share this post


Link to post
Share on other sites

Tu pourrais dire pourquoi la nouvelle installation sur clef a fonctionné et pas la première ?
le portage m’intéresse aussi ;)

Bravo pour ta maîtrise quand même, c'est pas courant à 70 ans d'être comme un poisson dans l'eau en informatique surtout dans des domaines ardus.

Share this post


Link to post
Share on other sites

D'abord je ne suis pas comme un poisson! Je ne fais que quelques programmes très ciblés et je n'apprends que ce dont j'ai besoin pour eux... mes connaissances sont donc très "dispersées" et pas très homogènes mais ça dérouille le cerveau et ça occupe.
L'installation de Presta sur une clé avec UwAmp se fait toute seule si on peut dire. Presta trouve la base de lui-même et s'installe correctement (il suffit de le mettre dans le répertoire www). Peut importe la lettre attribuée à la clé (D, E F...) si on met la clé sur un autre ordinateur qui lui attribue une autre "lettre" : ça fonctionne.
j'ai pas encore eu le temps de regarder le problème de la migration d'un e-commerce déjà en place ailleurs. Je regarderai ça lundi et te tiendrai au courant.
Bon WE
Laurent

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More