Jump to content

[Solved] Ssl + Customer Logout: Still Https In Url


Recommended Posts

Before submitting this issue in the bug tracker, I would like to know if any of you encountered the same problem.


I'm using PS and most things run pretty smoothly but I've found this annoying issue when I enable SSL:


When customers log out, they are redirected to an URL that still starts with https, e.g. https://webshop.nl/


This is a minor issue in Firefox since it only leads to display of the lock with a warning (bottomright of the page) and subsequent navigation on the website corrects the https issue (it shows http again for non-secured pages)


But in IE8, this is a real problem. When customers log out, they get this nice warning message: "Do want to view only the webpage content that was delivered securely?"

Either selecting "Yes" or "No" leads to this message: "Unable to open the Internet site https://webshop.nl/" & "Operation aborted". And finally IE8 shows a white page with: "Internet Explorer cannot display the webpage"


Actually, the redirect after log out is https://webshop.nl/nl/ and https://webshop.nl/en/ (i.e. with selected lang) and I have enabled both Friendly and Canonical URL.


I'm not sure if this issue was present when I first enabled SSL but it is now and I can't get rid of it.


Edit: just to make sure, this is only the case when customers logout from a secured page (that already starts with https)

Link to comment
Share on other sites

  • 4 weeks later...

Ah, I was just about to submit this bug. Great that you have done that already.
I added a comment to your bug report that I have the same problem, so I hope the developers will look into this quickly.

Link to comment
Share on other sites

  • 1 month later...

This bug has now been fixed by the Prestashop developers. Look for SVN revision 7967.


Alternatively, you can carry out the following code change in classes/Tools.php:


Replace line 62 (for PS 1.4.3):

$url = $link->getPageLink($explode[0], true);



$useSSL = !empty($url);
$url = $link->getPageLink($explode[0], $useSSL);


I have tested the fix and it works for me!

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...