Jump to content

HTTP 500 hiba (A webhely nem tudja megjeleníteni a lapot)


Sanci
 Share

Recommended Posts

Nem régen volt egy Bad Gateway 502 hibám, amit elvileg kijavított a tárhely szolgáltatóm.
Törölnöm kellett az adatbázisból az e-mail címeket, hogy újra betudjanak regelni a régi ügyfeleink.
Mindezt megoldottam, működött is minden rendesen. (kipróbáltam új regeléssel is)
Küldtem egy e-mailt az összes ügyfelemnek, hogy regeljenek újra.
Aztán a cms-ben kijavítottam a nyitva tartásunkat.
A vége : http://www.elektro-sat.hu/webshop/
A webhely nem tudja megjeleníteni a lapot HTTP 500

A legvalószínűbb okok:
•A webhely karbantartás alatt áll.
•A webhely programozási hibát tartalmaz.
Lehetséges lépések:
A lap frissítése.
Visszatérés az előző oldalra.
További információ

S.O.S. Segítsetek ! Már kész vagyok ettől a sok hibától.

Share this post


Link to post
Share on other sites

Igen, megy a webshop nélkül, de minek - a lényeg nem elérhető...

Hagyd ott a szolgáltatót, ha ennyi gondot okoz.
Én kb két hét után odébbálltam, mert csak az igérgetéseket és kifogásokat kaptam a pénzemért.
Jó, buktam a bérlés díját, de most utólag belegondolva, nagyon is megérte a váltást.
Nincs gondom a prestashop futásával.

Share this post


Link to post
Share on other sites

Én a váltás előtt kértem egy hetes próbát két szolgáltatótól. Ezt minden további nélkül felajánlották.
Az olcsóbb és nagyobb tárhelyet biztosítót választva döntöttem: www.webdigital.hu

Share this post


Link to post
Share on other sites

Mind két oldal egy tárhelyen van.
5.000 MB tárhely, korlátlan FTP elérés, korlátlan e-mail postafiók, 2.000 MB e-mail tárterület, korlátlan e-mail alias, webmail felület, e-mail átirányítás, spam és vírus szűrő, POP3/IMAP elérés, CRON futtatás, PHP használat, PERL használat, webstatisztika, jelszóval védett könyvtárak, teljes körű DNS szolgáltatás, adatbázis (SQL), korlátlan adatbázis méret, teljes körű vezérlőpult, korlátlan adatforgalom, ingyen websablon, egyéni hibaoldalak, korlátlan aldomain, biztonsági adatmentés.
Szerverek:
Alkalmazás szerver: 4 db HP ML150
Fájl szerver: 2 db HP ML150
Dns szerver: 1 db HP ML110
Backup szerver: 2 db HP ML150
Központi adattároló: 1 db IBM ×226

localhost:
* Szerver verzió: 5.0.51a-24+lenny5
* Protokoll verzió: 10
* Szerver: Localhost via UNIX socket

# MySQL karakterkészlet: UTF-8 Unicode (utf8)
# MySQL kapcsolat egyeztetés: utf8_unicode_ci

phpMyAdmin - 2.11.8.1deb5+lenny8
* MySQL kliens verzió: 5.0.51a
* Használt PHP kiterjesztések: mysql

Nyugtassatok meg, hogy nem az én hibám, hanem a szolgáltatóé.

Share this post


Link to post
Share on other sites

Fel van telepítve a tárhelyünkre egy másik adatbázisba egy 1.5.22 Joomla is. ( Még a Bad Gateway hiba után raktam fel)
Ha nem tudom helyrerakni a prestát (Version 1.2.4.0 - 2.742s), akkor neki látok a Joomlának.
Bár szerintem sokkal bonyolultabb. Több modul, töbféle menű, minden máshol van benne, igaz sokkal szebb is.

Azért inkább maradnék a Prestánál, ha megmenthető. Ezt legalább nagyából ismerem már.

A legtöbb fórumban (joomla, drupal, e107) a HTTP 500 hibára szerver problémákat írtak. (500 - belső szerverhiba - internal server error)
Ha meg én szúrtam el, akkor meg egy cms átszerkesztésével nem hiszem, hogy így el lehet szúrni az egészet.

Share this post


Link to post
Share on other sites

Aki keres az talál. Megtaláltam a hibát !!!
Mielőtt nekiálltam a cms szerkesztéshez bekapcsoltam a két RSS modult. Most meg lekapcsoltam őket és rendesen műkszik minden.
Tök amatőr vagyok, de ez meg is látszik.

Ha egy régi mentésemből lecserélem a régebben működő RSS modulokat akkor az működhet ?

Share this post


Link to post
Share on other sites

  • 7 months later...

Csak okulásképpen írom, hátha valakinek lesz még ilyen gondja:

Én is így jártam az RSS-el. Azzal a különbséggel, hogy nekem a shop kezdete óta ment két RSS modul.

Egy a termék RSS feed, és egy külső oldalra mutató RSS csatorna.

Nem volt soha baj, ma délutánig. Nem csináltam semmit a shoppal, és mégis elérhetetlenné vált. Chrome alatt semmi nem volt látható, explorer alatt néha kiírta az 500 hibát, de leginkább azt sem. Az admin oldal tökéletesen ment.

Órák óta keresgéltem mi lehet a baj, és már éppen arra gondoltam holnap újrahúzom a shopot (amúgy is elkél egy frissítés már), amikor olvastam itt erről.

Kikapcsoltam a külső RSS modult és voilá, működik.

Még nem néztem utána, de a szolgáltatóm alighanem frissített valamit. Megkérdezem holnap, hogy mit, hátha elárulják.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More