Jump to content
Sign in to follow this  
NiWi

Flytta shoppen till förstasidan?

Recommended Posts

Hej!
Jag har en liten amatörfråga.
Jag är nu nästan klar med min webshop och jag skall nu flytta den till förstasidan.
Alltså från www.namn.se/test till www.namn.se. Hur bär jag mig åt?

Tack på förhand, NiWi! :)

Share this post


Link to post
Share on other sites

1. Flytta filerna från test till webroten

2. Ta bort test i definitionen av PS_BASE_URI i filen config/settings_inc.php så att det bara står

define('__PS_BASE_URI__', '/');

Share this post


Link to post
Share on other sites

Jag har samma problem, har bytt ut till

define('PS_BASE_URI', '/');



Men fortfanarnde så funkar det inte, inget theme laddas.
vad kan vara problemet, har bytt från

www.en-adress.se/butik
till
www.en-annan-adress.se/

kopierat allt från ftp, och sparat ner databasen och inporterat den.
Alla texter och så visas men iget theme som sagt.

Share this post


Link to post
Share on other sites

Med kopierat antar jag du menar att du har laddat ner från mappen test och sedan laddat upp på ftp:n igen i rooten då ftp-protokollet inte har stöd för kopiering av filer?
Om så är fallet måste du ställa in rättigheterna igen på mapparna. Se bilden nedan för info vilka mappar du
behöver sätta exempelvis chmod 777 på:

http://www.siteground.com/knox/tutorials/uploaded_images/images/prestashop/inst_img2.jpg

Share this post


Link to post
Share on other sites

hittar ingen post som heter PS_BASE_URI , Skummt har sökt igenom hela databasen efter just det.

Share this post


Link to post
Share on other sites
<?php
define('_DB_SERVER_', 'localhost');
define('_DB_TYPE_', 'MySQL');
define('_DB_NAME_', 'xxxxxxxx');
define('_DB_USER_', 'xxxxxxxx');
define('_DB_PASSWD_', 'xxxxxxx');
define('_DB_PREFIX_', 'shirtville_');
define(’PS_BASE_URI‘, ‘/’);
define('_THEME_NAME_', 'prestashop');
define('_COOKIE_KEY_', 'fC200PjVPx8mBfoPdkOcnAmAr2wJo0Y1G0JTgZeGtW8zVigYxny89f79');
define('_COOKIE_IV_', 'NQgzcLgw');
define('_PS_CREATION_DATE_', '2009-09-12');
define('_PS_VERSION_', '1.2.3.0');
?>



såhär ser det ut nu, men fungerar inte:(
Måste vara nått enkelt litet fel

Share this post


Link to post
Share on other sites
define('__PS_BASE_URI__', '/')



ska det vara, verkar som understrecken tas bort om man inte använder code-taggarna här

Har uppdaterat mina tidigare inlägg i tråden.

Share this post


Link to post
Share on other sites
define('__PS_BASE_URI__', '/')



ska det vara, verkar som understrecken tas bort om man inte använder code-taggarna här

Har uppdaterat mina tidigare inlägg i tråden.



Tack så jättemycket! Nu funkade det:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More