Jump to content

[SOLVED] Transit (delay) time not showing in the checkout in PS 8.1.5


Recommended Posts

Posted (edited)

Hi, 

Recently I have noticed that the shipping methods in the checkout are shown without transit time (delay) that I described for each shipping method in the Shipping -> Carriers. I do not know when these information disappeared and what cause that. Does anyone know how to bring them back?

 

screenshot.jpg.4dbb90eefd753f4e2d0973434e1fdc9d.jpg

 

image.thumb.png.33bedda3ef52dfaa7ed9bd52157be467.png

Edited by banan_44 (see edit history)
Link to comment
Share on other sites

Posted (edited)
On 6/10/2024 at 10:18 AM, Prestashop Addict said:

Verify in your html source (inspector browser) if htaml part is present but maybe not visible. In this case it's a css issue, otherwise theme template issue.

Thank you for your reply. I have just checked that. In the source there is no carrier delay:

nocarrier.jpg.95d1d2c49becfbfd4076717c34bea745.jpg

 

But when I checked checkout\_partials\steps\shipping.tpl this field should insert information from {$carrier.delay}. Now I am a little bit confused why my Presta doe snot insert anything into {$carrier.delay}. Any advice where I should check that? Is it something that I'll find in other tpl file or should I look elsewhere? BTW. I am also using Knowband Supercheckout and it also does not show me carrier delay while I know that there was such information. To write this topic I have deactivated Supercheckout to verify if this delay problem was a problem with the module or with Presta.

 

image.png.df98f09c24a2b5ade8ea49d9357b9885.png

Edited by banan_44 (see edit history)
Link to comment
Share on other sites

On 6/10/2024 at 10:18 AM, Prestashop Addict said:

Verify in your html source (inspector browser) if htaml part is present but maybe not visible. In this case it's a css issue, otherwise theme template issue.

Thank you for your reply. I have just checked that. In the source there is no carrier delay:

nocarrier.jpg.95d1d2c49becfbfd4076717c34bea745.jpg

 

But when I checked checkout\_partials\steps\shipping.tpl this field should insert information from {$carrier.delay}. Now I am a little bit confused why my Presta doe snot insert anything into {$carrier.delay}. Any advice where I should check that? Is it something that I'll find in other tpl file or should I look elsewhere?

 

image.png.df98f09c24a2b5ade8ea49d9357b9885.png

 

EDIT

I have just instaled  afresh Presta and installed my theme. The carrier delay is shown on the test Presta while on my working shop ther eis not information. I think this is not a problem with the theme.

Link to comment
Share on other sites

5 hours ago, Prestashop Addict said:

Does it works with classic theme? If so the issue is from your theme (or module overrride theme) effectively.

On the classic theme there was the same problem. I started to dig a little more and I found out that the problem was caused by "Restrict Shipping" module. As soon as I removed it from my shop the carrier delay is shown again. I have informed developer about his situation because I need that module.

Link to comment
Share on other sites

  • banan_44 changed the title to [SOLVED] Transit (delay) time not showing in the checkout in PS 8.1.5

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...