Jump to content

.htaccess weiterleitungen Problem


Recommended Posts

Servus,

 

Folgendes Problem habe ich, in der Search Concole von Google wird mir bei der Seitenindexierung zur Zeit über 600 Fehler angezeigt, der Grund hierfür ist folgender:

Google versucht auf diese URL zu zugreifen:

https://www.altezeitschriften.de/auto-motor-sport/12485-auto-motor-sport-heft-12-3-juni-1961-fahrer-graf-trips.html

doch diese ist nicht korrekt, richtig wäre diese URL:

https://www.altezeitschriften.de/auto-motor-und-sport/12485-auto-motor-sport-heft-12-3-juni-1961-fahrer-graf-trips.html

Der Fehler liegt bei einem Wort, das und: ...de/auto-motor-und-sport/....

Irgendwie crawelt der immer mehr, vor 2 Stunden waren es noch 593 Seiten.

Es betrifft auch nur die Kategorie Auto Motor und Sport.

Ist es möglich dass alle URLs automatisch von der fehlerhaften Kategorie /auto-motor-sport/ auf die richtige Kategorie /auto-motor-und-sport/ weitergeleitet wird?

Brauch wirklich dringend eure Hilfe. Danke.

Link to comment
Share on other sites

RewriteRule ^altes-verzeichnis/(.*)$ /neues-verzeichnis/$1 [R=301,L]

OT: Das Anbieten von unversichertem Versand wird gern abgemahnt.
       Im Footer bewirbst du europaweiten kostenlosen Versand, was offenbar nicht mehr aktuell ist.

  • Like 1
Link to comment
Share on other sites

vor 2 Minuten schrieb rictools:

Was willst du mit diesem (völlig überflüssigen und bei Prestashop-Seiten tatsächlich wirkungslosen) Eintrag erreichen?

Wie bitte überflüssig und wirkungslos? Ich frage doch ganz normal ob mir jemand helfen kann, was denkst du was ich sonst mache?

Schau selbst was dann kommt: https://www.altezeitschriften.de/hoerzu/5918-h�rzu-31-5-bis-11-august-1995-johnny-depp.html

 

Ich mache das nicht aus Spaß oder weil mir abends um 20:21 Uhr langweilig ist.

Link to comment
Share on other sites

Posted (edited)

AddDefaultCharset hat meines Wissens nichts mit den Umlauten in der URL zu tun. Ich kenne mich da nicht so aus, aber ich denke, dass du Umlaute in den htaccess-Weiterleitungen codieren musst (z. B. ö -> %C3%B6).

Bei meinem Shop wird für die URL übrigens ein ö in ein o umgewandelt, frag mich jetzt nicht wo das geschieht und ob man das ändern kann. Edit: Ich sehe gerade, ob in der URL Umlaute genutzt werden kann man im BackOffice einstellen.

Noch ein Edit: Ich habe in meinem Shop jetzt die Umlaute für die Friendly URLs eingeschaltet und einen Artikel bearbeitet, bei mir wird die URL korrekt angezeigt.

Edited by rictools (see edit history)
Link to comment
Share on other sites

Posted (edited)
Am 19.5.2024 um 4:36 PM schrieb rictools:

RewriteRule ^altes-verzeichnis/(.*)$ /neues-verzeichnis/$1 [R=301,L]

OT: Das Anbieten von unversichertem Versand wird gern abgemahnt.
       Im Footer bewirbst du europaweiten kostenlosen Versand, was offenbar nicht mehr aktuell ist.

Friendly URLs sind bei mir aktiviert.

Noch ein mal ganz kurz, also ich habe schon einiges bgeasrbeiten können was auch super gut funktioniert, allerdings gibt es da noch rund 700 URL die so aussehen:

/hoerzu/4381-h�rzu-35-3-bis-9-september-1988-mich-laust-der-affe.html
/stern-magazin/4109-stern-heft-nr11-8-m�rz-1990-kohl-gef�hrdet-die-einheit.html
/stern-magazin/4565-stern-heft-nr45-28-oktober-1976-amerika-w�hlt.html

und so weiter.

Ich habe gesehen dass dieses URLs in meiner Sitemap.txt schon falsch dargestellt wurden, der Fehler war dass ich beim Speichervorgang immer nur "speichern unter UTF-8" gemacht habe anstatt "UTF-8 mit BOM" letzteres war richtig. Die neue,, richtige Sitemap habe ich natürlich eingereicht.

Dennoch sind die falschen URLs jetzt bei Tante Google und ich kann keine neu Indexirung beantragen, da ich den Fehler ja nicht behoben habe.

Also wie kann man das ohne die konkreten URLs in der htaccess anzugeben am schnellsten umleiten?

Gefunde habe ich unter anderem Codes wie diese:

RewriteEngine On

# � wird zu ü
RewriteRule ^path/to/page-(.*)�(.*)$ /path/to/page-$1ü$2 [R=301,L]

# � wird zu ö
RewriteRule ^path/to/page-(.*)�(.*)$ /path/to/page-$1ö$2 [R=301,L]

# � wird zu ä
RewriteRule ^path/to/page-(.*)�(.*)$ /path/to/page-$1ä$2 [R=301,L]

hat nicht funktioniert

AddDefaultCharset utf-8
Options +AcceptPathInfo
RewriteEngine On
RewriteRule ^([^\.]+)$ index.php?pagename=$1 [NC,L]

hat auch nicht funktioniert, kommt dann 500 Server.......

 

Was für eine möglichkeit gibt es noch? Wäre echt für jede Hilfe dankbar.

Edited by altezeit
falsch geklickt (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...