Jump to content
Sign in to follow this  
vestax

V 1.4.1.0 Url Rewriting ne marche pas

Recommended Posts

Bonjour,

Après passage à la version 1.4.1.0 l'url rewriting de marche plus.

De plus il n'y a plus non plus de quoi l'activer dans les préférences.

Si quelqu'un à une idée je suis preneur.

Merci d'avance.

Share this post


Link to post
Share on other sites

Merci beaucoup pour ta réponse, déja un problème de régler.

Ceci dit depuis cette mise a jour le SSL ne fonctionne plus pourtant il est activé

Share this post


Link to post
Share on other sites

Bonsoir,

En faite je viens de m’apercevoir que quand jactiverle url rewriting tous les liens de mes catégories son comme ceci

Exemple : www.monsite.fr/fr/jardins

De ce fait le lien n'est pas bon avez vous une idée svp ?

Share this post


Link to post
Share on other sites

Bonjour,
C'est le fonctionnement normal de l'url rewriting en mode multilingue, et si cela ne fonctionne pas c'est que le cache du bloc catégorie ne s'est pas vidé correctement. Essayez de revalider l'option "friendly url" dans la page SEO & URLs, et de régénérer le fichier .htaccess.

Si votre site utilise une seule langue et que vous ne voulez pas du préfixe de langue dans vos urls, allez sur la page Outils->langues et désactivez toutes les langues sauf le français. Attention, vous pouvez aussi supprimer des langues, mais ne supprimez jamais l'anglais qui est nécessaire au fonctionnement du système. Recommencez ensuite la procédure d'activation de l'url rewriting.

Share this post


Link to post
Share on other sites

Bonjour, j'ai bien créer le fichier .htaccess (avec un bloc note, encodage utf-8) puis j'ai generé le fichier dans le back office et la un message d'erreur apparait sur mon site, je ne peux plus y aller. (en supprimant le .htacces je peux denouveau y retourner). Voici le message d'erreur:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@cashmedia.be and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Encore merci du temps que vous consacrez au novice et à tout les problèmes.

Share this post


Link to post
Share on other sites

Le problème est que quand je met le fichier .htaccess (enregistré avec un bloc note en utf-8) su mon serveur, plus rien ne fonctionne. Mais ce qui est bizarre c'est que lefichier est vide meme sur le serveur.

Merci pour votre réponse rapide. Je n'ai pas été sur la forge étant donné que le fichier est vide.
Le problème vient peut-etre d' un autre problème du à la migration: 1) fatal error sur la dernière étape de commande. 2) touts mes produits sont affichés mais quand on clique dessus, la page est vide.
Que dois-je faire, encore merci.

Share this post


Link to post
Share on other sites

.htaccess résolut : j'ai supprimer le fichier .htaccess de mon serveur et j'ai seulement cliqué sur générer le fichier .htacces (Panneau d'administration- Outils-Générateurs). Mes 2 problèmes énoncé ci dessus ne sont toujours pas résolut.

Share this post


Link to post
Share on other sites

Mon problème peut-il etre du au fait que j'avais modifié la taille sur mon ancienne version de la zone entre les 2 blocs de gauche et droite?

Share this post


Link to post
Share on other sites

Pour avoir plus d'information sur les erreurs, dans le fichier config/config.inc.php remplacer les lignes 29 et 30 par

@ini_set('display_errors', 'on');
define('_PS_DEBUG_SQL_', true);



La modification du thème peut poser des problèmes, il serait utilie de vérifier avec le thème par défaut fourni avec la 1.4.1.

Share this post


Link to post
Share on other sites

Ok, mais je n'avais pas de thème sur mon ancienne boutique, juste le thème fournit avec Prestashop. Je compte acheter un thème et des programmes pour améliorer le site une fois qu'il n'y auras plus de bug.

Que puis-je faire pour remédier à ces problèmes? ( fiche produit qui ne s'affiche pas ainsi que les modules de droite + quand on clique sur tout les nv produits et sur toutes les meilleures ventes, rien ne s'affiche + problème au niveau de la commande: fatal error sur la dernière étape de commande monsite/modules/bankwire/validation.php)
Excusez moi pour toutes ces questions mais plus rien ne va depuis la mise à jour alors que j'ai respecté toute les instructions à la lettre près.

Encore merci du temps que vous consacrez.

Share this post


Link to post
Share on other sites

Voila les messages d' erreur que j'ai obtenu:

Il y en a environ une 50 aines (pour tout les fichiers après modules)

Warning: file_put_contents(/var/www/clients/client2/web12/web/modules/dejala/config.xml) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/clients/client2/web12/web/classes/Module.php on line 988

Share this post


Link to post
Share on other sites

Voici un message d'erreur que prestashop affiche quand on clic sur un produit. Que dois-je faire?

Fatal error: Smarty error: [in /var/www/clients/client2/web12/web/themes/prestashop/product.tpl line 495]: syntax error: unrecognized tag: $link->getProductDeletePictureLink($product,{$field.id_customization_field (Smarty_Compiler.class.php, line 446) in /var/www/clients/client2/web12/web/tools/smarty_v2/Smarty.class.php on line 1095

Share this post


Link to post
Share on other sites

Allez dans l'onglet Préférences, en bas de page changez la version de smarty utilisée pour utiliser la version 3. Est-ce que vous avez installé des modules en dehors des modules de base de PrestaShop ?

Share this post


Link to post
Share on other sites

Merci de m'avoir répondu.Non, j'avais juste un module de parrainage avancé que j'ai désinstallé.
Vous m'avez résolut 1 problème (affichage des fiches produits), merci beaucoup.
Il me reste cependant un problème grave et 1 autre mineur:

1) fatal error lors de la dernière étape du processus de commande (mon site/modules/bankwire/validation.php).
Voila les messages d’ erreur que j’ai obtenu:

Il y en a environ une 50 aines (pour tout les fichiers après modules)

Warning: file_put_contents(/var/www/clients/client2/web12/web/modules/dejala/config.xml) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/clients/client2/web12/web/classes/Module.php on line 988


2) les page toutes les nouvelles ventes et tout les nouveaux produits ne s'affiche plus (redirigé vers la racine du site).

Share this post


Link to post
Share on other sites

Il semble que c'est un problème de droits, le répertoire modules doit avoir des permissions en écriture ainsi que ses sous-dossiers. Voici l'extrait concerné dans la doc d'installation :

While you have your FTP connected to your Web hosting server, make sure the following PrestaShop folders have ‘write’ permissions (also known as “CHMOD 777” – explanation of file permissions here) but do not apply these permissions recursively (to their subfolders): /config, /upload, /download, /tools/smarty/compile. Then make sure the following folders have ‘write’ permissions and apply these permissions recursively (to their subfolders): /img, /mails, /modules, /themes/prestashop/lang, /translations

Share this post


Link to post
Share on other sites

Voila, j'ai changer les droits en écriture (uniquement sur les dossiers) de façon récursive (tout ses dossiers et sous dossiers) sur /img, /mails, /modules, /themes, /translations.

Cela ne fonctionne pas , j4ai toujours le fatal error après chaque commande. (en même temps TOUT le bloc de droite disparait).


Voici 3 exemples de mesages d'erreurs ( sur une 30 aines) : le fichier config.xml apparait à chaque fois, il ne faudrait pas changer quelques chose à ce fichier présent dans la plupart des sosu-répertoires de/modules?

Warning: file_put_contents(/var/www/clients/client2/web12/web/modules/dejala/config.xml) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/clients/client2/web12/web/classes/Module.php on line 988

Warning: file_put_contents(/var/www/clients/client2/web12/web/modules/editorial/config.xml) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/clients/client2/web12/web/classes/Module.php on line 988

Warning: file_put_contents(/var/www/clients/client2/web12/web/modules/envoimoinscher/config.xml) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/clients/client2/web12/web/classes/Module.php on line 988

Merci, apparemment je ne suis pas le seul dans ce cas comme j'ai pu le voir sur le forum uk.

Share this post


Link to post
Share on other sites

Est-ce que vous pouvez poster ici le lien du sujet sur le forum uk ?
Si vous le souhaitez vous pouvez m'envoyer en message privé un accès FTP à votre serveur que j'y jette un coup d'oeil.

Share this post


Link to post
Share on other sites

Voici 2 liens du forum uk qui pourrait aider certains.

http://www.prestashop.com/forums/viewthread/99579/installing_prestashop/solved_errors_in_prestashopclassesmodule_dot_php_on_line_873

http://www.prestashop.com/forums/viewreply/444670/

Résumé en fr:
Je suppose que c'est problème d'autorisation. Vous devez rendre le fichier accessible en écriture. S'il vous plaît assurez-vous que vous avez défini comme suit l'autorisation pour tous les dossiers module et ses sous-dossiers: 755 pour tous les fichiers dans le dossier module et ses sous-dossiers: 644.

Puis-je esseyer avec la version 1.4.1 de prestashop? si cela ne fonctionne pas pas je veut bien vous laisser un acces privé à mon FTp. Merci beaucoup.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More