Jump to content
Sign in to follow this  
mobile.archerie

Impossible d'installer ou de mettre à jour vers PS 1.4.1

Recommended Posts

Bonjour à tous,

Je suis en train d'essayer de mettre à jour ma boutique prestashop qui est en 1.3.5 (n'étant pas un pro sous linux, à la base j’avais acheté le module easy update à 80€ qui ne fonctionne plus depuis le passage en 1.3.5)

Donc j’essaie "à l'ancienne" en suivant scrupuleusement le tuto vidéo ainsi que le guide en pdf.

Après les premières étapes, et transfert des données, quand je vais pour lancer la mise à jour via Adresse_IP_Serveur_développement\install\ je peux choisir la langue, l'installation ou la mise à jour, valider les conditions générales et en dessous ben j'ai plus rien!!! je n'ai pas les boutons annuler ou valider... (voir le fichier joint, si ça sert à quelque chose...)

J'ai téléchargé le fichier d'install la semaine dernière et aujourd'hui, rien ne change.

J'ai essayé sous Firefox 4.01 et IE9 c'est pareil...

Si quelqu'un à une idée, rencontré le problème et/ou résolu je suis très intéressé.

Merci d'avance.

44636_0xZ4MsOwWl8gX2BmRqqH_t

Share this post


Link to post
Share on other sites

Bon après avoir ré-installé le module easy update j'ai pu faire la mise à jour vers la 1.4.1

Par contre je ne peux plus voir les fiches produits dans le Front Office et ne peux plus affecter de catégories dans les fiches produits... Il y a pourtant les catégories qui existent, je dois d’ailleurs y naviguer pour modifier mes produits...

Je comprend pas tout.

Share this post


Link to post
Share on other sites

bonjour,
j'ai le même problème, impossible de voir les boutons suivant et précédent de la première page d'installation,
je suis en version 1.2.5

Share this post


Link to post
Share on other sites

j'ai le même problème, tout semble ok pour installer la version 1.4 mais je ne vois pas les boutons pour passer d'une étape à l'autre . Migration de 1.3.6 à 1.4 - hébergement chez OVH - installation via wamp je continue à chercher sur le forum et vous tient au courant si j'ai du nouveau...

Share this post


Link to post
Share on other sites

Bonjour

Je vous rejoins avec ce problème bouton précédent et suivant qui n’apparaisse pas.
Le fichier setting.inc.php si vous l'enlever les boutons réapparaisses donc je suppose qu'il y a une ligne dans le setting.inc.php qui cause cette disparition.

Par contre il affiche pas une mise à jour mais une installation.

Mise à jour de la 1.4.0.17 vers 1.4.1 une que j'avais réussi et là j'ai essayé sur deux serveurs différents idem.

Par contre il serait intéressant de faire une installation d'une version antérieure et de comparer les fichiers setting.inc.php
Ce que je vais faire.

si je trouve je reviens vous en informer.

Share this post


Link to post
Share on other sites

Re Bonjour

Aller debout il est 5 heures 34 mn :)

Voilà je viens d'installer une version 1.4.0.17, j'ai récupérer le setting.inc.php mis dans la version 1.4.1
Je lance l'install et je vois version détecté 1.4.0.17 et mise à jour qui est coché et les boutons Précédent et Suivants.
Je mets copie du fichier :

define('_DB_SERVER_', 'localhost');
define('_DB_TYPE_', 'MySQL');
define('_DB_NAME_', 'prestashop');
define('_DB_USER_', 'gaston');
define('_DB_PASSWD_', 'cenestpaslemotdepasse');
define('_DB_PREFIX_', 'ps_');
define('_MYSQL_ENGINE_', 'InnoDB');
define('__PS_BASE_URI__', '/prestashop/');
define('_PS_CACHING_SYSTEM_', 'MCached');
define('_PS_CACHE_ENABLED_', '0');
define('_MEDIA_SERVER_1_', '');
define('_MEDIA_SERVER_2_', '');
define('_MEDIA_SERVER_3_', '');
define('_THEME_NAME_', 'prestashop');
define('_COOKIE_KEY_', 'etquicroyaitquerjallaislaaisserça');
define('_RIJNDAEL_KEY_', 'etçanonplus');
define('_COOKIE_IV_', 'cookies');
define('_RIJNDAEL_IV_', 'Sage');
define('_PS_CREATION_DATE_', '2011-05-09');
define('_PS_VERSION_', '1.4.0.17');



Là je mets la version qui fait disparaitre les bouton précédent et suivant.

define('__PS_BASE_URI__', '/Prestashop/');
define('_MEDIA_SERVER_1_', '');
define('_MEDIA_SERVER_2_', '');
define('_MEDIA_SERVER_3_', '');
define('_PS_CACHING_SYSTEM_', 'MCached');
define('_PS_CACHE_ENABLED_', '0');
define('_THEME_NAME_', 'prestashop');
define('_DB_NAME_', 'prestashop');
define('_MYSQL_ENGINE_', 'InnoDB');
define('_DB_SERVER_', 'localhost');
define('_DB_USER_', 'gaston');
define('_DB_PREFIX_', 'ps_');
define('_DB_PASSWD_', 'cestpaslemotdepasse');
define('_DB_TYPE_', 'MySQL');
define('_COOKIE_KEY_', 'etçanonplusjelemetspas');
define('_COOKIE_IV_', 'cookies');
define('_RIJNDAEL_KEY_', 'etçanonplus');
define('_RIJNDAEL_IV_', 'encoremoins');
define('_PS_VERSION_', '1.4.0.17');



Maintenant qu'elle est la ligne qui cause la disparition des boutons ?
Peut-être le cookie_key ou rijndael_key ou rijnadael_iv ou est-ce autre chose si un observateur passe et trouve la faille merci de donner la réponse.

Share this post


Link to post
Share on other sites

Suite

à la 4eme étape j'ai eu une erreur

Erreur !
Une ou plusieurs erreurs sont apparues

Error during install/upgrade: Warning: Invalid argument supplied for foreach() in /home/tester/public_html/prestashop/install/php/desactivatecustommodules.php on line 41 Notice: Undefined variable: aModule in /home/tester/public_html/prestashop/install/php/desactivatecustommodules.php on line 49 Warning: Invalid argument supplied for foreach() in /home/tester/public_html/prestashop/install/php/desactivatecustommodules.php on line 49 Invalid loadConfiguration() SQL query

You may have to:

Fix the error(s) displayed
Put your database backup
Modify the file settings.inc.php to put the old version for the line with _PS_VERSION_
Restart the upgrade process from the begining

Share this post


Link to post
Share on other sites

Bonjour,

Concernant le module Easy Update je te conseille de te rapprocher du concepteur (tu joins la facture) pour obtenir une version plus récente qui va te permettre des mises à jour régulières.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More