Jump to content
Marghoob Suleman

[module-modified] categories menu modified

Recommended Posts

Thanks, it seems very beautiful.
This your blockcategory I must use him as a normal form for Prestashop? ... me known that it misses the icon 16x16 that it is in all the modules...
Excuse however I want to understand... how do I use blockcategories?

Share this post


Link to post
Share on other sites

Many thanks Marghoob

This worked very well just had to do a couple of tweaks to fit my theme...

Share this post


Link to post
Share on other sites

This your blockcategory I must use him as a normal form for Prestashop? … me known that it misses the icon 16×16 that it is in all the modules…
Excuse however I want to understand… how do I use blockcategories?

Share this post


Link to post
Share on other sites

I am sorry i did not mention. Download and extract blockcategories.zip and paste all files in the modules/blockcategories folder. You are done!

Share this post


Link to post
Share on other sites

Ok... thanks. Only to understand: Download and extract blockcategories.zip and paste all files in the modules / blockcategories folder. The icon 16x16 must create her me and to insert her in the folder blockcategories??? (as in all the present modules in prestashop)

Share this post


Link to post
Share on other sites
I am sorry i did not mention. Download and extract blockcategories.zip and paste all files in the modules/blockcategories folder. You are done!



My goosh, Marghoob Suleman, you did it again. That is a great contribution for the PS script. Thanks a lot.

Share this post


Link to post
Share on other sites

Yes that is it. Great Work Marghoob Suleman. Special thanks you. i wish to your works continuity.

Share this post


Link to post
Share on other sites

I don't perhaps make sense of well me. Excuse me. I speak of the icon 16x16 that it is present in all the modules of prestashop. If you open any form in yhe folder ..\modules\.. you will see that every form has one icon of his 16x16 that she will be visualized in the Back Office in the sections modules and position. My questions:
1) your form blockcategories is for the prestashop version 1.0, 1.1 or both?
2) the icon 16x16 that it is visualized in the Back Office I must create her to me me?
3) your form works as all the other modules? I must insert your blockcategories as a normal form in the folder..\modules \?
4) as me I plan the voices of menu and the secondary voices of menu?

Thanks

Share this post


Link to post
Share on other sites

I am sorry "myname". some people are angry with me. :) take a chill pill...

and all my updates are for 1.1. and you can modify it for 1.0 too...

Thanks "Start"... your appreciation really makes me happy :)

Share this post


Link to post
Share on other sites

Good evening,

First sorry for my English very average.
"Bravo" for your module "blockcategories", I tested at the moment, it's great!
I am very interested in the effect of enlarging images overview block "products" of your test-page.
Can you explain how to do this for all the pictures?
Thank you very much for your reply, it's very important for me.

Kinds regards,

Mandrake.

Share this post


Link to post
Share on other sites

Hi,
I have made a will the module "blockcategories" it is it seems to work... very beautiful! There are 3 great problems:

1) the module "blockcategories" after the 5 categories it overlaps to the other inferior modules (img 1)
2) if I shape the under categories the names they are not read - only after I pass the pointer above (img 2)
3) even if I eliminate the new one "blockcategories" and I insert the original module of PrestaShop 1.1 it doesn't appear me more the same original formulation (img 3)

Why?

HELP... thing I must do for having my original menu of prestashop 1.1? I have eliminated the folder with the "blockcategories" of Marghoob Suleman and I have inserted "blockcategories" original however the visualization is now confused (img 3)... what must I do for having in Front Office the my orginal "blockcategories" of prestashop 1.1?

3977_e8Gv1ro1X5swjfjAQdPp_t

3978_n6KCzGQPMi7DCyo2xbIq_t

3979_WGtkIJUt7m2NwOxJ4OPp_t

Share this post


Link to post
Share on other sites

myname

i had the overlap prob all i did was went into the Css file and right at the top it has height AUTO i changed it to what i needed for example 220px.

Share this post


Link to post
Share on other sites

Hi, the great problem is that inserting the module "blockcategories" of Marghoob Suleman is changed some inside parameters to Prestashop. I have eliminated the module of Marghoob Suleman and me I have inserted the original module of "bockcagories" of PrestaShop 1.1. Now the module is seen always as in immage 3. I have seen the file global.css, I have compared with other global.css of a prestashop 1.1 not installed... it is equal. I don't succeed in understanding what I must do for returning to the original situation with mine "blockcategories" original of prestashop 1.1


Help me please

3980_uaBn6t70ykQRWOGz4Pek_t

Share this post


Link to post
Share on other sites

The problem is that I have inserted original form of Prestashop 1.1, however the result is that of the image 3. I have also tried to insert the thema prestashop defoult, the original form "blockcategories" however it doesn't change. And' as if the "blockcategories" of Marghoob Suleman goes to modify other in the configuration of PrestaShop 1.1. I don't know what to do. I have put the "blockcategories" original... however it doesn't change... the result is always that of the image 3. HELP!

Does someone know how to resolve the problem to be able to make to work the "blockcategories" original of PrestaShop 1.1?

Share this post


Link to post
Share on other sites

Thanks for the help,
however I make the tests in local. I don't understand because even if I insert the original one "blockcategories" it doesn't bring me the original situation of my prestashop 1.1.
Please, does someone know what you can have happened when have inserted the "blockcategories" of Marghoob Suleman?
why now even if have I inserted the "block categories" original of prestashop 1.1 me from as resulted a block as in image ?

3985_zBynltdGFZI00kc4d1VD_t

3986_UTDhFYHDqYYH9qDnBAsN_t

Share this post


Link to post
Share on other sites

Thanks for your help,
however it seems that after having inserted your change of module "blockcategories" is modified something inside prestashop 1.1 because even if I insert the old one" "blockcategories" original, or your last file "blocategoires.tpl" the situation always stays the same one. I don't know how I must do and I don't understand how come you don't return to the original state. I have inserted only your block and later I have removed immediately him and inserted the "blockcategories" original of prestashop 1.1. Only that now he doesn't return to the original state.. I don't know what to do. Please help.
Some idea?

Share this post


Link to post
Share on other sites

Hi, I have followed the suggestion of Marghoob Suleman... I have cancelled the whole files of.. tools\smarty\compile (I have not removed alone index.php in compile folder)... magic .... the form "blockcategories" original of PrestaShop 1.1 are returned in the design as that original. I don't understand how come eliminating these files everything returns to the original state and with these files in.. smarty / complete her.. the form "blockcategories" was deprived of his original characteristics.

Thanks Marghoob Suleman

Share this post


Link to post
Share on other sites
Hi Guys!

Here is another updates for category menu (modules/blockcategories).

Modify stylesheet (ddsmoothmenu.css) for your own look and feel.

files included in zip:
blockcategories.tpl
ddsmoothmenu.css
ddsmoothmenu.js
down.gif
right.gif

Preview Available at: http://www.giftlelo.com/cart3/

Thanks and Regards
Marghoob Suleman


IE6 to menu width missing !!!

4011_Lum1TZNz29h5Ek7CpJ8J_t

Share this post


Link to post
Share on other sites
Hi Guys!

Here is another updates for category menu (modules/blockcategories).

Modify stylesheet (ddsmoothmenu.css) for your own look and feel.

files included in zip:
blockcategories.tpl
ddsmoothmenu.css
ddsmoothmenu.js
down.gif
right.gif

Preview Available at: http://www.giftlelo.com/cart3/

Thanks and Regards
Marghoob Suleman


IE6 to menu width missing !!!


encounter the same issue with IE6, though most ppl should update their IE or change other browser, so i just ignore it ....
Tomany other serious thing to take care .....
My solution, pit a note a footer : "Best view with FireFox or IE 7 and above"
:)

Share this post


Link to post
Share on other sites

sase

in the css file that come with this mod change the background color near the top of the css to the color that matches the rest then it will be fine i had to do it on mine now it looks ok in ie6. check it out vibrantgifts in my sig

Share this post


Link to post
Share on other sites
Hi, I have followed the suggestion of Marghoob Suleman... I have cancelled the whole files of.. tools\smarty\compile (I have not removed alone index.php in compile folder)... magic .... the form "blockcategories" original of PrestaShop 1.1 are returned in the design as that original. I don't understand how come eliminating these files everything returns to the original state and with these files in.. smarty / complete her.. the form "blockcategories" was deprived of his original characteristics.

Thanks Marghoob Suleman


You welcome! and I'll try to check modules in IE6. Actually i dont have that. But will find some solution.

Share this post


Link to post
Share on other sites

Hi Marghoob

Thanks for a great module. I have only one big problem and that is that when viewed in IE7, the sub-categories of the first main category do not display unless the cursor is hovered over them (image 2 and image 1 attached). From the second main category onwards everything works fine (i.e. their sub-categories display automatically and smoothly)(image 3 attached).

Also, when trying to position the cursor over the sub-categories of main catogory 1, they keep fading away before you can properly place the cursor over them to display them to click on the link i.e. not very smooth and stable at all.

About half of my website visitors still use IE so this is pretty important to me. I see some other people have had this problem as well but I cannot find any answers with a fix for this.

Everything works perfectly in FireFox ;-)

Thanks again for all your hard work on these modules, keep up the good work, we do appreciate it.

Mark

5575_M0EafAJHwVTU4b2Fvejw_t

5576_rpV2vAtCoBaruKJ1WmnS_t

5577_AITOvhKp5sgNUjEDi5LX_t

5578_AVNAkXikKCcTEHUZQ1vJ_t

Share this post


Link to post
Share on other sites
Okay, I'll check this. Some guy has problem in IE6 so I have uninstalled IE7 :( but i"ll check somewhere.
Hi Marghoob, any progress on this yet?

Or has anyone else been able to fix the IE bug with this module? This is a great module and I would love to be able to go live with it on my site next week but the IE problem is a bit of a deal breaker for me.

Share this post


Link to post
Share on other sites

Hi - has the IE problem been sorted yet? - any idea why the sub categories don't show without first rolling over them?

I also have anothe IE problem where by a gap opens up when you hover over an item in (for example) the second level menu if it contains a further subcategory. This means that it is impossible to scroll to the next item in the menu as it disappers beife you can get to it! See attached screenshot.

These are both quite major problems that need to be addressed.

6446_fLbrhvlxjDi9YtDiSyqR_t

Share this post


Link to post
Share on other sites

Well I found the offending style for my gap problem:

.ddsmoothmenu ul li ul li{
display: list-item;
float: none;
}



I find that if I add

margin-bottom:-3px



the gap disappears, but then when you move doen to the next item, it jumps up 3px because the gap disappears anyway (if that makes sense!) It seems that when the item is selected and has a submenu, a 3px gap is added to the bottom of that list item, but ONLY when itt is selected.

Any ideas about what would cause this? How can I stop it happening without screwing up the rest of the menu?

Share this post


Link to post
Share on other sites

Yippee! I've solved it. It was to do with IE adding extra space between li (as it does). the solution was to add:

vertical-align: top;



instead of the negative bottom margin.

Now to solve the disappearing link problem....

Share this post


Link to post
Share on other sites
Yippee! I've solved it. It was to do with IE adding extra space between li (as it does). the solution was to add:

vertical-align: top;



instead of the negative bottom margin.

Now to solve the disappearing link problem....

Thanks Babyewok, I am battling with the same "disappearing link" problem. Please post if you find a fix for it. Oh and I didn't even notice the "gap" problem, will check that out tonight.

Thanks again ;-)

Share this post


Link to post
Share on other sites

Marghoob, any suggestions to fix the disappearing link problem??

Share this post


Link to post
Share on other sites

Anyone? The link only disappears in IE when a subcategory has another subcategory. Once the link is rolled over it appears and then stays there until you navigate to another page. The only thing I can see changing in Firefox Firebug (where it all works fine) is that the display property for the sub category ul changes from "none" to "block" when the parent ul is rolled over

There must be a solution! :(

Share this post


Link to post
Share on other sites

Yippee! I found the solution! I was looking on the Dynamic Drive website, since the script originates from there, and found that the shadows had been causing problems - not quite the same as I had been experiencing, but problems none the less. Since I don't use the shadows anyway, I turned them off Et Voila!!! No more disappearing links (well in IE7 anyway as I am still testing on my local computer so can't test on IE6 yet - any IE6 reports appreciated).

You just need to edit this bit of code around lines 12-16 of ddsmoothmenu.js:

//Specify full URL to down and right arrow images (23 is padding-right added to top level LIs with drop downs):
arrowimages: {down:['downarrowclass', 'modules/blockcategories/right.gif', 23], right:['rightarrowclass', 'modules/blockcategories/right.gif']},

transition: {overtime:50, outtime:50}, //duration of slide in/ out animation, in milliseconds
shadow: {enabled:true, offsetx:2, offsety:2},



change the last line to read:

shadow: {enabled:false, offsetx:2, offsety:2},



So Marghoob, now you know where the problem lies, maybe you can figure out why IE7 doesn't like the shadows...

Share this post


Link to post
Share on other sites

OK, I just tried testing in IE6 and the disapperaing link problem is still evident. Help needed urgently please, I need to sign off in this site with my client now!!!

Share this post


Link to post
Share on other sites

ATTN: Marghoob

OK, I asked on the dynamic drive forums since the script originates from there and was asked:

"Does this happen with the default DD demo as well, or just on your own page? If the later, make sure your nested lists are nested properly. With the default demo, Folder 2 contains 3 levels deep of sub menus. In IE6, it works for me"

Now, it DOES work fine on the demo, so it has to be something to do with the may you edited the script for Prestashop. When I look at the source code for the generated page, the lists seem to be nested just fine.

Any suggestions?

Share this post


Link to post
Share on other sites

By the way, to keep the parent link 'active' when you move the mouse through the submenus, add this to the js file:

$headers.hover(
       function(e){
           $(this).children('a:eq(0)').addClass('selected')
       },
       function(e){
           $(this).children('a:eq(0)').removeClass('selected')
       }
   )



just ABOVE this (around line 46):

//$("#"+setting.mainmenuid).css({height:'auto'});

Share this post


Link to post
Share on other sites

I think I'm the only person who posts on this thread anymore!! Anyway, I notice that the anchor tags get ids such as menu_1, menu_2 to reflect how many submenus there are. However, this means that there are multiples of the same id!! That's bad css - you can only have one of a particular id on the page.

I can't for the life of me find where to change this to a class though....maybe this is the cause of the IE problems?? Worth a shot, besides it's bad practice so should be corrected anyway if someone can tell me how to please.

Share this post


Link to post
Share on other sites

well in IE7 when i have sub-subcategories they don't show untill mouseover.
Just looks like an empty slot.

Share this post


Link to post
Share on other sites

aha i don´t have sub subs
so i don´t know

but did you check the update version marghoob made som changes
sd

Share this post


Link to post
Share on other sites

i have his last updated version from his site.

Share this post


Link to post
Share on other sites

just write marghoob a pm

he his such a nice guy i´m sure he can help you with this
he made the module so he might know the answer.
sd

Share this post


Link to post
Share on other sites

Hi there - still stuck on the issue of the disappering links in IE6. I asked on the dhtml drive forums and finally got a reply from someone saying he had the same issue which went away when he updated to jquery 1.3.2. I am concerned that if I just replace the jquery-1.2.6.pcak.js file then I will cause problems elsewhere. Could I maybe add a script tag refferencing the location of the new jquery to the top of blockcategories.tpl and then have both scripts in the jquery file or would that cause problems?

Share this post


Link to post
Share on other sites

Hi all

I got an more interesting problem, I tested on firefox and chrome are fine, IE looks good until I try to access loyalty program, the whole categories just doesnt slide out, anyone has any idea how to fix it?

Thanks
Sean

10902_GeRowXw8yEYfe8Z5958L_t

Share this post


Link to post
Share on other sites

Hi! i have a some problem with this module. When i view some product with enabled FiendlyURL rigth arrow in this block was not appear. I correct this problem in ddsmoothmenu.js:

arrowimages: {down:['downarrowclass', 'modules/blockcategories/right.gif', 23], right:['rightarrowclass', 'modules/blockcategories/right.gif']},


rewrite to:

arrowimages: {down:['downarrowclass',baseDir +'modules/blockcategories/right.gif', 23], right:['rightarrowclass',baseDir +'modules/blockcategories/right.gif']},



just for fun;)

Share this post


Link to post
Share on other sites

Hey Guys,

This is a great little module is there any way of making the sub categories show up to the left as i would like this menu to go on the right side of my website.

And the sub categories won't be viewable on some small screens.

Cheers!

Share this post


Link to post
Share on other sites

I have only recently moved over to Prestashop and that is why I am only seeing the issues now. I too have the problem of when viewing with IE7, the sub menu's are not displaying unless you mouse over them.

Any advice?

Share this post


Link to post
Share on other sites

I have a small problem as-well .

If I add more then 5 categories the modules intersects with the next module




Edit : Solved , my bad .I moved "payment logo" just under the module

Share this post


Link to post
Share on other sites

Hello Marghoob Suleman, Thanks for this module.

Someone solved the problem of sub menu disappears? Both IE7 and IE8's the same. Someone help us.

Share this post


Link to post
Share on other sites

Hello! I deleted Index.php from "tools\smarty\compile" folder. After I realized i copied index.php from "smarty\compile" from Does it effect any thing on production? What will happen if i delete index.php file from tools\smarty\compile folder?

Share this post


Link to post
Share on other sites

How will the next two columns show the classification? Results are as follows




There are many categories when the two line display

24267_zGEGbcqsZFB3qOgvdwON_t

Share this post


Link to post
Share on other sites

Hey i also have a problem regarding the sub categories being blank. Is there anyway to fix this? :(

It works in one of my shops (version 1.2.5.0) but not in the latest 1.3 version.

Share this post


Link to post
Share on other sites

Hi
I have a problem:
When I change resolution menu are weird.
Here is a picture.
I don't know what to do.
pls help

39874_FcRYEAW9XtqWkE2jCyQw_t

Share this post


Link to post
Share on other sites

is this being updated for presta 1.4.x? I get a javascript error that breaks the whole site. FireBug's console reads "jQuery is not defined"

Share this post


Link to post
Share on other sites

Hi,

 

Any download link for prestashop 1.4.6.2? Please suggest.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

is it work for Presta 1.4.9 ?

or any other module could remplace..

 

 

Thank's you in advance,

fanfouet

Share this post


Link to post
Share on other sites

While using it in Version 1.5.1.0 I am getting error massage as below.

 

Fatal error: Call to undefined method Category::hideCategoryPosition() in /hermes/.../estock/modules/blockcategories/blockcategories.php on line 139

 

Will be great if anyone assist me.

 

thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More