Jump to content

[Fatal Error] Problème inconnu survenu sur mon site Prestashop 1.7


Recommended Posts

Bonjour à tous,

Je viens vers vous pour vous demander un avis sur un problème que je n'avais jamais eu sur Prestashop et qui me pose aujourd'hui problème.

Je suis en alternance et chargé de faire un site e-commerce sous Prestashop 1.7, lors de ma dernière période entreprise, tout fonctionnait à merveille. Lorsque je suis revenu en entreprise, j'ai constaté un problème lorsque j'ai tappé l'url du site sur le navigateur, voici le contenu du message d'erreur :

Quote


Warning: include(/home/premiuf/www/vendor/composer/../../app/AppKernel.php): failed to open stream: No such file or directory in /home/premiuf/www/vendor/composer/ClassLoader.php on line 571

Warning: include(): Failed opening '/home/premiuf/www/vendor/composer/../../app/AppKernel.php' for inclusion (include_path='/home/premiuf/www/vendor/pear/pear_exception:/home/premiuf/www/vendor/pear/console_getopt:/home/premiuf/www/vendor/pear/pear-core-minimal/src:/home/premiuf/www/vendor/pear/archive_tar:.:/usr/local/php7.4/lib/php') in /home/premiuf/www/vendor/composer/ClassLoader.php on line 571

Fatal error: Uncaught Error: Class 'AppKernel' not found in /home/premiuf/www/config/autoload.php:28 Stack trace: #0 /home/premiuf/www/config/config.inc.php(38): require_once() #1 /home/premiuf/www/index.php(27): require('/home/premiuf/w...') #2 {main} thrown in /home/premiuf/www/config/autoload.php on line 28

A savoir, comme dit plus tôt, pendant les 2 semaines passées en dehors de mes périodes de cours, je n'ai pas touché au site et personne n'est intervenu dessus dans l'entreprise... Ce problème persiste sur l'url du site ainsi que l'url du back-office de ce site !

Le site est hébergé chez OVH, je leur ai demandé si cela pouvait venir de leur côté ou non, mais la réponse du support était que ce soucis ne les concernait pas et qu'ils ne pouvaient rien faire pour arranger cela.

J'aurais aimé savoir si certains d'entre vous ont déjà rencontré ce problème ? Si c'est le cas, cela serait très gentil de m'expliquer ce qui ne fonctionne pas afin que je sache me débrouiller la prochaine fois et expliquer comment je pourrais régler ce problème rapidement !

Merci d'avance pour toute aide apportée et pour votre temps !

Paul
(https://premiumcartouche.com/)

Share this post


Link to post
Share on other sites

Oh oui je viens de vérifier, il était justement sorti de mon dossier "www" et se situait au même niveau que ce dernier ! Je viens de le remettre et tout fonctionne correctement ! Désolé pour l'erreur bête !

Ce n'est pas la première fois que vous m'aidez, je reconnais votre pseudo et photo, merci beaucoup pour votre aide précieuse !

Share this post


Link to post
Share on other sites

Cela arrive souvent quand on a Filezilla d'ouvert et qu'on clique en bougeant la souris alors qu'elle était sur cette fenêtre^^

Conseil: Réduire la fenêtre de Filezilla quand on a terminé pour éviter ce genre de mésaventures ;) 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More