Jump to content
Sign in to follow this  
heybref

Mise a jour inversé 1.4 > 1.3.2

Recommended Posts

Bonjours à tous,
Suite à une erreur d'achat de template, je me retrouve avec un Prestashop 1.4 et un template compatible 1.3.2.x.
Mal grès mes recherches sur le forum je n'ai trouvé personnes ayant fait la même bourde. le vrai problème, tout les produits (et il y en a) sont déjà rentrés dans la base.

Je voulais savoir si il était possible de migrer vers une version antérieure ou de de transférer les produits et les catégories de la version 1.4 vers une autre instal 1.3.2 ?

Merci d'avance, Cordialement,

Hey

Share this post


Link to post
Share on other sites

bonjour

Pour etre revenu sur 1.3.7, je confirme que c'est possible. Mais il faut avoir fait une sauvegarde de ta BDD avant la maj sur 1.4.

Share this post


Link to post
Share on other sites

Merci le Cathare mais je me suis mal exprimé. La première instal est la version 1.4. Il n'y a jamais eu de version 1.3.x. Si je pose la question c'est pour ne pas avoir acheté un template pour rien ou pour le pas avoir à réintégrer tout mes produit :'(
Merci quand même pour ton intervention.

Cordialement,
Hey

Share this post


Link to post
Share on other sites

Bonjour Le-cathare,


Peux -tu me dire comment on fait une mise à jour inversée (1.4.2.5 > 1.3.1.1) ?
J'ai un énorme souci avec les modules de paiement paypal et systempay, et personne (pas même prestashop) n'est capable de résoudre ce souci.
Alors je compte bien retourner en 1.3.1.1


Cordialement

Share this post


Link to post
Share on other sites

Houla !!

je vais tenter de me souvenir la manip.

Tout d'abord a tu une sauvegarde de ta basse de donnée de la version 1.3 et également une sauvegarde FTP de ta boutique en 1.3.

Si oui tu es "sauvé" Par contre si tu à fait des vente sur 1.4 elle seront perdu.

Quel est ton pb avec Paypal?


Je suis passer sur 1.4.3 et tout fonctionne, sauf paypal qui beug de temps en temps, mais l'équipe de prestashop travaillent sur ce pb

Share this post


Link to post
Share on other sites

Oui j'ai fait une sauvegarde lundi, mais depuis j'ai eu des commandes et je ne peux pas me permettre de les perdre, il faut absolument que je puisse récupérer les factures ce que je ne peux pas faire actuellement.

Mon souci :

Depuis que j’ai fait la mise à jour de prestashop 1.3.1 vers 1.4.2.5 sur le site de production (http://www.vidangefacile.com), les commandes faites avec systempay et paypal n’apparaissent plus dans l’onglet “Commandes” du back office.
En revanche, on les voit dans“Clients”>“Paniers”.
Le problème ne vient pas des modules puisque sur le site de test (http://www.5dpreprod.com) ça fonctionne.
Dans la table “ps2_orders” , on peut constater que “valid” est à 0 et non à 1

Tu penses que si je passe en 1.4.3 je n'aurais plus ce problème ? Parce que j'ai vraiment l'impression que ça vient de la base de données, mais si je fais la mise à jour en 1.4.3, je reprendrais ma sauvegarde, mais je ne peux pas me permettre de perdre mes commandes =/

Share this post


Link to post
Share on other sites

Moi quand j'avais cette manip ( retour de 1.4 à 1.3.7) j'ai pas eu de commande sur 1.4, car j'avais fermé la boutique. Mais on m'avais dit pour tout retrouver sur 1.3.7 il fallais de modifs ( commande, facture...) sur 1.4


Après plusieur tentative de maj de 1.3.7 à 1.4, Prestashop m'a contacter afin de mettre en place 1.4.2, j'ai donc testé cette version en avant première.

Et j'ai rencontré très peu de pb.

J'ai également était contacté pour la version 1.4.3, j'ai testé et toujours pas de pb, a part le petit bug intermittent de payal.


Si tu passe de 1.4.2 à 1.4.3 tu ne perdra pas les factures, commandes.....

Share this post


Link to post
Share on other sites

Lloraklo,
Je ne suis pas assez bon pour t'aider mais je pense que tu devrais dupliquer ton site V1.4.2.5 et faire la mis à jours sur la version dupliqué pour tester.

Aussi, n'étant qu'un "newcomer", je ne sais pas si je dois passer ma question en [Abandonné] ou si je laisse le post ouvert comme ça (vue que j'ai carrément réinstaller une version 1.3.2) ? Merci de me dire comment vous préféré !

Cordialement,
Hey

Share this post


Link to post
Share on other sites

Bonjour heybref,


La mise à jour sur le site de test s'est correctement déroulée, et je n'ai aucun souci sur le site de test avec les modules de paiement.
Si je dois faire une mise à jour inversée je la testerai sur le site de test ce qui est dommage puisqu'il fonctionne =/

Je préfère que ton post reste ouvert si ça ne te dérange pas, je pense que sur un post "abandonné" moins de personnes viennent voir le problème.


Cordialement

Share this post


Link to post
Share on other sites

OK je laisse comme ça. Mais le système de paiement marche peut-être mieux sur la version 1.4.3 non?
D'ailleurs question bête mais les paiements de tes paniers mal validés sont-il correctement passé?

Hey

Share this post


Link to post
Share on other sites

Peut-être, mais je ne peux pas me permettre de perdre les commandes qui ont été faites depuis la mise à jour.

J'avais demandé à la secrétaire de vérifier si les paiements avaient été validés, mais elle m'a dit que ça mettait 4 jours ...

Share this post


Link to post
Share on other sites

sinon, reste en 1.4 et soit acheter un nouveau template soit faire la mise à jour de ce template, je crois que c'est mieux

Share this post


Link to post
Share on other sites

Si la mise à jour en 1.4.3 a fonctionné, pourquoi ne passe tu pas le prod en 1.4.3?

Share this post


Link to post
Share on other sites
heybref a réinstallé PS 1.3.2 donc apparemment il n’a plus de souci


Moi j'ai réinstallé mais j'ai du tout recommencer :$. Je créé le site donc aucun besoin de garder mes commandes.

Hey

Share this post


Link to post
Share on other sites

parce que j'ai un souci avec la base de données apparemment, et je ne pense pas que le problème sera résolu en faisant la mise à jour 1.4.3, puisque la base de données sera la même..

et puis depuis mardi j'essaye d'avoir prestashop , enfin plus précisément une personne comme l'entreprise paye une prestation de maintenance, mais j'ai l'impression que rien n'est fait, le problème il faut vraiment que je le résolve au plus tard aujourd'hui
je sais bien qu'ils ont d'autres personnes avec des soucis mais tout de même !

Share this post


Link to post
Share on other sites

Si c'est un pb de basse de donnée, je pense pas que revenir sur 1.3 résoudra le problème.

J'était revenu sur 1.3.7 car 1.4 faisait que ramer, impossible d'ajouter des produits ...., mais j'avais pas eu de commande le temps que j'étais sur 1.4. ( pour passer de 1.4 à 1.3.7 j'avais mis 2 jours)

Depuis bientôt 1 mois je suis passer sur 1.4, et la semaine dernière sur 1.4.3.

Share this post


Link to post
Share on other sites

en revanche, je peux demander à mon hébergeur de remettre le site comme il était avant la mise à jour
mais je perdrais les commandes faites depuis =/ sauf si c'est possible de les récupérer ...

la version 1.4.3 fonctionne correctement sur ton site ?

Share this post


Link to post
Share on other sites

Si non , note toute les commandes et les créations de comptes et ajout de produits depuis la mise à jour, ferme ta boutique pour la journée et réinstalle un 1.3.x et tu recréé les commandes, compte et produits manuellement. Tu met un paiement par chèque au commande que t'a recrée comme sa t'a pas à galérer à refaire des paiement paypal.
Par contre je vois pas pk ta basse de donnée aurai un problème et pas ton prestashop?! tu a modifier le cœur du système? regarde dans les log change de la version 1.4.2 si ils ont fait des modifs sur les fonctionnement des commandes et de la validation des panier mais pour moi y a pas de raison que la basse de donné plante que sur un seul index de une seul table !

Hey

Share this post


Link to post
Share on other sites

c'est une idée oui, mais il faudra que je recrée les clients aussi non ? et puis leur mot de passe :S

dans ma base de données, on voit que dans la table "orders" l'élément "valid" est à 0 au lieu de 1 pour les commandes

je n'ai rien modifié, j'ai juste fait la mise à jour, regénérer le .htaccess, et rajouter dans celui-ci les lignes suivantes :

#Fonction fopen
php_flag "allow_url_fopen" "On"
php_flag "allow_url_include" "On"

#Demandé par Infomaniak
php_value magic_quotes_gpc "1"
php_value register_globals "0"

#Pour permission mail
php_flag allow_url_fopen On
php_flag allow_url_include On
php_flag register_globals Off

On voit que les 2 lignes pour la fonction fopen sont quasi les même que pour la permission des mails mais avec des guillemets en plus, mais je ne pense pas que le problème soit ça

Comment on fait pour regarder dans les log ?

Share this post


Link to post
Share on other sites

@ Lloraklo,

réponse à ton post 5. J'avais un problème sur ma table ps_order, c'est là ou sont stockées tes commandes.
de la 1.4 pour revenir vers la 1.3, c'est possible. Tu remets ton ancienne base, ton fichier ftp sauvegardé et c'est bon, tu as ton ancienne version.

1) méthode 1
Avant de faire cela tu sauvegarde ta base mysql de la 1.4 et tu la mets sur ton serveur local. Si tu veux récupérer tes commandes de la 1.4 sur ta base 1.3, tu peux mais t'as du boulot.

il te faut :
-copier toutes les lignes de ta table ps_order sur ta base mysql 1.3 en utilisant la fonction insérer ligne, mais t'as pas que ça tu as les tables, groupe, inscription sur le site et à ça que va te servir ta base 1.4 en local.

Une fois terminé, t'auras toujours un problème, tes nouveaux clients inscrits qui ont passé commande sur ta 1.4, tu devras les contacter et leur attribuer un mot de passe.

2) méthode 2
en te servant de ta base 1.4
tu inscris tous tes clients sur le site depuis le back office, client->nouveau. Tu prends soin de changer d'adresse mail, une adresse yopmail suffit, tu passes les commandes qu'ils ont passé.
Ensuite tu vas sur ton serveur, tu changes les adresses de tes clients en remettant leur adresse et dans ta table ps_order, tu rectifies avec le calendrier la date des commandes passées.
Tu devras de toute façon leur attribuer un mot de passe aussi.

Si t'as qu'une quinzaine de commandes, c'est réalisable, sinon laisse tomber. Quand la tuile m'est arrivée, j'ai recopié 11 commandes, ensuite, j'ai laissé tomber. J'ai toujours ma vieille base en archive donc je peux voir mes arriérés de commande.

Share this post


Link to post
Share on other sites

Je te remercie pouicpouic12,
Je ferais cela si le problème ne se résoud toujours pas.

J'ai vu que dans le dossier log il y avait deux fichiers contenant énormément d'erreurs... les problèmes doivent venir de là !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More