Jump to content

Product creation add of features error: This value is not valid


Recommended Posts


I have a problem with my prestashop 1.7.8 site

When I create a new product and add features with predefined values and others with custom values and save the product I get the error: This value is not valid for custom values


Do you have any idea how to solve the problem please

Link to comment
Share on other sites

  • 3 months later...
  • 5 months later...
hace 11 minutos, Maurice dijo:

Same problem for me version

i try to change php version from 7.3 to 7.4 but still same problem anyone solved this issue?

Hello, I attached a screenshot, but I would say that you cannot choose custom and predefined at the same time on the same line

Link to comment
Share on other sites

Hi . Yes you are right , if i choose custom i get error while if predefined no error.

Unfortunately my provider do not allow to swicth to php 7.2x i feel that php verion can be the problem i m not sure

even i think some module can create problem , but unfortunately i almost deactivated some module , but custom features still give me problem i would solve to 100%

Link to comment
Share on other sites

  • 2 weeks later...
  • 7 months later...

Dear Dandu , glad to see that i m not alone fighting this problem , i personally discovered this bug in October 2022

and posted Video on https://github.com/PrestaShop/PrestaShop/issues/30042#issuecomment-1556546158

when no one nobody believed in this bug , i try trillion of solutions but until now nothing to do , even because if you go on debug you won't find errors in reference

i m sure that problem is located in classes/product.php

I appreciate if we can stay in touch in order to solve this matter.



Link to comment
Share on other sites

1 minuto fa, dandumit dice:

@Maurice I have solved it. I have deleted some empty values from features / database and now it's working flawlesly back.

I for this investigation I have used  Presta Tool Suite from @musicmaster

Hi , i try in the past to see if in my features there is some value with symbols ecc , but i never try to see if i have some empty value , but the strange  issue

is that i reproduce this bug even with a fresh install as you can see on GitHub Video , and i really feel that they do not know how to solve

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...