Jump to content

Slow back office, but fast in debug mode


Angeall

Recommended Posts

Hi everyone !

I could use some help.
I'm using Prestashop 1.7.7.7, and since a few weeks, I'm experiencing a really slow back office (10 to 20seconds between pages). I have no issues with the front office. I upgraded to a faster server (doubled the CPU/RAM), but nothing changed.

Trying to know which module or hook could be responsible for this slowness, I enabled debug mode to have timings on the request. And in debug mode, the back office is super fast. I don't have the same issue at all.

I already tried to clear the 'prod' and 'dev' cache, my smarty recompilation settings are on "never recompile".
I'm a bit clueless right now, do you have an idea what could case such a difference between debug and prod modes ?

My first idea was to enable debug mode as it enables performance monitoring using Symfony, but as I said, debug mode seems to "solve the issue"... It is obvious that I just can't let the shop in debug mode while in production, so I must find the real issue.

Do you have ideas for me to dig deeper ?

Thanks a lot ūüėĄ

Link to comment
Share on other sites

Thanks as well for you answer ! :)

I already saw this topic and tried everything proposed in it.
For me it does not change anything.
I had big hopes about disabling the gamification plugin, but it does not help at all, neither do the other things mentioned.

I don't know what to do but keep the website under debug mode :(

Link to comment
Share on other sites

  • 7 months later...

I'm having exactly the same problem on my Prestashop. I've looked into basically everything and none of the solutions worked. I've also upgraded to a faster server, which made little to no difference when debug mode is off. All the cache settings are optimized. Also uninstalled the gamification plugin and all unecessary plugins.

My PrestaShop version is 1.7.8.2.

If it helps, I'm using the Warehouse theme by iQit.

Any idea would be greatly appreciated

 

Link to comment
Share on other sites

You can try two things:

1)You can check your error log if there is any issue showing in error log regarding the third party module then you can disable that module and check if the issue is caused by that module.

2)You can disable the module one by one and check for the speed and you have to disable the debug mode also after which if you notice that after disabling a particular module there is difference in speed of back office then you can check that module or contact that module developer for the same.

Link to comment
Share on other sites

  • 3 months later...
  • 1 year later...
Posted (edited)

Hi,

I've the same issue facing for backoffice login which is taking more than 10-15 sec to login.

PrestaShop version: 1.7.7.2

OS: REHL 7

PHP: 7.1

I've done all the debugging like restarting HTTPD, PHP FPM, MYSQL ROUTER services, even I tried to rebooting the OS as well but the problem still exists. I've been monitoring the CPU usage, memory consumption, everything is fine and had enough space free.

Please let me know if anybody finds something to resolve this.

Edited by Rachit Agarwal
Update text (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...