Jump to content

Recommended Posts

Hello, i'm trying to install Prestashop on a custom docker container, but every time i try, i get a 500 error during addon module

install, my docker image looks like this :

 

FROM php:7.1.33-apache

RUN docker-php-ext-install mysqli pdo_mysql
RUN apt-get update \
    && apt-get install -y libzip-dev \
    && apt-get install -y zlib1g-dev \
    && rm -rf /var/lib/apt/lists/* \
    && docker-php-ext-install zip \
    && docker-php-ext-install opcache
RUN apt-get update && apt-get install -y libpng-dev
RUN apt-get install -y \
    libwebp-dev \
    libjpeg62-turbo-dev \
    libpng-dev libxpm-dev \
    libfreetype6-dev

RUN docker-php-ext-configure gd \
    --with-gd \
    --with-webp-dir \
    --with-jpeg-dir \
    --with-png-dir \
    --with-zlib-dir \
    --with-xpm-dir \
    --with-freetype-dir \
    --enable-gd-native-ttf

RUN apt-get -y update \
    && apt-get install -y libicu-dev \
    && docker-php-ext-configure intl \
    && docker-php-ext-install intl

RUN docker-php-ext-install gd
RUN sed -i 's/www-data:x:33:33/www-data:x:1000:1000/' /etc/passwd
RUN a2enmod rewrite
COPY ./php-custom.ini /usr/local/etc/php/conf.d/docker-php-memlimit.ini

 

I can't change my php version for some reasons. I'm running docker on windows with wsl2 integration.

 

I've tried to change the permissions of install dir and index to 755, i've also tried the same installation on wamp, and get the

same error 500. (the screenshot bellow).

image.png.621b2e4bc541be326c1f7dfe970500e7.png

 

I don't think that's a database issue because the connection work (on docker or wamp) and the database is created and filled.

 

the access log of the errors are bellow :

image.thumb.png.b68add8ce732f95f7e9a5f4282d07cfe.png

 

I've tried with this archive https://github.com/PrestaShop/PrestaShop/releases/download/1.7.3.0/prestashop_1.7.3.0.zip .

 

(I also tried with the source code from github but i get a composer error that says that composer.json doesn't match json regex)

 

Thanks for reading me, and sorry for my bad english, i hope you understand !

Share this post


Link to post
Share on other sites

57 minutes ago, ComGrafPL said:

Check the folders and files permissions. Set 775 / 644.

 

I've already checked file / folder permissions, and i still have the same 500 error

find . -type d -exec chmod 0755 {} \;
find . -type f -exec chmod 0644 {} \;

 

Share this post


Link to post
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More