Jump to content

[Risolto]Descrizione prodotto (<br>non funziona)


Lind22
 Share

Recommended Posts

Buongiorno,

riscontro per la seconda volta questo problema: scrivo un testo in 'descrizione prodotto' e premo invio tra una frase e l'altra per creare uno spazio. In Front End questo spazio non viene creato (cache svuotate), tra una frase e l'altra va a capo, ma restano attaccate.. non viene generato alcun tipo di spazio.

Provo ad inserire vari <br> in codice sorgente, salvo, svuoto le cache, ma in Front End non cambia nulla. La prima volta ho pensato che fosse un problema del tema in uso, ma questa volta inizio a pensare che funzioni così di default.

Al momento ho risolto inserendo delle righe di tabella dove mi serve lo spazio (allegato), in Front End la tabella non si vede, perciò il risultato finale è quello desiderato, ma è poco intuitivo per il cliente che in seguito dovrà caricare da solo gli articoli.

Qualcuno sa se posso agire diversamente?

Grazie per la disponibilità.

spazio.JPG

FE.JPG

Edited by Lind22 (see edit history)

Share this post


Link to post
Share on other sites

Ciao,

ecco il link: https://www.idigital3.net/am/it/caterina-lancini-/2-43-blusa-in-raso.html#/1-taglia-s/11-colore

In allegato come si vede in BO.

Ho inserito due <br> in codice sorgente (dopo Made in Italy e dopo 'lavare e stirare al rovescio').

Dopo aver salvato in codice sorgente vengono entrambi sostituiti da <p></p>. 

esempio1.JPG

Edited by Lind22 (see edit history)

Share this post


Link to post
Share on other sites

 Purtroppo non risolve il problema, perchè aumenta l'altezza di tutte le righe. Avrei bisogno della differenza tra 'a capo' e 'invio', come accade per esempio su Word.

Per il momento ho trovato questa soluzione (per il cliente migliore di quella delle tabelle): copia/incolla del testo da Word. PrestaShop mantiene la formattazione lasciando in Front End il testo come desiderato.

La scomodità sarà quella di scrivere sempre prima in Word e poi trasferire.

Grazie per il consiglio 🙂 

Edited by Lind22 (see edit history)

Share this post


Link to post
Share on other sites

Ciao come dice Giuseppe potresti aggiungere una classe nel template, ma la cosa piú rapida é intervenire da css, aggiungi al theme.css

.product-description > p

line-height: etc etc

 

Correzione: ho visto ora che in realtá non é la soluzione perché espande tutte le p ovviamente.

Si dovrebbe estendere l'editor!!. Só che c'erano delle guide da qualche parte in rete, ma esistono anche moduletti dal costo irrisorio che forse migliorano quest'aspetto dell'editor!!

 

 

ciao:-)

Edited by Fabry
correzione (see edit history)

Share this post


Link to post
Share on other sites

Ciao a tutti,

grazie davvero per i preziosi consigli! 

Al momento ho trovato una quadra aggiungendo in custom.css:

#description.tab-pane.fade.in.active  {
 line-height: 14px;
 white-space: pre-line; 
}

Mi informo per le guide ed i moduli, intanto imposto il Topic come risolto. 

 

Buona giornata,

Linda

 

Edited by Lind22 (see edit history)

Share this post


Link to post
Share on other sites

  • Lind22 changed the title to [Risolto]Descrizione prodotto (<br>non funziona)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More