Jump to content

Webservice not working after server migration


yodeux
 Share

Recommended Posts

Hello all,

We migrate from OVH to O2switch a few days ago.

To make the transition, I went with SSH, compress everything on the old server, download to the new one (all cache cleared).

Everything went smooth except for the webservice we use for our shipping service.

Since the server change, we have this error in the XML everytime we try to connect to https://[email protected]/API/

<error>
<code>
<![CDATA[ 5 ]]>
</code>
<message>
<![CDATA[ [PHP Notice #8] Undefined index: description (/home/lhhp6295/preprod/classes/webservice/WebserviceOutputBuilder.php, line 331) ]]>

So far I tried to

  • Tried CGI or module
  • upgrade to PS 1.7.7.4
  • deleted and recreated webservice key
  • activate/deactivate webservices
  • deactivate/reactivate all non native modules and overrides

I installed a fresh and empty PS on a subdomain, and webservice works fine...

So I am a bit lost...

Please someone help !

  • Like 1

Share this post


Link to post
Share on other sites

  • 5 weeks later...
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More