Jump to content

(gelöst) Problem mit "Neue Artikel"


Recommended Posts

Posted (edited)

Auf der Startseite meines Prestashops 1.7.7.3 habe ich den Block "Neue Artikel" platziert. Dieser Block enthält einen LInk zu "Alle neuen Artikel". Klickt man auf diesen Link werden alle neuen Artikel aufgelistet. In meinem Fall sind das alle, weil alle neu sind. Die Artikel sind in drei verschiedenen Kategorien eingeordnet.

Jetzt kommt das eigentliche Problem. Habe ich mir die Kategorie "Fotografie" angesehen, gehe von dort auf die Startseite und klicke dann auf "Alle neuen Werke", so werden mir alle neuen Werke angezeigt aber als Kategorie wird "Fotografie" angezeigt. Das gleiche passiert, wenn ich vorher in der Kategorie "Grafik" war. Dann wird mir auf "Neue-Werke" "Grafik als Kategorie angezeigt.

Wenn ich auf Galerie gehe und anschließend über die Startseite zu den "Neuen Werken" werden mir alle Kategorien angezeigt, was ich irgendwie richtig finde. Allerdings liegt die Vermutung nahe, dass hier etwas grundsätzlich falsch läuft.

Das muss wohl mit irgendwelchen Sessions und php zusammenhängen – oder auch nicht. Ich habe echt keine Ahnung. Oder man muss auch "Neue Artikel/Werke" als Kategorie definieren, damit es eine Headline bekommt? Aber die URL ist immer korrekt und auch die Breadcrumbnavi zeigt brav "Neue Werke". Also was läuft hier schief.

https://amthof.art

41590572_Screenshot_2021-05-07NeueArtikel-1.png.94442ba91fb4401a72c12bef28b081bd.png215408312_Screenshot_2021-05-07NeueArtikel-2.png.95981ebba27d7c66aee5f801b9977862.png

 

264274461_Screenshot_2021-05-07NeueArtikel-3.png.78f0f672eebfb6e32053365734d0296b.png

 

Edited by pixmax (see edit history)

Share this post


Link to post
Share on other sites

Ich fürchte da hast du einen Bug von 1.7 gefunden, im offiziellen Demo-Shop ist es auch so, bei meinem 1.6er-Shop nicht.

Eine "Überschrift" ist das in der linken Seitenspalte übrigens nicht (die steht in der Hauptspalte über den Bildern), sondern Links zu Kategorien und Unterkategorien (was da angezeigt wird kann konfiguriert werden, wohl im Modul "category tree links").

Share this post


Link to post
Share on other sites

Da habe ich mich vermutlich etwas blöd ausgedrückt. Dort links wird natürlich die Kategorie angezeigt in der man sich befindet und eventuelle Unterkategorien. Deshalb hatte ich auch die These aufgestell ob dann "Neue Werke" auch als Kategorie definiert werden müsst um dort zu erscheinen und nicht beispielsweise "Fotografie".

Wo meldet man einen solchen Bug? Irgendwie kommt man ja an Prestashop nicht heran.

Share this post


Link to post
Share on other sites

Ich erstelle gerade dort ein neues Thema. also ist es nicht notwendig das hier zu verschieben. Danke für Deine Mühe. Du hast meinen allerhöchsten Respekt.

Share this post


Link to post
Share on other sites

Ich kann den Fehler im Demoshop nicht reproduzieren. Der Demoshop ist 1.7.7.4. Vielleicht hat man das schon behoben? Kann ich mir gar nicht vorstellen.

Share this post


Link to post
Share on other sites

Ok, also eigentlich dürfte der Block mit den Kategorien links gar nicht erscheinen. Das ist der eigentliche Fehler. Die Seite sollte sich ähnlich verhalten wie "Werke einer bestimmten Ausstellung" oder "Werke eines bestimmten Künstlers". Dort gibt es die linke Spalte nicht und es werden einfach nur die Artikel/Werke aufgelistet. Das sind die Seiten in denen normalerweise die Artikel eines Lieferanten bzw. einer Marke aufgelistet werden. Seiten die im Backoffice nicht konfiguriert werden können wie Kategorie-Seiten. Ich schau mir jetzt mal das Template für "Neue Artikel" an. Vielleicht finde ich da etwas.

Share this post


Link to post
Share on other sites

Ich glaube es liegt einzig und allein am Modul "Neue Artikel". Aber die linke Spalte habe ich jetzt mit CSS gekillt.

#new-products div#left-column {
    display: none;
}

Jetzt muss ich nur noch den Content-Wrapper auf 5 Werke verbreitern, so wie auf allen anderen Seiten. Dann bin ich zufrieden.

Share this post


Link to post
Share on other sites

Posted (edited)
vor 1 Stunde schrieb pixmax:

Ich kann den Fehler im Demoshop nicht reproduzieren. Der Demoshop ist 1.7.7.4. Vielleicht hat man das schon behoben? Kann ich mir gar nicht vorstellen.

?

Also wenn ich dort eine Kategorie auswähle (z. B. Clothes oder Accessoires) und dann unten auf "New Products" klicke wird neben allen neuen Produkten in der linken Spalte die zuvor aufgerufene Kategorie sowie deren Unterkategorien angezeigt.

Zitat

eigentlich dürfte der Block mit den Kategorien links gar nicht erscheinen.

Wieso nicht, in meinem Shop werden in diesem Fall alle Hauptkategorien angezeigt. Du hast aber die Möglichkeit im BackOffice das Anzeigen der linken Spalte für die Seite "Neue Artikel" komplett auszublenden (Design > Theme & Logo > Theme > ganz unten auf Wähle Layouts oder ähnlich).

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

  • pixmax changed the title to (gelöst) Problem mit "Neue Artikel"

Oh, da hab ich mir jetzt völlig umsonst eine Menge Arbeit gemacht. Dieser kleine unauffällige Link ist mir noch nie aufgefallen. Jetzt ist alles nahezu perfekt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More