Jump to content

(gelöst) Sortierung funktioniert überhaupt nicht mehr


Recommended Posts

Posted (edited)

Hallo, leider wieder nichts gefunden mit der Suche. Über nicht funktionierende Suche schon, aber irgendwie nicht das was ich bräuchte.

Also ich weiß, dass die Suche funktioniert hat. Seit wann genau sie jetzt nicht mehr funktioniert kann ich nicht sagen. Ich habe gestern einen Passwortschutz über die htaccess eingebaut. Aber die habe ich gerade wieder rausgenommen und es wird trotzdem nicht richtig sortiert. Also es wird zwar sortiert, aber in keinem Fall richtig. Ob Preis oder ABC, vorwärts oder rückwärts – es wird zwar immer umsortiert, aber nie richtig. Ist immer alles durcheinander.

Was kann das bewirkt haben?

Prestashop 1.7.7.3
https://amthof.art

Edited by pixmax
gelöst (see edit history)

Share this post


Link to post
Share on other sites

Posted (edited)

Sehr merkwürdig. Wenn ich nach Name (A-Z) sortiere bekomme ich die Reihenfolge Eiswelt, Stele, Wasserwelt, City structures, Constructivism, Passage, Skyfall, Urban Architecture. Wenn ich Z-A sortiere bekomme ich nicht etwa das Ergebnis A-Z umgekehrt, sondern wieder ganz anders sortiert. Wenn ich nach Preis sortiere geht das genauso durcheinander. Ich habe das jetzt in Firefox, Chrome, Opera und Android Chrome getestet und überall das gleiche Ergebnis.

Für jede Sortierung gibt es aber immer ein spezifisches Ergebnis. Das Ergebnis der Sortierung nach A-Z ist also immer das gleiche, falsche Ergebnis.

Was kann jetzt die Ursache für die richtigen Sortierungen bei Dir und die falschen bei mir sein? Wir greifen auf den selben Server und die selbe Datenbank zu und die selbe Shop-Software auf diesem Server. Da bin ich jetzt wirklich absolut ratlos.

1639296842_Screenshot_2021-05-04Galerie.thumb.png.5d64c2810986d3e072008334874fa3e6.png

Interessanter Weise habe ich in der Liste "Neue Werke" fast immer die richtige Sortierung. Nur einmal war die Sortierung falsch. Beim weiteren Testen passierte das aber nicht mehr.

In der Galerie und den Kategorien ist es aber noch immer falsch.

Screenshot_2021-05-05 Neue Artikel.png

Edited by pixmax
Ergänzung (see edit history)

Share this post


Link to post
Share on other sites

Jetzt stimmt die Reihenfolge bei mir auch nicht mehr (oder es handelt sich um andere Kategorien). Seltsam, ich habe erst gedacht daß es sich um Kategorien mit Unterkategorien handelt und die Artikel nicht in der Kategorie selbst liegen sondern nur in den Unterkategorien. Das ist aber bei der Kategorie Fotografie offenbar nicht der Fall. Kann es sein daß ein Modul da eingreift, ggf. deaktiviere mal alle Fremdmodule und Overrides.

Share this post


Link to post
Share on other sites

Ok. Also Fremdmodule habe ich bis jetzt nur zwei (Paqypal, Google sitemap). Die habe ich deaktiviert. Ob ich Overrides habe, kann ich gar nicht sagen. Ich vermute mal nein. Ich habe kein Theme installiert bis auf das "classic" und daraus über das CSS alle umgestrickt. Das sollte aber keinen Einfluss auf die Sortierung haben.

Ich kann inzwischen aber ein Muster erkennen. In der Sortierung  "Name (A-Z)" sind die ersten sechs Artikel die, die ich zuerst eingestellt habe. Diese sechs für sich sind richtig sortiert. Sieht man sich separat mal die restlichen 7 Werke an, so sind die für sich gesehen auch richtig sortiert. Das gleiche gilt, wenn man nach Preisen sortiert. Es sieht so aus, als hätte ich zwei Gruppen. Ich habe gerade nochmal alle Kategorien überprüft. Alle Artikel sind der Startseite, der Galerie und (bis auf die Stele) der Fotografie zugeordnet. Hauptkategorie der Bilder ist überall Fotografie.

Was könnte diese Grupierung bewirken? Alle Artikel sind indiziert, wobei das nach meinem Verständnis ja nur für die Suche relevant ist. Irgend eine Idee?

Share this post


Link to post
Share on other sites

Ich habs!!! Ich hatte die Bestandsverwaltung in den Shopeinstellungen deaktiviert. So ist mir nicht aufgefallen, dass die zweite Gruppe als Menge alle 0 hatten. Waren also nicht vorhanden. Nicht vorhandene Artikel sollen aber trotzdem angezeigt werden. Allerdings werden sie so immer in der Auflistung von den lieferbaren separiert. Es fehlt bei dieser Einstellung im Backoffice auf der Artikelseite auch das Eingabefeld für die Menge und in der Artikelauflistung wird die Menge auch nicht angezeigt. So konnte mir dieser wichtige Unterschied nicht auffallen. Und die Mengen für die zweite Gruppe habe ich dann auch nicht eingetragen, weil das Eingabefeld gar nicht da war.

Jetzt haben alle ihre Mengenangabe und siehe da, jetzt wird alles ordentlich sortiert. Danke nochmal für Deine Unterstützung!

 

Share this post


Link to post
Share on other sites

  • pixmax changed the title to (gelöst) Sortierung funktioniert überhaupt nicht mehr

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More