Jump to content
Sign in to follow this  
bretweb

Après mise a jour vers 1.4.1 certains liens ne fonctionnnent plus !

Recommended Posts

Bonjour
j'ai appliqué la mise a jour vers 1.4.1 et c'est une horreur !!

Infernal le temps que l'on perd avec ces mises a jours! je ne comprend pas que l'on n'arrive pas avoir une mise a jour automatique avec cette boutique!!!
mais comment voulez vous que l'on vous suive sur les MAJ si l'on doit se galérer a chaque fois !
Heureusement c'est une boutique test chez 1and1 et pas une boutique client ...
http://www.eboutique-prestashop.bretweb.net/
hors tous les problèmes résolus sur les Htacces voici ici ceux restant
lien panier = La page que vous avez demandée n'existe plus
lien commande= La page que vous avez demandée n'existe plus
lien site map = O
lien rechercher =O



merci de votre aide

Share this post


Link to post
Share on other sites

Prestashop est open-source, les développeurs font de leur mieux pour optimiser la solution. Il est compliquer de satisfaire autant de boutique et le processus d'installation prend du temps car les éléments en jeux sont risqués.
Concernant vos erreurs, avez vous généré le htaccess à partir du module Prestashop ? D'où provient votre thème ?

Share this post


Link to post
Share on other sites

Bonjour

je comprend bien Open source mais quitte à améliorer comme vous avez fait le Back off. peut être que devant le nombre qui galèrent un systeme de MAJ plus perfectionné serait bienvenu ...

pour ce qui est des thèmes j'ai le même problème avec le thème standard ou d'autres bien prévus pour la 1.4 ...

pour ce qui est du HT access il est généré par le système avec juste les modifs nécessaires à 1and1 ..

mais vu que 90 % du système fonctionne je pense peut etre que delà vient d'ailleurs ...

Share this post


Link to post
Share on other sites

Bonsoir,
C'est vrai qu'après lecture des différents postes, on comprend mieux ceux qui prefere ne pas suivre les mises à jour et rester avec de vieilles version qu'ils ont réussi à débugger.

Concernant open source, cela ne veut pas dire que le systeme doit etre forcément buggé(bonjour la pub pour l'open source :-S ), qu'il soit Open source ou autre, à partir du moment que celui-ci est annoncé stable, cela veut dire que celui-ci est sensé fonctionner parfaitement, seul quelques bug très très mineurs peuvent à l'occasion est découvert au fil de l'utilisation hors, à peine prestashop est installé que celui-ci ne fonctionne pas correctement :long:

C'est très dommage que la team prenne cela à la légere, il existe plein de systeme Open-source qui fonctionne très bien du premier coup et cela pour une raison évidente, ils prennent le temps d'effectuer les testes, le délai est peu-etre beaucoup plus long entre chaque version mais lorsque celle-ci est annoncée stable, il n'y a pas a revenir dessus 8-/, c'est navrant de ne pas pouvoir faire confiance lorsque l'on veu effectuer une mise à jour 8-/ .

Cette version est donc une instable :smirk: , il faudra attendre l'etat de la prochaine version pour pouvoir définir vraiement si celle-ci sera une VRAIE stable ou non :long:

Share this post


Link to post
Share on other sites

A chaque sorties de mises à jour, c'est toujours et à juste titre, le bureau des plaintes.

Beaucoup ont demandés par le passé, que les fichiers mis à jour soient renseignés et qu'il n'y ai plus qu'à remplacer les anciens mais apparemment ce ne doit pas être possible puisque rien n'a changé.

Toujours est-il qu'il faut s'attendre à mon humble avis, dans les mois qui viennent à plusieurs mises à jour, si je me réfère à la 1.3 qui est maintenant la 1.3.7.

Alors je pense que si votre version 1.4 tourne sans problèmes majeurs, il est sans doute préférable d'attendre une version plus à maturité avant de sauter le pas.

Cordialement

Share this post


Link to post
Share on other sites
Bonjour

je comprend bien Open source mais quitte à améliorer comme vous avez fait le Back off. peut être que devant le nombre qui galèrent un systeme de MAJ plus perfectionné serait bienvenu ...

pour ce qui est des thèmes j'ai le même problème avec le thème standard ou d'autres bien prévus pour la 1.4 ...

pour ce qui est du HT access il est généré par le système avec juste les modifs nécessaires à 1and1 ..

mais vu que 90 % du système fonctionne je pense peut etre que delà vient d'ailleurs ...


Bonjour,

Dans le BO : Préférences -> SEO

Tu édites par exemple la ligne correspondante à Plan du site

si ce n'est fait , tu ajoutes l'url simplifiée plan-du-site et tu sélectionnes bien le fichier sitemap.php dans la liste déroulante.
Enregistre et hop , ton lien refonctionne.

Ensuite ben tu répètes l'opération pour contact ...

C'est à faire pour tous les controlleurs qui ne fonctionnent plus .

Je pense qu'il y a un oubli à ce niveau là dans la mise à jour ... du fait des améliorations SEO

Share this post


Link to post
Share on other sites

Merci pour les infos VIP je vais aller voir ça de plus prés!
j'avoue que je suis un peu dubitatif je n'ai rien changé de particulier et le lien panier et commande remarche a nouveau !!!

effectivement actuellement il n'y a plus que les lien contact et plan de site qui ne fonctionnent pas ... je vais regarder ... mais bon je me vois mal condamner 48h ou plus la boutique d'un client pour un MAJ !
Puisse que l'on parle de SEO quelqu'un aurait il un idée pour virer les chiffres qui se rajoutent dans les URLS ... je ne vois pas a quoi ça sert...

tiens encore une autre la thickbox ou fancy ne fonctionne plus non plus :(

Merci d'avance

Share this post


Link to post
Share on other sites
Merci pour les infos VIP je vais aller voir ça de plus prés!
j'avoue que je suis un peu dubitatif je n'ai rien changé de particulier et le lien panier et commande remarche a nouveau !!!

effectivement actuellement il n'y a plus que les lien contact et plan de site qui ne fonctionnent pas ... je vais regarder ... mais bon je me vois mal condamner 48h ou plus la boutique d'un client pour un MAJ !
Puisse que l'on parle de SEO quelqu'un aurait il un idée pour virer les chiffres qui se rajoutent dans les URLS ... je ne vois pas a quoi ça sert...

tiens encore une autre la thickbox ou fancy ne fonctionne plus non plus :(

Merci d'avance


Je ne m'appelle pas VIP mais bon ...
Par ailleurs si tu postes 500 messages même bidons sur ce forum tu auras le même statut.
Moi je me contente de donner l'info nécessaire à la résolution de ton problème. Que tu sois dubitatif ou pas, franchement je vois pas le sens de ta réponse. A vous dégoûter de vouloir aider...
Et puisque l'on parle de seo , virer les "chiffres" des urls revient à ne plus fournir à prestashop le moyen de savoir ou l'on veut aller.
Comme ce topic semble virer au post contestataire anti-prestashop, et que des réponses concrètes ne semblent pas satisfaire l'intéressé,
puis comme je ne suis en rien affilié à la Team Presta et que je ne dois rien à personne,
je me permet de dire que les plaintes et remarques du genre de celles qu'on trouve ici ne font pas avancer le schmilblick, bien au contraire, et que beaucoup semblent oublier ici que leur boutique tourne parfois depuis des années pour 3 francs six sous d'investissement et que rien ni personne pourtant ne les a forcé à utiliser cette solution plutôt qu'une autre.
Je sais pas ce qui m'a pris de ramener ma pomme de ce côté du forum : j'aurais été bien mieux inspiré de m'abstenir.

Share this post


Link to post
Share on other sites

Bonjour Broceliande ( et effectivement pas VIP) mais j'ai répondu un peu vite!!
ce petit mail en privé pour répondre a ton dernier post.. Milles excuses si tu as pris mon terme 'dubitatif ' pour toi mais celà ne t'était en aucune manière adressé !! c'était de la façon de faire les mises a jours que je parlais...

Au contraire pour ce qui te concerne j'ai bien apprécié et appliqué tes solutions avec réussite!!
Et non, je ne suis pas un anti-Prestashop et bien au contraire je trouve cette boutique très bien ... c'est justement pour ça que l'on en demande toujours plus! ;)

comme quoi les messages écrits peuvent des fois être mal interprétés ! MEA CULPA! si je t'ai froissé, loin de moi cette intention!

Reste présent sur le forum !!! Merci

Share this post


Link to post
Share on other sites

Rassure toi il en faut plus que ça tout de même pour me froisser ;)
J'ai répondu globalement parce que ce que j'ai lu l'ensemble des posts du topic et que ça ma un peu titillé.
Si tu me relis tu verras que j'ai dis vous/vos , en m'adressant à un ensemble de personnes et donc personne en particulier.
Ce que je disais n'est pas d'ailleurs limité à ce topic ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More