Jump to content
Sign in to follow this  
besky

Avis sur 1.4.1 ? [résolu] (Bon pour prod en instal, mais gaffe au MAJ)

Recommended Posts

Bonjour,

Après ma malheureuse expérience avec la version 1.4.0.17 (bugs et compagnie) J'avoue avoir un peu de réticence à passer à la 1.4.1, bien que je salut tout de même la rapidité des développeurs pour avoir sorti une version corrigé aussi vite.

J'aimerais donc avoir des avis de personnes qui ont essayé. Êtes vous convaincus ? avez-vous rencontré des problèmes ?

Je remercie tous ceux qui prendront le temps de répondre à ce sujet et je pense que ça pourra aider bien des gens à faire le pas.

Bien cordialement,
Besky.

Share this post


Link to post
Share on other sites

bonjour pour ma part tout est ok commande produit etc....

petit bémol la navigation a facette tourne dans le vide

vais essayer de trouver une solution que je posterai ici si je trouve lol

sinon merci a toute l'équipe de prestashop %-P

Share this post


Link to post
Share on other sites

L'installation de la mise à jour sur un site local avant l'installation définitive sur ma boutique c'est très bien passé. Aucun problème tous les tests étaient satisfaisants.

Une fois installé sur ma boutique, c'était l'anarchie totale
• Dans le Back-Office à l’accueil et dans préférences->apparence j’ai le même message -> “L’onglet ne peut être trouvé”;
• Affiche d'articles sans image;
• Lenteur de consultation dans le Back-office;

A la vue des différents problèmes sur une boutique en exploitation, j'ai fait marche arrière en réinstallant l'ancienne version.
Pour le moment, j'attends les nouvelles corrections même si les nouvelles fonctionnalités sont très sympathiques. Dommage, mais je ne peux pas me permettre d'avoir une boutique plantée même momentanément.

A suivre

Share this post


Link to post
Share on other sites

Merci pour vos deux avis malheureusement opposés ^^

Quelqu'un ou quelques-uns auraient-ils aussi un avis à donner s'il vous plais pour compléter l'avis de Gomosloca et Mxfree ?

Share this post


Link to post
Share on other sites
L'installation de la mise à jour sur un site local avant l'installation définitive sur ma boutique c'est très bien passé. Aucun problème tous les tests étaient satisfaisants.

Une fois installé sur ma boutique, c'était l'anarchie totale
• Dans le Back-Office à l’accueil et dans préférences->apparence j’ai le même message -> “L’onglet ne peut être trouvé”;
• Affiche d'articles sans image;
• Lenteur de consultation dans le Back-office;

A la vue des différents problèmes sur une boutique en exploitation, j'ai fait marche arrière en réinstallant l'ancienne version.
Pour le moment, j'attends les nouvelles corrections même si les nouvelles fonctionnalités sont très sympathiques. Dommage, mais je ne peux pas me permettre d'avoir une boutique plantée même momentanément.

A suivre


J'ai exactement le même problème : Tout est OK en local, mais la pagaille en live !

"onglet ne peut être trouvé". J'ai pourtant essayé plusieurs fois, j'ai bien mis le lien du site "live" dans SEO, mais rien à faire, il me manque la moitié des fonctions du backup.

PS: cela arrive suite à une mise à jour 1.3.7.0 vers 1.4.1.0 . Lors d'une nouvelle installation, pas de problème.

Share this post


Link to post
Share on other sites

Pour résoudre le problème de la navigation a facette qui mouline:

Dans blocklayered.php

Ligne 263 il faut remplacer “new category” par “new Category”.
Et aussi remplacer les “ps_” par le préfixe de vos tables ou par ‘.DB_PREFIX.’ comme à la ligne 266.

Et après ça marche nikel ;)

Share this post


Link to post
Share on other sites
Pour résoudre le problème de la navigation a facette qui mouline:

Dans blocklayered.php

Ligne 263 il faut remplacer “new category” par “new Category”.
Et aussi remplacer les “ps_” par le préfixe de vos tables ou par ‘.DB_PREFIX.’ comme à la ligne 266.

Et après ça marche nikel ;)


oui je confirme ca marche nickel encore merci beaucoup

:-)

Share this post


Link to post
Share on other sites

excellent !! les "mises à jour stables" :coolsmile:
moi je dois encore me tapper un diff manuel vu que les 25 devs prestashop ne trouvent pas le temps de le faire.

D'ailleurs je me demande si c'est pas un contrat entre presta et les agences partenaires pour permettre de facturer plusieurs centaines d'euros pour une mise à jour ! keep the business up !

Share this post


Link to post
Share on other sites

un diff ? peut-tu être plus explicité s'il te plais BigZ.

Merci pour toutes vos réponses :)

Share this post


Link to post
Share on other sites
excellent !! les "mises à jour stables" :coolsmile:
moi je dois encore me tapper un diff manuel vu que les 25 devs prestashop ne trouvent pas le temps de le faire.


Sont ils au courant? Il est bien indiqué à plusieurs endroits du forum que le seul endroit ou ils consultent les rapports de bugs sont sur le tracker. Tu sais si le bug y est mentionné ?


D'ailleurs je me demande si c'est pas un contrat entre presta et les agences partenaires pour permettre de facturer plusieurs centaines d'euros pour une mise à jour ! keep the business up !


Je vais m'empresser de remplir ma candidature si tu dis vrai !


Franchement je sais pas si c'est l'effet rebond de ma semaine ou si j'en ai pas tout simplement assez de lire des trucs pareils. Je l'ai déja dit ailleurs aujourd'hui mais là je confirme: d'habitude je traîne pas de ce côté ci du forum, et je me suis dit que ça pouvait être intéressant... Pas sûr que je vais continuer ma lecture.

Share this post


Link to post
Share on other sites

salut,
diff est le nom d'un programme unix qui permet de lister les différences entre deux fichiers ( http://pwet.fr/man/linux/commandes/diff )
c'est en gros la seule solution que je connaisse pour trouver les différences entre deux versions - il existe d'autres programmes similaires un peu plus user friendly biens sur -; et en déduire les patchs les patchs à appliquer. Heureusement, depuis l'intégration de l'override, cela simplifie un peu la tache ( les modifications sont appliquées dans des fichiers séparées ); cependant cela n'empechera pas de devoir relire et comparer toute fonction surchargée, tout ca en devinant dans quelle optique telle ou telle modif à été faite.

Une solution donnée par de nombreux logiciels open source dans le web est de fournir les patchs sous forme de rechercher / remplacer accompagnés de commentaires explicatifs; mais ca prends un peu de temps à faire.

Bref l'upgrade peut etre un gros travail etant donné le manque d'infos de presta; un e-commercant desireux de mettre a jour sa boutique n'y arrivera sans la détruire qu'avec l'aide d'un developpeur, qui ne travaillent pas souvent gratos. Après, pour nous c'est cool, ça fait du boulot, mais de manière générale je trouve pas ca très correct...

Share this post


Link to post
Share on other sites

Bonjour Broceliande, je n'ai pas vu ton avis sur la v1.4.1 qu'en penses-tu personnellement ? As tu observé des bugs ?

Merci encore à tous pour vos commentaires, cependant pourrait-on se concentrer s'il vous plais sur la V1.4.1 de sorte à savoir si elle est plus stable que la v1.4.0.17 et si tous les bugs ont été corrigés.

Merci encore.

Share this post


Link to post
Share on other sites

Bonjour à tous,

Je ne viens pas donner mon avis, juste renforcer la question du post qui m'interesse vivement, sur la nlle version 1.4.1.
Avez vous vu des bugs ou est ce vraiment stable ?
En effet je me tate pour changer ma boutique pour passer d'une ancienne version 1.1.0.5 à la 1.4.1...

Merci

Claire

Share this post


Link to post
Share on other sites

hello,
des bugs sont signalés juste au dessus... la 1.4.2 est pour dans 20 jours, et la 1.5 pour dans un mois et demi.

Ya plus qu'a choisir ! ( sic ... )

Share this post


Link to post
Share on other sites
Bonjour Broceliande, je n'ai pas vu ton avis sur la v1.4.1 qu'en penses-tu personnellement ? As tu observé des bugs ?

Merci encore à tous pour vos commentaires, cependant pourrait-on se concentrer s'il vous plais sur la V1.4.1 de sorte à savoir si elle est plus stable que la v1.4.0.17 et si tous les bugs ont été corrigés.

Merci encore.


Salut Besky , je vais te le donner ;)
J'ai vu des tas de personnes pester sur ces forums que la 1.4 mettait trop de temps à sortir..
Aujourd'hui elle est sortie et bien là, et je vois les mêmes crier au scandale parce que celle-ci comporte encore des bugs.
Ca n'a aucun sens.
Il y a eu une réécriture incroyable pour la 1.4 , et se balader dans le code est de plus en plus agréable.
Je n'ai pas constaté de bug majeur propre à justifier de ne pas passer à la 1.4
Les bugs sont le lot de toutes les applications. Ils sont quasi inévitables et sont faits pour être corrigés non ?
Il y a de meilleurs retours lorsqu'une version stable est releasée, c'est un fait.

La Team (dont je ne fais absolument pas partie je précise, gare aux malentendus...) aurait très bien pu décider de lancer une période de 'feature freeze', il s'agit d'une période parfois longue durant laquelle une application est testée et débuggée et plus aucune fonctionnalité ajoutée.
Dans ce cas forcément, à terme , l'application n'a plus aucun bug connu...

Compte tenu de la demande pressante, je crois que ce choix n'aurait plu à personne dans la communauté, toujours à l'affût de la moindre petite fonctionnalité en plus.
Pour moi la team fait donc le choix d'aller de l'avant, et ne pas stagner.

Cette 1.4.0.17 suivie de la 1.4.1 sont à mon goût une avancée nécessaire et de de bonne facture.
Je n'hésiterais pas à upgrader les sites de mes clients pour gagner en performances, en souplesse et en fonctionnalité.

Quant aux bugs relatés ça et là, je n'en ai vu aucun de réellement majeur ne trouvant pas sur le forum une réponse rapide.
Parallèlement, je le répète , il est largement expliqué que la Team ne prend en compte (en théorie car nous ne sommes vraiment pas hyper disciplinés là dessus) que les bugs reportés sur le tracker, et c'est logique : l'outil est adapté, et fait pour ça ... Le forum ne s'y prête pas.

J'ai trois migrations réussies en 1.4 à ce jour et aucun regret à l'horizon de la part de mes clients.

Je génère certes mes maj d'export depuis le svn, sur lequel je reporte également les deux ou trois correctifs que je peux trouver utiles (en attendant qu'ils soient déja corrigés).

Voilà en gros mon ressenti à ce jour : content de passer à quelque chose de plus frais.

Share this post


Link to post
Share on other sites

Je pense que chacun est conscient de la pression que subit la team et je le répète ils font un boulot de très bonne qualité, je ne critique donc pas leur bonne foie ni même leurs compétences, je ne critique pas l'application, les bugs sont monnaie courante pour toutes les applis, c'est normal rien n'est parfait.

Cependant il est normal selon moi de se poser la question de savoir si oui ou non la version en cours jugée "stable" par la team est utilisable en prod sans aucun bug majeur comme les problèmes avec paypal, le panier qui se vide avant d'avoir pu confirmer la commande, ou des petites choses comme ça qui certes ne sont pas de gros bugs en terme de fonctionnement mais pour une boutique en prod qui perd peut-être 200€ par jour à cause de petits bugs comme ça, faut reconnaitre que c'est ballot.

En ce qui concerne le tracker, personnellement je ne suis pas un familier de ce genre de choses et en plus de ça c'est en anglais uniquement (à moins que j'ai loupé quelque chose) sans quoi je remonterais volontiers bon nombre de bugs constatés. Je pense qu'une petite explication du fonctionnement serait de bon goût :)

Si effectivement aucun bug majeur (donc empêchant la boutique de faire de l'argent) n'a été constaté jusqu’à maintenant je pense que la conclusion de ce sujet est que la version 1.4.1 est réellement stable et utilisable en production. Tout de même faites la mise à jour en local dans un premier temps je pense que ça vaut mieux pour anticiper les éventuels problèmes avec les modules ou les thèmes.

Si personne n'y voit d'objection d'ici demain soir je rajouterais "[Résolu] Version 1.4.1 utilisable en prod" pour que chacun puisse en être informé.

Bonne soirée à vous et bonne fête de pâques, mangez pas trop de chocolat :-p

Cordialement, Besky

Share this post


Link to post
Share on other sites

Bonjour,
Il reste toujours des petits bugs qui sont plus souvent liés aux upgrades qu'à la dernière version.
Tous les cas ne sont pas testés, Par exemple:
la secure_key de la table customer bloque le paiement par chèque en passant de la 1.3 à la 1.4.
Je viens de remarquer une erreur SQL en passant de la 1.4.0.17 à la 1.4.1.0, parce que le cas où le bloc categorie n'est pas installé, n'est pas pris en compte !!

Pour trouver l'erreur, c'est compliqué pour les non dev.!!

J'ai remarqué un dysfonctionnement sur la page produit, qui ne provoque pas de bug,, mais il y a appel aux hooks avant que toutes les informations produit ne soient initialisées dans smarty, ce qui manque de logique !!
Par conséquence si je veux afficher le produit et sa déclinaison dans un popup au moment de l'ajout au panier, avec le hook productAction, avec le fichier original ça ne marche pas.
Il suffit de déplacer une instruction, je l'ai signalé dans le tracker en Novembre, je l'ai signalé pendant le barcamp.
et c'est encore le cas avec la dernière version, c'est agaçant!
J'ai fait la modification et il n'y a pas de problème, j'avais joint le fichier à ma demande.

Share this post


Link to post
Share on other sites
hello,
des bugs sont signalés juste au dessus... la 1.4.2 est pour dans 20 jours, et la 1.5 pour dans un mois et demi.

Ya plus qu'a choisir ! ( sic ... )


Bonjour

les avis sont très interressant, je vais donc attendre avant de faire des essais car assez de temps perdu avec la 1.4.0.17.
La 1.5 dans 6 semaines ? Et la 1.4.1 a encore des bugs ?
Sans commentaire !
Cordialement

Share this post


Link to post
Share on other sites

Bon ben je vais attendre je crois
Par contre j'espere que les upgrade fonctionnerons correctements
Merci

Share this post


Link to post
Share on other sites

Bonjour,
Je suis nouveau sur Prestashop donc directement passé à 1.4.1, malheureusement j'ai des ralentissements énormes (40 à 50 secondes) dans certaines pages du backoffice. Voici le post en cours : Lenteurs backoffice
Si une bonne âme ou un pro pourvait m'éclairer...

Merci

Share this post


Link to post
Share on other sites
Bonjour,
Je suis nouveau sur Prestashop donc directement passé à 1.4.1, malheureusement j'ai des ralentissements énormes (40 à 50 secondes) dans certaines pages du backoffice. Voici le post en cours : Lenteurs backoffice
Si une bonne âme ou un pro pourvait m'éclairer...

Merci


bonjour malheureusement cela peut provenir de ton hebergeur ou de ton choix d'hebergement.
trop d'utilisateur ici font des economies sur le prix des hebergements
cordialement

Share this post


Link to post
Share on other sites

bonjour malheureusement cela peut provenir de ton hebergeur ou de ton choix d'hebergement.
trop d'utilisateur ici font des economies sur le prix des hebergements
cordialement


Je suis sur un serveur dédié... cf le l'url de mon post : ici

Share this post


Link to post
Share on other sites

bonjour malheureusement cela peut provenir de ton hebergeur ou de ton choix d'hebergement.
trop d'utilisateur ici font des economies sur le prix des hebergements
cordialement


Je suis sur un serveur dédié... cf le l'url de mon post : ici


tu peux faire un essais avec ça : http://tools.pingdom.com/fpt/

afin de voir ce qui est lent

si cela peut t'aider

Share this post


Link to post
Share on other sites

Oui, j'ai essayé la page d'accueil se charge en 7.9 seconds.
Mais ce n'est pas là qu'est mon pb, c'est le backoffice...

Share this post


Link to post
Share on other sites

Bonjour,

Essai d'activer l'affichage des erreurs sur ta page il est possible qu'un script qui plante fasse ralentir considérablement ton site.

Pour cela:

Dans le fichier "Config>Config.inc.php"

une des premières lignes :

assigner le paramètre 'on' à 'diplay_errors', comme ceci :

@ini_set('display_errors', 'on');

Après si lorsque tu navigue sur ton site tu vois des erreurs apparaitre il te suffira de chercher comment les résoudre ou bien quel module provoque l'erreur et le désactiver.

Pense bien à désactiver l'affichage des erreurs une fois que tu les as constatée, sinon ça les affichera aussi à tes visiteurs.

Cordialement,
Besky

Share this post


Link to post
Share on other sites

pour moi tout est ok en mise a jour a part mon panier qui pointe vers un lien https://ssl.monsite/commande?step=1 et du coup me donne une page d'erreur , du coup ma boutique n'est pas fonctionnelle et c'est très embêtant !! j'ai beau chercher je trouve pas de soluce !

Share this post


Link to post
Share on other sites

Bonjour onon59

Quelle url devrait-il mettre normalement ?

Share this post


Link to post
Share on other sites

J'attends avec impatience la version 1.4.2 : sur infomaniak en mettant l'allemand comme langue par défaut sur une installation toute fraiche + URL rewr. activé ça bug :/ (le .htaccess apparemment).

En installant simplement en version allemande ça a également buggé dans mon cas (et pour ceux qui se poseraient la question, je connais relativement bien les tutos d'install-config PS/infomaniak).

Share this post


Link to post
Share on other sites

Nous sommes passé d'une 1.2.4 hyper stable et adaptée à la 1.4.1. Pas de bugs importants, le plus gros problème vient des secure_key qui sont plus utilisés dans les nouvelles versions (table cart par exemple) et pas toujours renseignés dans les vieilles.

La plupart des problèmes rencontrés pour les MAJ ne concernent pas le coeur mais les thèmes et les anciens modules. Faire une MAJ vers la 1.4.x nécessite l'utilisation d'un thème et de modules adaptés. On touche ici à la problématique du développement communautaire de modules et de thèmes dans un environnement où les versions du core changent vite et en profondeur. Lorsqu'on achète ou on récupère un module, il faut avoir à l'esprit qu'il ne sera pas immédiatement compatible avec les nouvelles versions (et quelques fois, il ne le sera jamais !). Il faut donc se préparer à éventuellement devoir s'en passer ou en racheter un nouveau si on est pressé de faire des MAJ. Après, il y a aussi le choix du thème. On a opté pour un thème assez épuré avec très peu d'images en CSS et dans les TPL, facile à maintenir et à faire évoluer.

Pour les lenteurs, je ne comprends pas. Notre page d'accueil est en grade A sur Yslow et on a gagné 1 bonne seconde en temps réel de chargement des pages (de 1.8s en moyenne à 0.8s). Les nouvelles fonctions de cache et de compression sont de vrais merveilles !! Faites un tri drastique des modules et virez tous ceux qui sont trops anciens. Un peit truc qui aide bien, c'est de surveiller ses 404. Souvent les lenteurs sont dues à des appels à des pages ou des médias non disponibles.

Share this post


Link to post
Share on other sites

Moi je vous conseillerais (au moins) d'attendre la version 1.4.2 en raison de pas mal de bugs encore présents.
J'abandonne l'idée de faire la mise à jour sur la 1.4.1.
Déja le sixième rapport de bug que je fais en une dizaine de jours -_-'

Par contre je reconnais que l'équipe est très réactive donc l'attente ne devrait pas être trop longue avant d'avoir une version 1.4 au top ^^

Share this post


Link to post
Share on other sites

je peut vous dire que la version 1.4.2 sera plus efficace et qu'il vaut mieux attendre cette version !!elle ne va pas tarder ;)

Share this post


Link to post
Share on other sites

J'ai reçu moi aussi la version 1.4.2 mais n'ai pas eu le temps de la tester. Pouvez-vous nous faire un topo sur les nouveautés ?

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

Prestashop son sur sur mon site pour essayer de résoudre les problèmes. Ils M'on envoyer la 1.4.2 par mail afin de la tester avant la sortie. J'ai donc essayer de mettre ma boutique sur 1.3.7 sur cette version, mais j'ai encore eu de pb de MAJ. Bug bug bug.... comme quand j'avais tenter avec 1.4.0. A ce moment là je suis revenu sur 1.3.7. J'espère qu'ils vont trouver une solution (déja 24h qui penche dessus). sinon je retenterai de revenir sur 1.3.7

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More