Jump to content

[Fermé] Erreur 500 à la connexion au back-office


Recommended Posts

Bonjour,

J'ai mis à jour mon site de Prestashop 1.6 à Prestashop 1.7 et depuis impossible d'accéder au back-office.

J'ai effectué l'upgrade en local sur WAMP. 

La partie Front s'affiche à peu près correctement. (Il me reste à mettre à jour les modules.)

La partie Back par contre m'affiche le formulaire de connexion et quand je valide "POUF" : 
"Cette page ne fonctionne pas

Impossible de traiter cette demande via localhost à l'heure actuelle.

HTTP ERROR 500"

Je suis en mode dev et les messages d'erreurs s'affichent bien sur le front mais rien sur le back.

La console de Chrome me dit Failed to load resource: the server responded with a status of 500 ()

Du coup je suis allée chercher un message d'erreur dans les logs :

[2021-03-11 13:08:08] doctrine.DEBUG: SELECT name FROM ps_module WHERE active = 1 [] []
[2021-03-11 13:08:08] translation.WARNING: Translation not found. {"id":"Successful deletion.","domain":"AdminNotificationsSuccess","locale":"fr-FR"} []
[2021-03-11 13:08:08] translation.WARNING: Translation not found. {"id":"The selection has been successfully deleted.","domain":"AdminNotificationsSuccess","locale":"fr-FR"} []
[2021-03-11 13:08:08] translation.WARNING: Translation not found. {"id":"Successful creation.","domain":"AdminNotificationsSuccess","locale":"fr-FR"} []
[2021-03-11 13:08:09] translation.WARNING: Translation not found. {"id":"Successfully signed in to PrestaShop Addons.","domain":"AdminModulesNotification","locale":"fr-FR"} []
[2021-03-11 13:08:09] translation.WARNING: Translation not found. {"id":"The root category of the shop %shop% is not associated with the current shop. You can't access this page. Please change the root category of the shop.","domain":"AdminCatalogNotification","locale":"fr-FR"} []
[2021-03-11 13:08:09] php.CRITICAL: Maximum function nesting level of '256' reached, aborting! {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Maximum function nesting level of '256' reached, aborting! at C:\\wamp64\\www\\*******\\classes\\cache\\Cache.php:700)"} []
[2021-03-11 13:08:14] request.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalThrowableError: "Maximum function nesting level of '256' reached, aborting!" at C:\wamp64\www\*******\classes\cache\Cache.php line 700 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Maximum function nesting level of '256' reached, aborting! at C:\\wamp64\\www\\*********\\classes\\cache\\Cache.php:700)"} []
[2021-03-11 13:08:23] php.CRITICAL: Fatal Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 15106048 bytes) {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\OutOfMemoryException(code: 0): Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 15106048 bytes) at C:\\wamp64\\www\\*********\\var\\cache\\dev\\twig\\0c\\0ccb8ec178abb9900947f9b1684fb9b4db9d623791dae59236673cc940001528.php:93)"} []

 

(Les "****" sont volontaires)

Si quelqu'un comprend le problème, je suis preneuse 😃
 

1.PNG

2.PNG

 

Edited by Allyta
Suppressions d'infos pas pertinentes (see edit history)

Share this post


Link to post
Share on other sites

Dans le doute j'ai augmenté les permissions sur post_max_size et upload_max_size. 

L'erreur 500 est toujours la même et dans mes logs

[2021-03-11 14:04:16] translation.WARNING: ...
[2021-03-11 14:04:16] php.CRITICAL: Maximum function nesting level of '256' reached, aborting! {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Maximum function nesting level of '256' reached, aborting! at C:\\wamp64\\www\\*****\\classes\\cache\\Cache.php:700)"} []

 

4.PNG

Edited by Allyta (see edit history)

Share this post


Link to post
Share on other sites

Je suis déjà en _PS_MODE_DEV_', true
J'ai bien des erreurs qui s'affichent sur le Front mais rien en Back.

Sinon pour essayer de corriger le problème de limite j'ai désactivé XDebug et la memory_limit de mon WAMP (c'est pas bien, je sais).
Même en lui donnant toute la mémoire qu'il souhaite je tombe sur une "OutOfMemoryException" (Enfin un message d'erreur au moins !)
Visiblement j'ai une fuite de mémoire à la connexion au back-office...

5.PNG

(+) recursiveTab est appelée dans admin****>functions.php et dans classes>controller>AdminController.php6.PNG

Edited by Allyta
Ajout infos.php (see edit history)

Share this post


Link to post
Share on other sites

  • 1 month later...

Je ferme ce topic car j'ai appris qu'un prestataire a réalisé une modification directement sur les fichiers Prestashop de base (les fameux "ne pas toucher").

Je recommence un site de zéro en 1.7 en copiant juste les données de la BDD.

  • Like 1

Share this post


Link to post
Share on other sites

Allyta, "juste" copier les bases de données n'est pas forcément la meilleure méthode.

Passer de 1.6 à 1.7 n'est pas une simple mise à jour. Il existe des modules qui vous permettent de migrer vos données de votre ancien presta vers une install propre 1.7.

 

Share this post


Link to post
Share on other sites

  • Allyta changed the title to [Fermé] Erreur 500 à la connexion au back-office

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More