Jump to content

Recommended Posts

könnt Ihr mir sagen wo ich unter 1.7.7.1 den Hinweis zzgl. Versandkosten unter dem Artikel einstellen kann?  Ich finde es nirgends. Im Modul Offizielles Modul zur DSGVO-Compliance konnte ich es auch nicht finden.

Danke

Share this post


Link to post
Share on other sites

Hallo, habe das gleiche Problem.

das Modul habe ich von Github heruntergeladen. Bei der Installation kam die Meldung, Falsches ZIP Format. Hab danach alles entpackt und mit WINRAR neu gepackt, gleiches Problem. hat wer eine Lösung für das Problem?

 

Share this post


Link to post
Share on other sites

ja, du must das Modul mit doppelclick entzippen, dann den Ordner so umbenennen wie die php.ini datei und dann wieder kompremieren, dann geht es

Gruß Rolf

 

Share this post


Link to post
Share on other sites

ok, damit hat es geklappt, aber was hat das Modul in meinem Shop angestellt?

Nur kurz die Dinge die mir auf die Schnelle aufgefallen sind:

Versandkosten wurden falsch angezeigt. Button zum einstellen bei den Versanddiensten ob mit oder ohne MWST fehlte.

Beim Testkauf hat sich der Warenkorb nach Versandauswahl aufgehängt.

Habe das Modul wieder deinstalliert und das zuvor erstellte Backup wieder eingespielt.

Gibt es eine andere Möglichkeit den Versandkostenlink auf die Artikelseite zu bringen?

 

Share this post


Link to post
Share on other sites

das passierte bei mir auch (nach den Versandkosten) ich habe im paypal Modul die Rundung befolgt und das paypal modul resettet. Danach war alles ok. Bei mir stand dann  statt zzgl. Versandkosten irgendetwas anderes. Da war ein Übersetzungsfehler drin und ich habe es auf zzgl. geändert. 

Share this post


Link to post
Share on other sites

In einem anderen Thread hattest du auch einen Anzeigefehler, auf meinen Hinweis auf eine möglicherweise falsche PHP-Version (bei 7.4 gibt es solche Fehler) hast du nicht geantwortet.

Share this post


Link to post
Share on other sites

rictools: In einem anderen Thread hattest du auch einen Anzeigefehler, auf meinen Hinweis auf eine möglicherweise falsche PHP-Version (bei 7.4 gibt es solche Fehler) hast du nicht geantwortet.

PHP Version ist 7.3 .

 

yolodrolo: nein, direkt bei Versanddienst der MWST Button. hier habe ich bei DHL 19% und nettopreise angegeben und Deutsche Post Brief steuerfrei Bruttopreise.

dieser Button war weg. Als ich das Modul wieder deinstalliert und das Backup eingespielt hatte, war der Button wieder verfügbar.

mwst Versanddienst.jpg

Share this post


Link to post
Share on other sites

PHP 7.3 wird ab Prestashop 1.7.7.0 offiziell unterstützt. Nach deinem Screenshot läuft bei dir übrigens diese Version und nicht wie im ersten Beitrag angegeben 1.7.7.1, bei so einer Nuller-Version muß man immer von überdurchschnittlich vielen Bugs ausgehen. Du bist ganz sicher, daß nicht PHP 7.4 läuft (manchmal ändert der Provider so etwas ungefragt)?

Um das Rechtssicherheitsmodul kommt man in Deutschland (sofern man nicht vieles individuell ändern will) kaum herum, entspricht ohne denn der letzte Bestellschritt den hiesigen Vorschriften (Produktauflistung mit Endpreis direkt vor dem "Kaufen"-Button)?

Bei den Spannen fällt mir auf daß die erste nicht mit "0" beginnt, das könnte evtl. zu Problemen führen.

Und dann schreibst du, beim Paket habest du inkl. MwSt. ausgewählt und beim Brief steuerfrei, das geht so nicht, entweder du mußt dem Kunden MwSt. berechnen oder nicht (ob die Post dir MwSt. berechnet oder nicht hat damit nichts zu tun).

Share this post


Link to post
Share on other sites
4 hours ago, rictools said:

Du bist ganz sicher, daß nicht PHP 7.4 läuft (manchmal ändert der Provider so etwas ungefragt)?

ja, da bin ich sicher, da ich die PHP Versionen bei allen Domains selbst einstelle.

 

4 hours ago, rictools said:

Und dann schreibst du, beim Paket habest du inkl. MwSt. ausgewählt und beim Brief steuerfrei, das geht so nicht, entweder du mußt dem Kunden MwSt. berechnen oder nicht (ob die Post dir MwSt. berechnet oder nicht hat damit nichts zu tun).

berechnet wird bei mir als Kleinunternehmer keine keine MWST. das Kleinunternehmermodul ist installiert. Die MWST bei den Versanddiensten habe ich vorsorglich  eingegeben, für den Fall das ich mal aus der Kleinunternehmerregelung rausfalle. Demnach muß ich da die MWST nochmal ändern.

Share this post


Link to post
Share on other sites

Als Kleinunternehmer brauchst du den MwSt.-Button ja nicht, vielleicht wurde der durch eine entsprechende Einstellung oder ein Modul ausgeblendet. Ich denke du mußt dich schon entscheiden ob im Shop MwSt. verwendet wird oder - als Kleinunternehmer - eben nicht, ein Durcheinander führt eben zu einem Durcheinander ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More