Jump to content
  • 0

Fehler 500 im Module Manager


Question

Hallo,

ich bin neu und habe einen Fehlermeldung seit Gestern im Prestashop Backend.

Und zwar kommt bei mir auf einer weißen Seite die Fehlermeldung:

An Error Occurred_Internal Server Error.pdf

Quote

 

Oops! An Error Occurred

The server returned a "500Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

 

 

Wenn ich auf Module Manager in Module klicke. Ich habe zuvor einige Module aktuallisiert, aber die können mir doch nicht das Backend bzw. die Prestashop Modul-Seite zerschießen? 

Meine Prestashop Version ist: 1.7.6.0

 

Hilft hier evtl. ein Update des Shops? Dies würde aber viel Zeit in Anspruch nehmen. Außerdem komme ich nicht auf den Modulmanager um das 1-Click Update durchzuführen.

Welche Informationen werden zur Fehlerbeseitigung noch benötigt?

Über Hilfe würde ich mich freuen.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Aktiviere den Debug Modus oder schau in deine Server Logs um die Details des Fehler zu sehen.

Share this post


Link to post
Share on other sites
  • 0

În den Logs bekomme ich folgende Fehlermeldung, die zum Fehler beigetragen haben könnten: 

 

Ausnahmefehler im Modul fsafterbuyshop bei upgrade: Error sent by Addons. You may need to be logged.

Wird ein Login im Afterbuy-Addon benötigt? Und wenn ja, wie soll ich das Addon öffnen, wenn ich Module-Manager nicht öffnen kann.

Edited by AW IT (see edit history)

Share this post


Link to post
Share on other sites
  • 0

Der Fehler hat damit nichts zu tun. Aktiviere den Debug Modus, öffne dann den Modul Manager und schau welcher Fehler angezeigt wird.

Share this post


Link to post
Share on other sites
  • 0

Wenn ich den Debug Modus starte, ist meine Backend Oberfläche weg und ich habe eine Liste von Logs.  (Siehe Bild unten). Das ist doch nicht normal?

 

Ich kann im Backend nicht mehr navigieren. Auch der Shop (Frontend) ist dann nicht mehr erreichbar. Ich glaube, dass mein Debug Modus nicht richtig funktioniert. Der Shop scheint beschädigt zu sein.

 

image.thumb.png.9dec7ba5198c8fe8605e12c79896e313.png

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, AW IT said:

Das ist doch nicht normal?

Doch genau das ist der Sinn vom Debug Modus, es macht die Fehler in deinem Shop sichtbar.

Leider ist die Meldung abgschnitten so dass die Ursache nicht klar erkennbar ist. Ich denke auch nicht dass dies die Meldung vom Modul Manager ist!?

Share this post


Link to post
Share on other sites
  • 0

Danke schon mal für die Hilfe.

Vielleicht stehe ich auf dem Schlauch, aber das was du in meinem Post siehst, ist alles. Ich sehe keine Navigation, wo ich den "Module Manager" sehe oder suchen könnte.

Wenn ich unten auf die rote "500" klicke, dann gelang ich auf eine neue Übersicht. Hier ist dann auch eine Navigation, aber ich wüsste nicht, wo ich meine Fehlermeldung finde.

image.thumb.png.32c0afc619b3f05b916aec19ed4760fb.png

 

Unter Logs finde ich folgende Fehler

image.png.7489059686a5208b1627da6aedcdf374.png

Share this post


Link to post
Share on other sites
  • 0

Du nutzt PHP 7.4 - Prestashop 1.7.6. ist nur bis PHP 7.2. kompatibel!

Mit abgeschnitten meine ich den unteren Teil deines ersten Screenshots, da kann man ja noch runter scrollen.

Share this post


Link to post
Share on other sites
  • 0

 

Quote

Du nutzt PHP 7.4 - Prestashop 1.7.6. ist nur bis PHP 7.2. kompatibel!

Ich glaube nicht, dass es an der PHP Version liegt. Ich war kurz zuvor noch im Modul Manager und habe Plugins aktualisiert.

 

On 2/24/2021 at 1:05 PM, JBW said:

Mit abgeschnitten meine ich den unteren Teil deines ersten Screenshots, da kann man ja noch runter scrollen.

Ich weiß, aber es war ein wirrkürliche Exception. Ich wollte nur zeigen, dass ich keine Navigation zum Modul Manager sehe.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, AW IT said:

Ich glaube nicht, dass es an der PHP Version lieg

Deine Version wird immer wieder zu Fehlern führen, viele davon sind hier im Forum dokumentiert

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Okey. Danke. Beim Hoster kann ich nur runter auf 7.3 und damit klappt es dann auch nicht.

Dann muss ich Prestashop aktualisieren, aber wie mache ich das, wenn der Modulemanager nicht funktioniert?

Edited by AW IT (see edit history)

Share this post


Link to post
Share on other sites
  • 0

Es ist etwas Zeit vergangen, aber nun beschäftige ich mich wieder mit meinem Problem 🕵️‍♂️.

Dein Link mit meiner Domain und admin-Bezeichnung führt zu keiner gefundenen Seite:

Quote

 

 

 

Seite nicht gefunden

Der Controller AdminSelfUpgrade fehlt oder ist ungültig.

 

 

So langsam bleibt wohl nur den Shop neu aufzusetzen....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More