Jump to content

Recommended Posts

Salut. 

J'ai mis a jour ma boutique de 1.7.5 à 1.7.7 pour bénéficier des mise à jours de sécurité.

J'ai remarqué que mon backoffice est assez lent et je n'arrive pas à ajouter des modules en cliquer sur le bouton prévu à cet effet. Lorsque je mets en mode debug j'ai cette erreur :

Une idée du problème ?

Merci

Url de la boutique : http://bit.ly/3jbaHxV

Capture d’écran 2021-01-31 à 22.35.33.png

Share this post


Link to post
Share on other sites

Vous avez une override de la classe Cart.php qui n'a pas été écrite pour cette dernière version et qui est donc non conforme. Vous devez mettre à jour le module qui l'a générée. (le nom du module concerné doit être écrit au début du fichier d'override)

image.png.4f10b5cc6b4cc8e396618a7e8c23d070.png

Share this post


Link to post
Share on other sites
59 minutes ago, Eolia said:

Vous avez une override de la classe Cart.php qui n'a pas été écrite pour cette dernière version et qui est donc non conforme. Vous devez mettre à jour le module qui l'a générée. (le nom du module concerné doit être écrit au début du fichier d'override)

image.png.4f10b5cc6b4cc8e396618a7e8c23d070.png

Merci. je vais regarder ca

 

Edited by @rthur (see edit history)

Share this post


Link to post
Share on other sites

Donc module orderfees_shipping à mettre à jour ou corriger cette partie de l'override par:

        $shipping_cost = parent::getPackageShippingCost(
            $id_carrier,
            $use_tax,
            $default_country,
            $product_list,
            $id_zone,
	    $keepOrderPrices
        );

 

Share this post


Link to post
Share on other sites
25 minutes ago, Eolia said:

Donc module orderfees_shipping à mettre à jour ou corriger cette partie de l'override par:


        $shipping_cost = parent::getPackageShippingCost(
            $id_carrier,
            $use_tax,
            $default_country,
            $product_list,
            $id_zone,
	    $keepOrderPrices
        );

 

En fait le module est compatible avec la 1.7.7.0 pas la 1.7.7.1. 

Par contre je rencontre un autre souci. Lors de la mise a jour je mets mon serveur en php 7.3 comme recommandé par prestashop et il m'affiche cette erreur. Vous avez une idée comment le résoudre? Merci beaucoup

 

Capture d’écran 2021-01-31 à 22.31.14.png

Share this post


Link to post
Share on other sites
Just now, Eolia said:

Là c'est un problème de droits sur votre répertoire

Perso je resterai en PHP7.2^^

D'accord merci mais ca ne va pas causer de problèmes sachant que prestashop recommande php 7.3 ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More