Jump to content

Problème "The CSRF token is invalid. Please try to resubmit the form."


Recommended Posts

Bonjour, j'ai un problème sur mon site prestashop installé sur un VPS ovh.

Lorsque je souhaite créer un produit avec plusieurs déclinaisons j'ai ce message d'erreur qui s'affiche :

"La valeur du paramètre "max_input_vars" dans le fichier PHP.ini doit être élevée à 2000 afin de permettre la soumission du formulaire produit."
et celui la aussi :

"The CSRF token is invalid. Please try to resubmit the form."
"This value should not be blank."

Pourtant les champs sont remplis. J'ai essayé de modifier le .htaccess en ajoutant max_input_vars = 10000
mais rien ne change.
Lorsque je supprime beaucoup de produit d'un coup aussi, j'ai plusieurs messages d'erreur qui s'affiche dans le prestashop.

Version : prestashop 1.7.6.4

Informations sur votre serveur Linux #1 SMP Debian 4.19.37-5+deb10u1 (2019-07-19) x86_64

Version du logiciel serveur : Apache/2.4.38 (Debian)

Version de PHP : 7.3.19-1~deb10u1

Limite de mémoire : 128M

Temps maximal d'exécution : 30

Taille max. pour envoi de fichiers : 20M


Merci de m'aider s'il vous plait ^^

Screenshot_2021-01-22 Produit • b612(1).png

Screenshot_2021-01-22 Produit • b612.png

Share this post


Link to post
Share on other sites

Le 22/01/2021 à 1:53 AM, 1118061_1508432898 a dit :

sur un VPS ovh

Bonjour

En fonction de l'application que vous avez installé sur votre vps (  cPanel, plesk etc..)   vous pourrez y modifier votre "max_input_vars" ou sur votre fichier php.ini 

Le 22/01/2021 à 1:53 AM, 1118061_1508432898 a dit :

Version de PHP : 7.3.19-1

Votre version prestashop 1.7.6.4 n'est compatible avec votre version PHP

Voici le Tableau de compatibilité PHP

https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/#php-compatibility-chart

Share this post


Link to post
Share on other sites

  • 4 months later...

Hi, try this.

Create a file in document root where is index.php, called ".env" or if you almost have a file called .env, add a new line whith this content:

_TOKEN_=disabled

 

Greetings

Share this post


Link to post
Share on other sites

Le 05/06/2021 à 9:23 AM, raultamayomate a dit :

Hi, try this.

Create a file in document root where is index.php, called ".env" or if you almost have a file called .env, add a new line whith this content:

_TOKEN_=disabled

 

Greetings

respect-langue-forum.jpg.e6c1749980f2e76cd47d15e6e68cf809.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More