Jump to content

HTTP 200 - parsererror while installing modules on first install


Recommended Posts

I am installing Prestashop for the first time, i tried it on 2 webserver, i always get this error. It always failes at 67% (Install Addons modules). Any ideas?

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Whats your PHP version? Why are you installing such an old Presta version? 1.7.5.1 has known security bugs

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello,

I'm having a problem there too. Same step. First of all, addons.prestashop is using a `x-frame-options` header with value `allowall`. Don't know if this is a thing, but I installed a firefox plugin which ignore this header.

But, with or without this plugin, I got another error (_PS_MODE_DEV_ enabled).

1: HTTP 200 - parsererror -
Fatal error: Uncaught Symfony\Component\Debug\Exception\ClassNotFoundException: Attempted to load class "Ps_accounts" from the global namespace. Did you forget a "use" statement? in /var/www/html/modules/ps_checkout/vendor/prestashop/prestashop-accounts-auth/src/Handler/ErrorHandler/ErrorHandler.php:63 Stack trace: #0 /var/www/html/modules/ps_checkout/vendor/prestashop/prestashop-accounts-auth/src/Handler/ErrorHandler/ErrorHandler.php(106): PrestaShop\AccountsAuth\Handler\ErrorHandler\ErrorHandler->__construct() #1 /var/www/html/modules/ps_checkout/vendor/prestashop/prestashop-accounts-auth/src/Installer/Install.php(59): PrestaShop\AccountsAuth\Handler\ErrorHandler\ErrorHandler::getInstance() #2 /var/www/html/modules/ps_checkout/ps_checkout.php(166): PrestaShop\AccountsAuth\Installer\Install->installPsAccounts() #3 /var/www/html/src/Adapter/Module/Module.php(249): Ps_checkout->install() #4 /var/www/html/src/Core/Addon/Module/ModuleManager.php(302): PrestaShop\PrestaShop\Adapter\Module\Module->onInstall() #5 /var/www/html/ in /var/www/html/modules/ps_checkout/vendor/prestashop/prestashop-accounts-auth/src/Handler/ErrorHandler/ErrorHandler.php on line 63

Tested with php 7.3.24 & 7.2.34 : same error.

Bypassing this step, I can access admin, but cannot activate HTTPS, ignore tutorial...

Any idea ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More