Jump to content
Sign in to follow this  
toto77

[RESOLU] prestashop hébérgé sous OVH et base de données en local

Recommended Posts

Bonjour,

Tout d'abord désolé pour le titre, je ne savais pas quoi mettre pour être explicite.

Je suis chez OVH, je viens de finir ma boutique prestashop en local avec wamp, il y a donc une base de données nommé boutiqlingeri que j'ai exporté : boutiqlingeri.sql

Malgré mes recherches et le guide OVH, je ne comprend pas comment importer ma base de données. J'ai pensé qu'il fallait créer une base de données depuis le manager OVH mais du coup elle n'a pas le même nom que celle en local et je ne vois toujours pas comment l'importer...

Je désespère :-( si quelqu'un peut m'expliquer simplement comment faire...

Ah oui une dernière chose, dans le ftp et le dossier www il y a un index.html, .htaccess et un dossier img, dois-je les laisser ou les supprimer?

J'ai du mal avec ça, j'ai peur de faire des bêtises :-(

Mille merci pour votre aide!

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour,

pour la base de données il faut simplement vous connecter avec phpmyadmin sur ovh à votre nouvelle base de données et importer le fichier sql exporté de votre base local.

Puis configurer le fichier settings.inc.php pour se connecter à la nouvelle base sur votre espace d'hébergement ovh.

Vous pouvez effacer les fichiers.

Share this post


Link to post
Share on other sites

Bonjour,

Merci.

Le le fichier settings.inc.php je le trouve où exactement?

Par contre j'ai cette erreur sur le site :
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /homez.428/winkyz/www/index.php on line 29.

Le index.php :

<?php
/*
* 2007-2011 PrestaShop 
*
* NOTICE OF LICENSE
*
* This source file is subject to the Open Software License (OSL 3.0)
* that is bundled with this package in the file LICENSE.txt.
* It is also available through the world-wide-web at this URL:
* http://opensource.org/licenses/osl-3.0.php
* If you did not receive a copy of the license and are unable to
* obtain it through the world-wide-web, please send an email
* to license@prestashop.com so we can send you a copy immediately.
*
* DISCLAIMER
*
* Do not edit or add to this file if you wish to upgrade PrestaShop to newer
* versions in the future. If you wish to customize PrestaShop for your
* needs please refer to http://www.prestashop.com for more information.
*
*  @author PrestaShop SA 
*  @copyright  2007-2011 PrestaShop SA
*  @version  Release: $Revision: 1.4 $
*  @license    http://opensource.org/licenses/osl-3.0.php  Open Software License (OSL 3.0)
*  International Registered Trademark & Property of PrestaShop SA
*/

require(dirname(__FILE__).'/config/config.inc.php');
ControllerFactory::getController('IndexController')->run(); // ligne 29




Si quelqu'un peut m'aider, je ne comprend pas.

Mille merci

Bonne journée

Share this post


Link to post
Share on other sites

Avez vous activé le php5 dans votre htaccess comme expliqué dans la FAQ de OVH ?

Share this post


Link to post
Share on other sites

Bonjour,

Entre temps j'ai pensé à ça, je viens de le faire (juste avant de voir votre message).

Un dernier soucis (j'espère que ça sera le dernier), à la place de mon site j'ai : Link to database cannot be established.

Comment établir ce lien? je suis perdu...

Mille merci!

Share this post


Link to post
Share on other sites

il faut adapter le lien vers votre base de données ovh dans le fichier /config/settings.inc.php

Share this post


Link to post
Share on other sites

Merci! J'y suis presque :

Cette première ligne : define('__PS_BASE_URI__', '/boutiquelingerie/'); : C'est quoi au juste, dois-je modifier le nom ?

define('_DB_NAME_', 'nomDeBaseCreer'); : C'est bien le nom de ma BDD créé sous OVH ?

define('_DB_SERVER_', 'localhost'); : ici, je remplace par le serveur OVH (reçu par email) ?

define('_DB_USER_', 'root'); : ici, c'est le nom d'utilisateur?

define('_DB_PREFIX_', 'ps_'); : préfixe je laisse comme ça?

define('_DB_PASSWD_', ''); : ici c'est le mot de passe de ma base de données?


Je préfère demander que faire des bêtises...

Merci beaucoup!

Share this post


Link to post
Share on other sites

Re encore moi,

Je viens de remplir les champs comme je l'ai dis plus haut.

Avec pour première ligne : define('__PS_BASE_URI__', '/');

Maintenant j'ai ce message : Requête SQL pour les sous-domaines invalide

ça veut dire quoi?

Mille merci

Share this post


Link to post
Share on other sites

Je viens de me rendre compte qu'il n'y avait pas toutes mes tables dans la BDD...

Ce que j'ai fais, j'ai supprimé les tables et j'ai ré-importer ma BDD et là il y a bien toutes mes tables.

Par contre quand je vais sur mon site : www.winkyz.com , j'ai cette url qui s'affiche ensuite : http://localhost/fr/ avec comme message :

Not Found

The requested URL /fr/ was not found on this server.


Quelqu'un peut me dire d'où ça vient?

Mille merci!

Je désespère! Toute l'après-midi pour mettre un site en ligne...

Share this post


Link to post
Share on other sites

le fichier htaccess ?
ou dans la base de données table ps_configuration peut être que l'url est inscrite dans une valeur.

Share this post


Link to post
Share on other sites

Je viens de regarder dans ma base de données, le fichier sql :

J'ai 2 lignes comme ceci:

(155, 'PS_SHOP_DOMAIN', 'localhost', '2011-04-02 13:13:11', '2011-04-02 13:13:11'),
(156, 'PS_SHOP_DOMAIN_SSL', 'localhost', '2011-04-02 13:13:11', '2011-04-02 13:13:11'),

Il y a localhost... Peut-être qu'il faut modifier non?

Merci

Edit : dans mon .htaccess, il y a par exemple :

RewriteRule ^api/?(.*)$ /boutiquelingerie/webservice/dispatcher.php?url=$1 [QSA,L]

boutiquelingerie : le nom de mon dossier en local : wamp/www/boutiquelingerie/

Peut-être faut-il mettre le nom de domaine à la place? dans mon cas winkyz.com ? non?

Share this post


Link to post
Share on other sites

peut être qu'il faut essayer pour le savoir comme cela vous pourrez nous le dire.

mais modifiez le directement dans votre base et pas dans votre export sql

Share this post


Link to post
Share on other sites

Je ne trouve pas où c'est dans ma BDD pour modifier... Je met le nom du serveur de ma BDD OVH?

J'ai du mal avec les BDD et ça me fait peur...


Merci

Share this post


Link to post
Share on other sites

Bonjour,

Je crois que tout est de ma faute! Je fais tout de travers!

En local, dans le backoffice dans la rubrique préférences /SEO&URLS;Quand je vais dans configuration des urls:

Répertoire contenant PrestaShop : /boutiquelingerie/

Nom de domaine : localhost

Nom de domaine SSL : localhost

Du coup c'est pas bon du tout, n'est ce-pas?

Donc je dois remplir ces champs comme ceci? (je préfère demander votre avis pour être sûr) :

- Répertoire contenant PrestaShop : je met rien ou je met un / (slash)? car je suis directement dans le www, je passe pas par un dossier

- Nom de domaine : www.winkyz.com

- Nom de domaine SSL : C'est ce que j'ai reçu par email ? (je mets l'url qu'il m'indique) :

(SSL
---

Vous avez la possibilité d'accéder à votre espace de manière sécurisée.
Pour cela, vous pouvez vous connecter via cette URL :


Merci de me confirmer si c'est bien comme cela qu'on rempli? Si le problème vient vraiment de là, je vais m'en vouloir à mort!

Mille merci!

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour,

Non finalement il n'y avait pas besoin de modifier...

Bonne journée

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More