Jump to content

Problema su qualsiasi modifica dall'ftp


Recommended Posts

Salve, qualcuno potrebbe spiegarmi come mai, qualsiasi modifica effettuo ai file di prestashop tramite ftp, non vengono visualizzati? 

Se lavoro in locale vedo ogni cosa, lavorando e modiificando su ftp praticamente non vedo nessun cambiamento.

Vi faccio un esempio: modifico nel footer il testo "ecommerce software"? Non cambia nulla. Stessa cosa anche modificando un semplice sfondo.

Non è un problema di cache, ho provato a ripulire dalla sezione prestazioni del backoffice.

Uso il tema classic e la versione 1.768.

Grazie a chiunque mi dia una soluzione

Share this post


Link to post
Share on other sites

Ciao,

ammesso che i permessi su tutti i file e cartelle siano correttamente impostati ( 755/644) quando lavori sulla piattaforma devi tenere cache smarty e cache css/js disattive. Una volta fatto le modifiche rigenera il template se hai operato sui tpl....e ctrl+f5 per pulire anche le cache del browser!

 

ciao

  • Like 1

Share this post


Link to post
Share on other sites

Grazie per la risposta Fabry,

le cache sono disattivate e ho tutti i permessi per modificare i file. 

Ho appena riprovato, per esempio, cambiando "ecommerce software" in basso, nel footer del tema (classic/templates/_partials/footer.tpl)

Salvo, rifaccio l'upload per riaprire il file e le mie modifiche ci sono... ma non vengono "calcolate",come se li leggesse da un'altra parte.

sto impazzendo credimi.

Non pretendo neanche una riga di codice ma mi piacerebbe capire il problema. Grazie comunque

PS per rigenerare il template cosa intendi?

Edited by Luca883 (see edit history)

Share this post


Link to post
Share on other sites
Just now, Fabry said:

Da parametri avanzati > performance entra nell'area cache..dove la disattivi c'é "template compilation# ecco..prova a forzare la compilazione

già provato..

Share this post


Link to post
Share on other sites

Ciao, non credo che i permessi siano il tuo problema. Potresti provare a cancellare le directory /var/cache/dev e /var/cache/prod per eliminare la cache manualmente.

Ma più banalmente potrebbe essere che il tema, o il singolo file, venga overraidato. Potresti verificare

  • Like 1

Share this post


Link to post
Share on other sites

Sinceramente non saprei indicarti come prevenire l'override del tema; ad ogni modo, nel caso di override dovresti avere un altro tema installato (che appunto fa l'override del primo) e attivo con una gerarchia simile in themes/nome_tema/templates

Share this post


Link to post
Share on other sites
10 hours ago, Luca883 said:

è come se leggesse il tema altrove, ma le modifiche risultano all'interno del file. Sono due settimane che sto impazzendo..

Grazie cmq per l'aiuto

Ti lascio il mio Skype di seguito; se mi condividessi lo schermo con TeamViewer potrei cercare di aiutarti velocemente perché dovrebbe essere abbastanza banale la risoluzione di questo problema.

Scrivimi pure, senza impegno.

live:.cid.14fa0a0481aabe5f

 

  • Like 1

Share this post


Link to post
Share on other sites

Grazie mille per la disponibilità, quando avro' la possibilità ti offriro' una birra un giorno :)

ho trovato il problema. Su aruba ho sia l' hosting linux che windows. L'ftp mi mostrava quello windows, quindi le modifiche erano "inutili", proprio perche' avevo caricato l'installazione di prestashop tramite softaculos di linux.

Grazie a tutti ragazzi, siete forti!

Edited by Luca883 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More