Jump to content

[gelöst] Produkt-Block in E-Mailtemplates


Recommended Posts

Hallo zusammen,

 

ich habe in einem Shop (v.1.7.6.8) die E-Mail-Templates angepasst bzw. eher übersetzt. Irgendwann habe ich gemerkt, dass die E-Mails für die Bestellbestätigung nicht korrekt angezeigt werden, da die Artikeldaten (Menge, Artikelnummer, ...) oberhalb des Tabellenkopfes angezeigt werden (s. Screenshot order-conf-falsch).

Da ich den Shop in der Zwischenzeit auf einen anderen Server kopiert und auch daran weitergearbeitet habe, bin ich auf den alten Server (hier war noch nichts überstetzt und die Mails im Ursprungszustand) und habe dort mal die nicht übersetzten Mails angesehen und siehe da: Die Anzeige war korrekt, es wurde zuerst der Tabellenkopf und darunter korrekt die Inhalte, also die Produkt-Daten angezeigt.

Ich habe nun die Übersetzung bzw. das alte HTML-File verwendet und auf den neuen Server kopiert. Komischerweise hat sich zwar die Übersetzung angepasst (alles auf Englisch) aber nicht die Anzeige der Artikel. Hier wurden wieder zuerst alle Daten der Produkte angezeigt und danach erst der Tabellenkopf.

Mir ist aber auch aufgefallen, dass in der E-Mail aus dem PS Alert-Modul zur Benachrichtigung des Verkäufers die (new-order.html) die Anzeige fehlerhaft ist obwohl ich diese Übersetzung gar nicht geändert hatte.

Kann mir jemand sagen woran das liegen könnte? Bzw. was benötigt ihr um mir zu helfen?

 

Grüße

Sebastian

 

PS: Bitte nicht am Grundpreis stören, hier teste ich gerade Anpassungen zur automatischen Grundpreisberechnung und habe es noch nicht im Legal-Compliance-Modul angepasst.

order-conf-falsch.png

Edited by SebastianU
Thema gelöst (see edit history)

Share this post


Link to post
Share on other sites

Ok, ich konnte das Thema lösen, indem ich mal einen ganz neuen Shop aufgesetzt habe (gleiche Version) und den gesamten mails-Ordner aus dem Root in meinen Shop kopiert habe.

Ich vermute, dass ich hier während der Übersetzung im Backend innerhalb des WYSIWYG-Editors irgendwas an der Formatierung geändert habe ohne es zu merken, da der gesamte Produkt-Block auch nicht mehr in diesem Editor sichtbar ist. In früheren Versionen war ja im E-Mail Template unterhalb der Kopfzeile eine Zeile mit der Variable {$productd} sowie eine Zeile mit der Variable {$discounts} zu sehen, was nun nicht mehr der Fall ist.

Ich habe die Übersetzung jetzt direkt innerhalb des HTML-Files durchgeführt um die Formatierung nicht schon wieder durcheinander zu bringen und es hat funktioniert, damit ist das Thema für mich gelöst.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More